Sign in with
Sign up | Sign in
Your question

External Maxtor HDD not recognized

Last response: in Storage
Share
February 14, 2009 10:24:07 PM

Hi,
I have an external Maxtor 750GB HDD that isn't being recognized by my computer. I tried different USB ports and wires but it didn't work. I also tried it on a different system without any luck. On my XP pc, it isn't showing up as a volume or a disk. When I plug it in, the computer recognizes that I have a USB device imputed, and when I go to Safely Remove Hardware, I can see that there is something there but it doesn't have a letter assigned to it and like I said i can't even see it as a disk when i run diskpart.exe. However on my Windows 7 pc, I can see the disk, but it isn't assigned a volume letter. Is there anyway for me to get the hard drive to be recognized without going to diskpart.exe on the Windows 7 pc and cleaning the disk?
a b G Storage
February 15, 2009 5:04:29 AM

Go into Disk Management (Administrative Tools), right-click on the drive and assign a drive letter.
February 15, 2009 12:46:26 PM

MrLinux said:
Go into Disk Management (Administrative Tools), right-click on the drive and assign a drive letter.


I can't see it on Disk Management
Related resources
February 15, 2009 2:06:52 PM

just an update

Hi everyone,
I have a problem with a Maxtor One Touch 4 Plus 750GB External HDD. The computer doesn't recognize the hard drive. Here are the things that I already tried doing:
1. Plug it into different USB ports
2. Use different USB wires
3. Plug it into different computer/OS
After that, I was able to see it on my Windows 7 system but not on my XP Professional. The XP professional wont list it as a disk or a volume in disk management and I couldn't find it when I ran diskpart.exe from the cmd command prompt. It wouldn't show me the disk when I did list disk.
After that I tried on my Windows 7 system. It still wouldn't show me any disk when I ran diskpart.exe however I could see a disk from disk Management. When I tried to initialize the disk, it kept on giving me a "Media is write protected error". So, I tried to clean the disk, because even though I couldn't see it on diskpart.exe, I could still select it. When I tried to clean the disk, it just gave me an error saying that the system's info. wasn't up to date.

Any thoughts on what might be the problem? I would really like to resolve it w/o reformatting the hard drive b/c I have important data that I dont want to loose.
February 15, 2009 5:18:26 PM

Found this on a review:

"I still don't understand why it happens, but in all cases that my partition had disappeared, it was simply hidden to the OS.

*Something* changes the NTFS partition type on this external drive to "Hidden NTFS" (17), so of course your OS won't normally see it.

Changing the partition type with a partition/disk editor back to normal NTFS (07) has solved this problem for me so far, in all occasions."

If neither system can read files on it, it might be also be defective drive. I have a Western that had that happen after I backed up everything on it (next time I tried to use it, nothing could be read). I still have the drive since WD sometimes does replacement deals called "customer loyality" (for broken drives out of warrenty).

The case looks hard to open, but if all else fails, you can insert it as a SATA drive into a computer (try all else first ;)  ). This is another "despiration" move that you might try if the data is more important than the case.

I'd like to point out I don't really know what I am talking about, but I like to try and pretend.
!