Sata HDD won't format? Cable Failure?

I just bought a WD 640gb Green hard drive. My mobo and vista both see the hard drive, I initialized it in disk management, but when I try to format it, it says, "Format failed to complete", or something like that. So I run Western digitals diagnostic tools and all I get is "Cable Test Failed", and it won't run any tests.

I tried setting my mobo to raid and normal, tried two different cables, two different sata ports, jumpers on every setting on the hard drive and I get the same Cable Test Failed.

Is it the drive? or should I try something else. I would just assume it's the drive, but windows and my motherboard can both see the drive, and if I do the long format, it goes all the way to 100% then says "Format failed to complete" Any help would be great, thanks.
5 answers Last reply
More about sata format cable failure
  1. I would return the drive.
  2. jitpublisher said:
    I would return the drive.

    So there's nothing else that could be affecting it? I just wanted to make sure I try everything before I send it back, thanks.
  3. Have you tried a DIFFERENT cable??? Both data and/or power?
  4. doormatderek said:
    Have you tried a DIFFERENT cable??? Both data and/or power?


    I have tried two different sata cables and different power cables and it made no difference.
  5. Try it on another system if you have a extra system.
    It could be a bios issue.
Ask a new question

Read More

Hard Drives Cable Format Storage