Sign in with
Sign up | Sign in
Your question

Invalid Block Adress in Burning Programs

Tags:
  • DVD Writers
  • Burner
  • Storage
Last response: in Storage
Share
February 17, 2009 9:46:03 PM

Hi guys, I have a really annoying issue with my DVD-Writer (Pionner DVR-215D Black SATA).

When I try to burn a DVD, the programs are starting the burning and after the lead in and on 1 or 2 percent of the main track burning the programs shutdown the burn and get me the Invalid Block Error message.
This is the 6th in the row that is busted (media). Also tried with other burning programs and got the same issue.

After some digging on the net, I saw that was happening a lot but on the IDE connection because of the DMA that is switching in PIO mode. For me there is a just a choise from the controller in the system to switch between DMA and motherboard BIOS auto switching (nVidia nforce 780a in AHCI mode).

This is the first time that this happening for me with this dvd-r, the media are tested correctly and worked ok for months. And I just got a fresh install for the OS. Any ideas on the problem?

And if anyone can read the damn error log from nero, I will bind them in the next post.

Thanks.

More about : invalid block adress burning programs

February 18, 2009 12:22:33 AM

turn off ahci mode, try ide mode. if that doesnt work there should be settings on the property page for the drive in device manager, you might get the pio / dma settings there. bit rusty on this now, but hope it helps
February 18, 2009 7:40:08 AM

This problem never occured before (with exactly the same configuration), and for the AHCI part, I can't disable it because I need all of the 6 SATA slot and if I disable it to get an IDE Mode I will lose the two them that are only supported in AHCI and will have to format and reinstall again (long story on the controller and the chipset...).

I have switched to force DMA (even if they're isn't any PIO mode, lol) and also updated the firmware of my drive and I will try again when I got some time.

I will update on the test after.

Thanks anyway.

Still iuif anyone can read the nero logs please post me.
Related resources
February 18, 2009 10:33:34 AM

Damn it, I forced the DMA, tried a direct burn from image and the super slowest speed but still nothing.

Starting to think on Hardware failure, I will update later.
February 18, 2009 8:49:56 PM

I was thinking about Hardware Failure (for my DVD-R), but after a few check I can see (mostly guess as always) that this is some kind of conflict between the hardware and the drivers (the driver doesn't report anything but the system log talks a lot about the drive [as a service and not as a device].

I already checked the nero version compatibility for my drive (already worked before the last format), but you never know. As well as a bunch of other burning programs and in Linux too.
Also the nVidia drivers (downloaded again and reinstalled).
Tried a lot of different media (DVD-R, DVD-RW,etc).
Tried to burn files as well as images.
And checked all the SATA connection.
Dig a lot on the net also and found out that the nVidia drivers are causing the problem (the drives where RMA, but the problem was still there).
And as I can see there isn't any mention on the update history of the Crosshair BIOS of a solved problem with nVidia controller issue.

To mention: The drive can read and rip any kind of media disc but cannot burn.

I will update if there is something new.
February 18, 2009 9:49:07 PM

Try using the SAME disc, i've had burns fail on me before and been able to get it to 'resume' somehow...
February 19, 2009 8:12:32 AM

My brain is dead, I had also tried this but the discs are simply useless...
This is like the damn thing do it on purpose, he fails exactly at the start of the burning (1 or 2 percent).
I did stop the litteraly speaking burning money by using a rewritable.

I'm starting to get pissed...
February 19, 2009 10:12:17 AM

Ok guys, there is the solution to my problem.

For anyone, that has the same symptoms and a SATA Controller from nVidia go to the device manager and get on the IDE/ATA ATAPI Contoller and on the nVidia nFOrce Serial ATA Controller go to the configuration of each port and force the DMA (don't let the mobo choose automaticly [uncheck it], and point to DMA use only).Don't search the option in the BIOS, it's non-existing.

Attention, even if you turn the DMA on your optical drives, you have to force also the DMA on your Hard Drives. The reason is for the burning software to use their buffer they use BURST readings from the Hard Drives.

This is error doesn't go for CD's and reading DVD's because of the slow speed needed for these actions.

As I never thought that the New Gen of Hard Drives (SATA), would even give me a choise for PIO mode, I didn't even bother to check it.

[Problem Solved]
February 19, 2009 10:13:08 PM

My joy is no more there. My drive can burn again but now at low speed...
Still searching now again.
February 23, 2009 9:55:34 PM

If I recall I had Nero installed, Demon Tools (latest version) and I might have had Alcohol 120% installed as well. Basically what I done was uninstall any programme that could be used to emulate discs so I uninstaled Alcohol and Demon Tools and I left a blank DVD in the drive and rebooted. When I got back into Windows Nero picked up my blank DVD and was able to write to it.

To be honest your issues are different to mine, your would appear to be hardware related mine were software related. The only thing I can suggest after reading your post is trying another SATA slot. You say your running on ahci, a lot of newer motherboards (from 2006) come with two independent SATA controllers on board so you could try one of them (if you have one).
February 24, 2009 8:09:43 AM

JeanLuc, thanks for your reply, and yes it looks like hardware issue as I format again after a superbad trojan and unlimited virus as they follow (12 hours of scan in a linux sandboxed system, jesus), the internet security didn't caught this one or too young to be recognise. So no emulation issue on a clean system. :p 


I have already contact Pioneer Support (the optical drive one) to see if they have a solution to this or going for warranty. I hope they contact me as fast as they can, because I'm in serious need for space. :sweat: 

And the problem is that I could put my PC to pieces and rebuild but as I have serious and urgent work to do, this is not a real option for the next 2 months.

As for the AHCI, the drive doesn't run on the complementary SATA controller (my system is on 4+2 SATA slots support, but as it look it's one controller). So for IDE and RAID mode, only 4 SATA slots run, but if I use the AHCI, I get access to 2 SATA slots more (and the drive isn't on this ones).

I'm out of ideas here, and I'm really tired of this.
I will post after the Pioneer Support answer, if they do...
March 3, 2009 9:35:46 PM

One more solution (hope that's the one), but my driver definitively writes now (and at all speed). After a flash that occurred me, I tried to write the files from another hard drive on my system (copy and paste only).
And now the writer actually write, I think that the files (video for most of them, in UDP mode as they are quite large) in the first drive, were super fragmented (but I had even checked for defragmentation) or wrote on bad blocks (and also checked for disk surface errors).

So for now, my system is up and writing again normally. If this comes up again I will update (I really hope not).
So if you got a message as the following one in Nero log [SCSIStatus(x02) WinError(0) NeroError(-1064)], try to put the files that you want to write on another hard drive, but if you don't have one on an another partition.
March 31, 2009 9:20:22 AM

Just for the update... (Frustrating)

I got this issue once again, but now that I don't use uTorrent during the burning session, my drive writes again (with all the media that I use, and on all speeds).
July 7, 2009 5:46:34 PM

try to turn of your Kaspersy antivirus it can block your burn program to get to data on HD thats why burn program can burn only lead in (that is about 2%) and becaus it cant reach the data it can give you several errors like Illegal disc ir invaid data or like youm have! if you have no Kaspersky it can be other protection program/ it depends of way it protect your pc
July 15, 2009 12:17:25 AM

Here may be the answer of your problem:

On Vista I had "Invalid block address" problem for months. Sent 2 times for repair to Toshiba and the stupid staff insisted on reinstall Vista from scratch (restore from Toshiba disks).

while reading about DMA in this forum I got an idea. I disabled the DMA (although DMA should be enabeled) and my problem goes!! :wahoo: 
July 15, 2009 12:19:29 AM

Here may be the answer of your problem:

On Vista I had "Invalid block address" problem for months. Sent 2 times for repair to Toshiba and the stupid staff insisted on reinstall Vista from scratch (restore from Toshiba disks).

while reading about DMA in this forum I got an idea. I disabled the DMA (although DMA should be enabeled) and my problem goes!! :wahoo: 

Device Manager > IDE Channel Proerties > Advanced Settings > Uncheck "Enable DMA"
Anonymous
a b G Storage
November 30, 2009 3:49:33 AM

thanks man, your solutions a great help! :wahoo: 
!