Sign in with
Sign up | Sign in
Your question

Floppy Drive Trouble

Tags:
Last response: in Storage
Share
February 25, 2009 2:05:43 AM

I've seen dozens of threads on FDD problems, but I haven't seen an exact match for my problem described (or solved). Most ideas point to some kind of mobo problem, which would be weird since nothing else seems to have any problem.

Intel mobo/Intel Core2Quad6600 CPU
XP x64
3.5" FDD with 7 in 1 card reader capability (Ultra "brand").

The FDD shows up in BIOS, it spins during the BIOS part of startup, it shows in My Computer as A:.
It can't be accessed from My Computer, it says "insert disk". It doesn't work from XP installation after I press F6 to load RAID drivers, though I'm actually trying to load AHCI drivers to use the second set of 4 SATA connectors (0-3 are full).

In BIOS, Floppy Support has been Enabled & Auto, write protect has been both Enabled & Disabled and I've tried both 1.44 & 2.88, just in case. The light does not stay green, but the LED stays red to show it is ready for card reading, which does work since it's separate from the FDD function.
Also Device Manager shows no issues with it. No jumpers on the drive.

Some people talk about drivers, but even if a driver was needed for XP, it wouldn't be loaded for use in the installation process, would it?

More about : floppy drive trouble

February 25, 2009 2:35:12 AM

It sounds to me like the floppy drive simply doesn't work, it's not reading the discs. Alignment is critical on these units and one forced eject while the disc is being accessed is enough to kill it. Floppy drives don't require drivers since Bios supports it natively.
February 25, 2009 7:10:20 AM

This drive is a little over a year old, and rarely, if ever, used. Honestly, I can't remember ever actually using it, but I think I at least tried it at one point early on. I tried another 3.5", an older one, same result. I may try another cable, just to make sure that isn't it, even though that's unlikely.

Thing is, during the attempted reinstall of XP, it isn't even trying to access the drive, not even a split second delay, whereas from My Computer, it at least waits several seconds before giving the "install disk" message.

Once though, I tried getting a "new" 5.25" FDD to work, but it never did work right, maybe I did something to the FDD controller on the mobo. The cable I used with the A & B type connectors made the 3.5" inaccessible during this "test". Intel themselves claim the hardware and/or BIOS wouldn't recognize a 5.5" anyway, but I wanted to recover some old games from floppies.

Any way to test the FDD controller and see if it's any good?
Related resources
Can't find your answer ? Ask !
February 25, 2009 8:07:23 AM

It may seem daft, but have you made sure the cable is inserted the right way round?
Some FDD's made it very easy to connect back to front.
Can you try the drive in someone elses computer?
JB
February 25, 2009 9:45:49 AM

Absolutely. You'll see that kind of suggestion in every forum on FDDs. If the cable is the wrong way, which I tried purposely, the LED will stay green constantly. Also, BIOS will not recognize the drive the way mine does now that it is correct. And it's not as easy as it used to be since the power plug is above the pins for the data cable and one could have the red line towards the power plug.
February 25, 2009 9:59:21 AM

pastit said:
It may seem daft, but have you made sure the cable is inserted the right way round?
Some FDD's made it very easy to connect back to front.
Can you try the drive in someone elses computer?
JB


It's recognized in BIOS and shows in Explorer, so it's connected correctly, it just doesn't read the disc; so either the floppy drive is bad, OR the disc is bad, has the OP tried more than one floppy disc?
a b G Storage
February 25, 2009 10:54:41 AM

I dunno, if the BIOS detects it, it shows up in Windows, but will not read a disk, the drive is bad. You can buy another one for about $15.
February 25, 2009 10:13:10 PM

I did try an older drive to no avail, so if I were to have to buy another one, I would want another one with the card readers built in and that's a few more dollars, $20 - $30.

So I would want to find some way to make sure it is the drive and not the floppy controller.

Again, any way of testing the controller outside of trusting Device Manager?
a b G Storage
February 26, 2009 11:29:03 AM

Put a disk in it you have checked, and are postive it works in another computer.
If it don't work, then it simply don't work. What more do you want us tell you?
$20-$30, you can't even buy a tank of gas for that.
February 28, 2009 3:31:21 PM

I can't believe I didn't think to put the drive in the other computer that's sitting on my kitchen counter. But when I did, it didn't work, then I jostled it a bit, then it worked.

So I put it back in the main machine and it worked, then stopped working.

Then I found a 3rd FDD I had, put it in the main machine and it worked fine with several tries.

So then I'm trying to do the XP reinstall, using the F6 to load RAID/AHCI drivers and it acts like there's no disk in it again. I give up on that, go back into XP, and now the damn thing isn't working at all.

Could the machine be damaging the drives? Again, never had a problem with any of the other drives (4 SATA & 1 IDE).

-------------------------------------------------------------------------------------------------------------------------------------------

Update: I put the original drive into the second machine, and it works/doesn't work intermittently, so something damaged there.

So I picked up a new mobo on ebay, an ASUS P5Q-E GREEN. It solves both problems, it still has an FDD controller and it has 6 standard SATA controllers instead of 4 plus 4 apparently unusable ones (at least since I couldn't load drivers from the floppy). I'll still need a new FDD, but at least it shouldn't get damaged by the mobo.
!