Sign in with
Sign up | Sign in
Your question

x1950xt low performance

Last response: in Graphics & Displays
Share
February 15, 2008 1:52:19 AM

Hello everyone, I have searched and searched but to no avail.

I have a x1950xt 256mb PCIe graphics card made by Sapphire. I have VERY low performance coming from this card. I opened up Counterstrike: Source and turned off AA and AF. All the rates checked out. I have tried every possible setting combo with no luck. So in hope of fixing this problem, I tried many different versions of Catalyst drivers, and yes, I did uninstall the old ones before installing the next driver. I even tried using OMEGA's driver. No luck. I tried manually controlling AA and AF in ATT and CCC, no luck. So then I went on to swapping out my 2gb's of memory with brand new sticks, no luck. I checked my PSU's amperage on the 12v rails, i have 25 amps, and the PSU itself is a 550 watt. So that rules out lack of power. Now, I know CS:S is a CPU intensive game, but I do have a 3.5ghz P4, which also should be enough. I checked the temps of my system, and my mobo runs between 30 and 45 degrees celcius, and the gfx card itself runs at 50c steady. When attemping to play a game online in CS:S, it goes to about 60c and hovers around there. So basically, that means heat isnt an issue either. Getting a little more frustrated, I decided to remove my sound card to see if that would make a difference. No luck. Also, in case you were wondering, this IS a fresh install of Windows XP Pro, meaning there is no spyware or virii that could be bogging my system down. I have DirectX 9.0c.

So, I ask you, what is going on? I remember having a 9800 Pro that would run CS:S at 100 fps constant on medium, this card can't even do that.

What usually happens in game is the FPS would be around 80-90 when theres NO ONE around me, but as soon as one person approaches, the FPS drops down to 15-20.

System specs:

Windows XP Professional SP2
550w PSU
Seagate 250Gb SATA HDD
Asus P5GC-MX 1333 Motherboard (brand new)
3.5ghz P4 HT processor (LGA 775 if that matters)
2x 1gb 667 DDR2 RAM
Writemaster DVD+RW Optical Drive
ATi Radeon x1950xt 256Mb by Sapphire


Thanks in advance,
Chris
February 15, 2008 3:06:36 AM

use a 3rd party driver uninstaller here: http://www.guru3d.com/index.php?page=detonatorrip to completely uninstall previous nvidia drivers, then use ccleaner or glarys utilities to clean system and registry or use both to thouroughly clean your system then install the...Nvidia Omega Drivers 2.169.21 (Forceware 169.21) reboot, disk cleanup, defrag and try running your games again.

your p4 is not the problem, sounds like a previous driver install.

1 more thing check the bios to see what the pci-e slot is running @?
4x, 8x or 16x.

also, its been recommended to run catalists drivers for x1+ cards with drivers 7.6 and no higher.

im running a x1650pro 512mb 128bit agp card on 1 of my rigs with latest omega drivers with no problems on all games i throw at it. but when i used the ati drivers not only do they have a large foot print but theyre noticeable slower performing when it comes to games. w/omega u get quick loading small footprint and fast optimized for gaming. heres my sons rig:

p4 2.53
x1650pro
psu 250 watt!!!!!
ata100 250hd
soyo p4vga mb
1gb 2700 ddr

and this rig runs crysis cod4 and bf2 and all the games ive thrown at it fine enough for me at med settings 2xaa but at a resolution of 1280x1024.

so that thing u got about the powersupply dont worry its enough or u can check it here:http://www.extreme.outervision.com/

hope this helps.
February 15, 2008 3:30:01 AM

Maybe I'm just not thinking but... why would I want to use an Nvidia driver for my ATi card? and my PCI-e is running at 16x.
Related resources
February 15, 2008 3:52:49 AM

1. He assumed you had a previous Nvidia driver.

2. Have you used a 3rd party app to check if it's actually running at 16x? Get CPU-Z:
http://cpuid.com/cpuz.php
and post results.


3. What driver version are you running? As Naw-yi said, x1xxx cards might not work well with drivers past catalyst 7.6.
You can get Driver Cleaner Pro from here:
http://downloads.guru3d.com/download.php?det=745
Use it to wipe your drivers, then go to the ati website and get the 8.2 drivers:
http://game.amd.com/us-en/drivers_catalyst.aspx?p=xp/ra...
OR
the 7.6 drivers:
http://ati.amd.com/support/drivers/xp/previous/radeon/r...
OR
the Omega drivers:
http://www.ngohq.com/home.php?page=Files&go=cat&dwn_cat...

February 15, 2008 4:01:30 AM

Reading your #3, I am confused. You say I shouldn't use drivers past 7.6, yet you tell me to download 8.2. Anyway, I used cpuid to verify that it IS running at 16x.

I am using 6.12 right now, I'll try the 7.6.
February 15, 2008 4:38:16 AM

Alright, I just cleaned out anything possibly ATI driver related. I installed 7.6 and I successfully made my fps even worse. Same thing with 8.2. Any more suggestions?
February 15, 2008 10:28:37 AM

did you recently get the card?

could just be a faulty card.
February 15, 2008 10:55:52 AM

Run memtest86+ and check for errors.
February 17, 2008 4:10:59 AM

everything checks out fine. any more suggestions?
February 17, 2008 4:48:14 AM

don't rely on your temp mesurement tools..they can give you false information.

Download throttlewatch. And check if your CPU is not throttling down in speed to cool itself to the 60 degrees you see..
February 17, 2008 5:02:50 AM

alright so i downloaded it. what am i supposed to be seeing? throttle is at 0%...
February 17, 2008 1:00:52 PM

dt0cks said:
alright so i downloaded it. what am i supposed to be seeing? throttle is at 0%...



Play the game.. this will create heat and if there is a problem, you'll see it.
February 17, 2008 2:00:06 PM

Naw-yi said:
install the...Nvidia Omega Drivers 2.169.21 (Forceware 169.21)

[:mousemonkey:1] How on earth would that make an Ati card run better!
February 17, 2008 4:17:06 PM

Quote:
nvidia are so great they make better drivers for ati cards than ati do.

:lol: 
February 17, 2008 7:57:22 PM

no throttling under game load. cs 1.6 is exactly the same, with "fps_max 300" set, my fps stays around 60 and drops to 15-20 when theres other players on the screen.
February 17, 2008 9:23:13 PM

its off... i tried all the standard procedures.. im at a loss here. any other suggestions?
!