Sign in with
Sign up | Sign in
Your question
Closed

Can't get signal from DVI to LCD TV! TRIED FOR 2 MONTHS!

Last response: in Graphics & Displays
Share
February 15, 2008 2:02:28 AM

I have a 32 in LCD TV (that is my primary monitor)

No matter what I've tried...I cant get it to accept a signal from ANYTHING other than a VGA out. Can't use a DVI adapter. Guys...trust me...I've tried everything...dvi/vga adapters, different cards...different drivers...nothing. Low resolutions.. I see boot up and windows logo...then "No input" from screen as soon as windows kicks in. It works before I install drivers...once geforce drivers (Latest ones)are installed..."No input" I've tried two older drivers...same problem
I'm currently running 1366x768 custom using the VGA out from card. Works fine, but I'd love to fix this so I can move to a better card (8800 gt?). If I plug it into DVI out, screen goes black at windows start. I can see boot process fine. Once again, It works before I install drivers ...boots into windows at 1024x768
I install drivers...blam...same problem. I even purchased an ATI card...wiped NVIDIA Drivers off system, install latest ATI drivers......Boot up, and...and...NO SIGNAL. Same thing.

If you want to see everything I've tried, check this thread: http://forums.guru3d.com/showthread.php?p=2602304#post2...

I'm currently using a evga 7600 GT. TV is a Scott (Akai) LCT32SHA
(Windows sees it as "Plug N Play" Monitor)
NVIDIA control panel recognizes it as LCT32SHA correctly. Can anyone tell me what the deal is?
I've been trying to get this working for three weeks.
I really apreciate ANY help to get a DVI to work with this TV/ Monitor. THANKS!

More about : signal dvi lcd months

February 15, 2008 3:46:38 PM

So...no one can figure this out?


Sigh.
February 15, 2008 4:24:10 PM

There are one or two "implied" resolutions for DVI. In other words, the DVI spec stipulates that if you are connected via DVI, then the display device must support the implied resolutions. Check wikipedia, and then the official DVI spec site for details.

If your LCD doesn't support one of those, and it happens to be what the drivers default to when they start up in windows for the first time, then that could be the problem.

If you have another display device to connect to, I'd recommend connecting to that, setting a resolution you know your LCD will accept, and then switching over. Or, you could boot up in VGA mode and force 640 x 480 display if your LCD can display that (which it might, since it shows the boot sequence). Once in, you could use regedit to set / modify the default screen res in the registry (no, I don't know where it is... but I have a hunch it's in there somewhere), and then try doing a normal boot.

Best of luck.
Related resources
February 15, 2008 4:24:49 PM

Just some clarifications:

Post your system specs (motherboard, ram, OS, etc).

It works fine VGA-VGA, but not VGA-DVI or DVI-DVI?

Does every combination of output-input work in safe mode?

How did you do your driver removal? Hopefully you used a good driver removal tool.

Have you done an OS reinstall (XP 32 bit?), it may be easier just to start from scratch again and work up from there. Also make sure your chipset drivers are up to date and the MOBO BIOS is correctly configured.

a c 271 U Graphics card
a b \ Driver
February 15, 2008 4:27:37 PM

And what resolutions and refresh rates have you tried?
February 15, 2008 4:30:03 PM

TeraMedia said:
There are one or two "implied" resolutions for DVI. In other words, the DVI spec stipulates that if you are connected via DVI, then the display device must support the implied resolutions. Check wikipedia, and then the official DVI spec site for details.

If your LCD doesn't support one of those, and it happens to be what the drivers default to when they start up in windows for the first time, then that could be the problem.

If you have another display device to connect to, I'd recommend connecting to that, setting a resolution you know your LCD will accept, and then switching over. Or, you could boot up in VGA mode and force 640 x 480 display if your LCD can display that (which it might, since it shows the boot sequence). Once in, you could use regedit to set / modify the default screen res in the registry (no, I don't know where it is... but I have a hunch it's in there somewhere), and then try doing a normal boot.

Best of luck.


Very true, this is why an LCD TV is not technically a monitor. Have you tried a LCD monitor that supports the native DVI resolutions?
February 15, 2008 4:57:06 PM

This maybe the tell, Bad GTX...
...if I boot to a standard CRT monitor from DVI out, boots fine...looks great. I then swap cable to my 32 LCD...it works fine at any resolution.

That tell you guys how I might fix this without cable swapping every time I boot up?
a b U Graphics card
February 15, 2008 4:58:42 PM

I'm not 100% sure on this but my 7950GT/OC only came with DVI-Component adapter. As far as I know these cards did not have the HDMI capability.
If your tv has component you can run that way and still get the 720p that the tv is capable of.
Hope this helps.
February 15, 2008 5:10:19 PM

So how about booting with the monitor off and just turn it on when windows loads?
February 15, 2008 5:11:23 PM

Nope...wont work.
February 15, 2008 5:17:11 PM

On the nvidia control panel on display -> set up multiple displays there is a question mark with "my display is not shown in the list" clicking on that brings up a window with "force television detection at startup" tick box. Have you tried that?
February 15, 2008 5:19:00 PM

OOOhh No Haven't see n that oh BOY!
Wish me luck...here goes....


...nope....didn't work. Had to even boot into safe and remove drivers to boot up again. :) 
February 15, 2008 5:33:42 PM

You can go DVI to HDMI if your HDMI is video only. Most HDMI is set for video and audio, if this is the case your speakers will squeel because there wont be sound.

DVI is a digital signal and your VGA is analog so it wont work.

2 options for you.
1. Use DVI to HDMI if your HDMI in is Video only.
2. Get a card that has built in s/pdif so you can do DVI to HDMI with sound. This card or one like it would work. http://www.newegg.com/Product/Product.aspx?Item=N82E168...
February 15, 2008 5:45:19 PM

From my experience...If you have an HDMI on that TV, you wanna use it...

get a simple DVI to HDMI adapter and you'll be golden.
February 15, 2008 5:50:41 PM

> This maybe the tell, Bad GTX...
> ...if I boot to a standard CRT monitor from DVI out, boots fine...looks great. I then > swap cable to my 32 LCD...it works fine at any resolution.

Normally when a computer powers up, the video card sends a message on the DDC channel of each of its video connectors for any connected monitor to send EDID data back to the video card, which contains data that tells the video card what the specifications of the display are. The EDID includes manufacturer name, product type, phosphor or filter type, timings supported by the display, display size, luminance data and (for digital displays only) pixel mapping data.

When you power up, the video card needs to know which connector(s) to output video on, so it if it doesn't detect any EDID data coming in on the DVI connector it assumes there's nothing plugged into it so doesn't enable output on it. Most video cards in this case fallback to only sending output to the VGA connector so that monitors older than about 1994 that don't do EDID/DDC at all will still get a signal, as they are also all older than the DVI standard so must be connected via VGA.

Your post above strongly indicates that your TV is not doing EDID which is perhaps not surprising as its a computer monitor standard not a TV standard. Some older TV's even with a DVI connector don't do EDID. It may also just be that the DVI cable to your TV doesn't connect pins 6 and 7 which are the DDC clock and data line that the EDID data exchange happens on, so I'm guessing either you have a bad or cheap cable or your TV is old enough to not do EDID.

The reason your solution works if you boot up with another computer monitor, not your TV, then switch over, is that the video card is getting that initial EDID data from the monitor, that tells it that something is plugged in to the DVI connector so enables the signal output on it. Later on you can then plug in your TV and get the signal because the video card happens to not notice/care that you've diconnected the monitor and plugged in something else. It still thinks its sending image to the monitor when in fact its now going to the TV.
February 15, 2008 5:58:58 PM

Intersting.
Well the LCD TV I'm using is current (still being sold). The EDID/DDC problem might be the cause, though.
So there is no work around this, I'm guessing? I'm really not willing to keep a CRT next to my desk to swap cables every time I boot. With me limited to VGA out cards only, Looks like the fastest card I can use will be a 8600 GT. I've tried SLI with my current 7600GT...it was a no go too. Sigh.

Well thx for all the help guys.
If anyone know a faster card than an 8600gt (w/ VGA out), let me know
February 15, 2008 6:01:56 PM

If you're not using the same cable to connect your PC to your monitor as to connect your PC to your TV, try connecting your TV with the monitor cable as we know that cable works already. It may be the cable you're using to connect your TV is fubar for EDID.
February 15, 2008 6:16:22 PM

I had this issues Q1 last year. I will respond after only reading the first few posts, so sorry if I reoeat others comments.
1. get your TV manual out....and look at the accepted signals at each input.
2. set your PC up on a regular monitor
3. set your PC to the resolution of the desired input for the TV
turn off PC and swap the cable over to the TV.

This should solve this
also understand that lower end tv's have sometimes very limited input resolutions (not implying your is I am not sure) and therefore can be tricky.

good luck
February 15, 2008 6:19:17 PM

Any reason you dont want to use HDMI?
February 15, 2008 6:22:21 PM

I tried going DVI to HDMI...didn't get a signal. I checked your other post...I think my set's HDMI is A&V.
February 15, 2008 6:54:25 PM

niz may be on to something. There is a feature in CCC to not read the EDID settings. Under Monitor Properties -> Attributes, there is a Monitor Attributes section with a check box "Use Extended Display Identification Data (EDID) or driver defaults". Below that is a pull-down for maximum resolution and maximum refresh rate. I suspect that if you uncheck this box (or the equivalent of this box in the NVidia world), you may be able to use your LCD without hassle. You'd have to set it using your other monitor, but I imagine that once it's set, you may be ok.
February 15, 2008 7:21:46 PM

Cool deal...trying it now.
Guys...I really aprieciate the help.
By the way, Tera...I've always loved that bmw. :) 
a b U Graphics card
February 15, 2008 8:35:27 PM

There are also some TVs that were EDTV and not HDTV. They would be 480p, which is the same resolution as DVD. I'm not sure what the right resolution would be for 480p- 1080x480? I don't know. make sure your tv isn't edtv.

also some "720p" hdtvs were 1024x768 even though they are widescreen. There are a lot of plasmas like this. 1368x720 would be out of spec for such tvs.
February 15, 2008 9:10:43 PM

Sounds like a refresh rate problem to me. Have you tried lowering the refresh rate?
February 15, 2008 9:25:09 PM

It's not the rate thx anyway
February 16, 2008 6:21:59 AM

If none of the above works, how about setting your tv up using "clone" on the nview display properties. This is meant when there are two monitors, so you would have to set it up with one on the vga and one on dvi to set up (make sure the dvi is the primary monitor). Worth a shot?

Nb. I run a lcd tv & lcd monitor in clone mode and there is no performance hit.
February 16, 2008 6:25:02 AM

Ah...cool. I'll give it a try....YAWN...in the morning.


Must sleep....
Thx!
May 15, 2009 5:06:03 PM

Hi, Yesterday I installed a PNY 9400 gt to my computer, It came with the dvi to hdmi adapter so I tried to use it, I connected the hdmi cable to my Samsung 37 LCD TV that I bought 2 years ago. And when I turned on the computer it was receiving signal, just before Windows logon screen, it stopped working. Can anybody help me and tell me how can I switch my graphics card input, I'm still using my tv as a monitor but with the vga cable plugged to it.
September 1, 2009 3:41:48 PM

I've had the same problem before as well on my 42" LCD. The Nvidia drivers keeps trying to set the resolution automatically to 1360 x 765, which my TV wont accept. I see the post and boot screens but as soon as Windows loads, the signal is gone and message "invalid signal" appears.

Neither low-resolution mode or swapping monitors with a CRT and changing the res then swapping back worked, as the drivers would instantly change the resolution as soon as my TV is detected.

I had to revert to an older version of the Nvidia drivers to get it to work (used the ones that came on the grahic card driver CD).

Does anyone know how to stop the (latest) Nvidia drivers from auto detecting and setting the resolution?
March 10, 2010 5:29:57 PM

roadrunner197069 said:
You can go DVI to HDMI if your HDMI is video only. Most HDMI is set for video and audio, if this is the case your speakers will squeel because there wont be sound.

DVI is a digital signal and your VGA is analog so it wont work.

2 options for you.
1. Use DVI to HDMI if your HDMI in is Video only.
2. Get a card that has built in s/pdif so you can do DVI to HDMI with sound. This card or one like it would work. http://www.newegg.com/Product/Product.aspx?Item=N82E168...



I just bidded on Monitor that only has DVI,- am I going to have problems with DVI on a 2000 Windows CRT I have a standard CRt on a CPU with Windows 2000 and want to replace it with a flat screen for space purposes. A flat screen would allow me more room on my desk.

I have another computer that uses HDMI ports, so I am not sure what to do about a monitor that does not have HDMI ports, but only DVI ports.

Not computer savory!!
a c 271 U Graphics card
a b \ Driver
March 10, 2010 10:30:56 PM

This thread was started two years ago so please start a new one.
!