Sign in with
Sign up | Sign in
Your question

I did something really stupid, please help

Last response: in Storage
Share
March 3, 2009 4:12:24 PM

Hi, i have this problem that i cannot solve. i know why it happened but i was kinda trying stuff without really knowing what i was doing, so now i turn to this forum cause i tried all i could think/find and i still cant solve my mistake.


I had two HD,

C: with XP pro sp3 and linux (dual boot)
D: formated in ntfs with all extra data (songs, video, reports, receipt etc..)

When i had these two working normally, i needed to restrict the access of the second HD (the D:)  to only one computer on the network so i messed around with the permission. I ended up deleting the whole list;

it was looking like this (under the security tab of the HD properties)

"Administrator"
"SYSTEM"
"User" X\username"


So i deleted these, it gave me problems , then i found how to re-take owner ship. but i only re-added

"User" X\username

i could then again access my files on the D: . but i still couldnt share my files as i wanted for some reason. so i decided to re-install windows...big mistake!!

I formated the C:, re-installed windows on it, no problem with that. But now i see the second HD in windows explorer as RAW and access is denied. Meaning the HD is detected and listed there, but the used space and total space amount is not showing, if i click properties, instead of NTFS its says RAW. If i try to open it to explore the content, i get an access denied message.

I tryied chkdsk it did some things (looked like it was changing stuff, but i cant see any differance, i still get the RAW and access denied thing. Then i tried Testdisk application. It can list my file's arborescence in a command prompt windows. (everything is there as it was before) but i still cant acces anything. windows still doesnt see it as ntfs but testdisk does...

Is there a kind sould out there that would be able to suggest the solution for this problem ? so i could again access my files. I know i did a big mistake when messing around with the permissions ...argh.

More about : stupid

March 3, 2009 5:22:34 PM

This, and many other reasons, are why neither my wife nor my father are administrators on their own computers. sigh...

I'm guessing you don't have backups? If you do, that might be your easiest path.

If you named your computer "X", after you did the O/S reinstall, and you named your login "username" (or whatever "X" and "username" actually used to be, as you refer to them above), then the drive and O/S are basing security on the GUID associated with X\username, instead of the text itself. I don't believe NTFS has a back door that allows X\Administrator to access the contents of a hard drive even if that username is not listed on the security. Note: If you did not use the same computer and login name to try to access the drive already, try that first.

However, there is one thing to take heart in: Unless your data was encrypted on drive D (and you would have had to do something to make it so; it isn't by default), it should still be there and accessible. The Windows XP O/S is denying you access to it because it adheres to its own security policies. But if you had another program that could read NTFS directory structures and such then that might enable you to gain access to your files, copy them to an unprotected location, and then get to them in-the-clear from within XP from there.

I don't know if such a tool exists in the open market. If it does not, then you could always send your drive in to a data recovery shop. They must know how to work around this.

Good luck.
!