Sign in with
Sign up | Sign in
Your question
Closed

Windows isn't detecting my USB MIDI Keyboard

Last response: in Windows XP
Share
July 10, 2010 12:45:10 AM

Hello,

I have a Casio CTK-2000. My computer refuses to detect my it. It will install the software for a "USB MIDI Device", so I'm pretty sure it sees the keyboard. However, whenever I try to use my keyboard as a MIDI device with any music programs, it simply does not show up. What's very odd is that this has happened before, but was fixed when i reinstalled Windows much later. This simply isn't practical and I need a solution.
July 10, 2010 2:27:30 AM

There's more than one thing to check and correct

A. USB power is automatically turning off:

click my computer, on your desktop
click control panel, it's on the left hand side of my computer window
click the "system" icon, a window will open that says system properties
click the hardware tab
click the device manager bar
when the device manager window opens, scroll down, find universal serial bus controllers
double click universal serial bus controllers, it's on this list
now you will see a list, find USB root hub on the list
double click the first USB hub on the list
when the USB hub properties window opens, click the power management tab at the top of the window
now you will see a box that says: "allow computer to turn off this device to save power"
Un-check that box, click OK
Now double click the second USB hub on the USB Hub Properties list, click the power management tab, un-check the power saver box just as above, and click OK
Now repeat that same procedure for all the other USB hubs on the list, un-check the power saver box in each USB hub, until you have done all the USB hubs on the list. There may be several, you must do each, one at a time.
Now close all your windows and restart the computer.
Now the USB should stay on.
The computer was turning off the USB device to save power. It's a bug in XP.

B: Plug and play USB needs to be turned on in bios settings:

Hold down F2 and start computer, look all through the bios settings. The plug and play needs to be turned on, the USB needs to be turned on. This varies with the type of computer, you may or may not see these settings in the bios set up.
Save the changes and exit the bios setup, if you were able to make changes.

C. Driver not installed correctly:

click my computer, click control panel, click add remove programs. Look at the list for the Casio MIDI diver. Delete the driver.
Turn off the anti virus, re-install the driver, restart the computer, turn the anti virus back on.

D. Midi sound turned off, midi turned off:

Double click the speaker icon in the lower right hand corner of the screen. This opens the audio settings. Look through the audio software and determine if the MIDI volume is turned up, if the midi is turned on.

click my computer, click control panel, click sounds and audio devices, click the audio tab. Look at: MIDI music playback, determine if the volume is set correctly, check the other available settings and drivers in this window.
Score
0
July 10, 2010 6:38:09 PM

Hrm... None of these solutions seem to be doing the trick. Maybe I should describe my problem a little better.
I don't really think that the device is being turned off, because what happens is:

Assuming all drivers have been uninstalled, I plug in my MIDI Keyboard, turn it on. Windows recognizes that something has been plugged in, identifying "casio usb-midi", installs drivers. Now, I go to Device Manager and it tells me that there's a "USB MIDI Device" plugged in. If I unplug the keyboard, this dissappears, likewise if I plug it in it reappears. As to be expected.

Now, I'll plug it in, USB MIDI Device shows up in Device manager, I open up, say, Synthesia (a game that uses MIDI Keyboards to play.) I go into the appropriate settings screens to set up my Keyboard and.. it isn't in the list, though previously it was.

So I check Windows' sound settings. I look at the "audio" tab of "Sounds and Audio Properties" and under "MIDI Music Playback" is nothing but "Microsoft GS Wavetable SW Synth" and nothing about a USB device or anything.

So the device is fully well connected and even recognized, but for some reason I cannot discern, It's not being used as a MIDI device.
Score
0
Related resources
July 10, 2010 9:20:13 PM

Have you tried opening the game/ program and then plugging in your midi keyboard?
Score
0
July 11, 2010 3:23:19 AM

Yeah, no luck.
Score
0
July 11, 2010 3:39:32 AM

Did the keyboard come with a software disk? did you try re-installing it?
Score
0
July 11, 2010 7:56:00 PM

From the run command try DXDIAG.EXE and see if it shows up any problems there
Score
0
July 11, 2010 8:17:01 PM

You said you re installed XP, and it worked...

my conclusion is that an automatic windows update is disabling it. Which is not unknown.

I would:
Backup all personal files
Do the repair install of the operating system (not reformat)
turn off automatic updates
load updates manually until I found which one stopped it from working
Install tweek UI XP, to shut off the message balloons
Score
0
July 13, 2010 9:22:36 PM

The keyboard did not come with a Software CD. in DXDIAG, under the Music tab I still can't find anything about my keyboard. Beyond that it doesn't give me any issues.

I don't believe it's a software update because I haven't installed an update any time after the problem set in.
Score
0
July 13, 2010 9:49:17 PM

You may need a powered usb hub to give that bit of extra power. Is there one you have or can borrow to try.
Score
0
July 14, 2010 12:16:02 AM

you would need to install an update before the problem set in, not after.
Is your automatic update turned on? they install themselves without notification.
Why I mentioned that is that you said when you re-installed the OS, the MIDI worked.
Then something happened to make it stop working. That might have been an automatic update.
That's why I suggest repair install of XP, shut updates off. See if it keeps working.
With the updates cleared out, and shut off, it might keep working.

Then you can manually install updates, one at a time, and maybe find which update causes the malfunction.
Score
0
July 14, 2010 8:57:44 AM

rfLarke said:
Hello,

I have a Casio CTK-2000. My computer refuses to detect my it. It will install the software for a "USB MIDI Device", so I'm pretty sure it sees the keyboard. However, whenever I try to use my keyboard as a MIDI device with any music programs, it simply does not show up. What's very odd is that this has happened before, but was fixed when i reinstalled Windows much later. This simply isn't practical and I need a solution.


You did something different. Yea, everyone's going to say no sh*t Sherlock, but are you forgetting to do something?

I looked at the Casio site and they have totally accurate info. Go there and look at line #3 especially. The part about "THERE ARE NO EXCEPTIONS TO THIS RULE" is right on the money. They didn't use all caps for nothing.

I play with Cakewalk Sonar 8.5 Producer and what they said at Casio is as much the law for me as it is for you.
If I don't Configure MIDI IN and MIDI OUT, I get nothing, and neither will you. Take a peek, it might solve the problem.

Article:
        http://www.casio.com/support/techsupport/A92BED00-98FC-...


Score
0
July 14, 2010 7:31:36 PM

No dice. I can't configure MIDI IN or MIDI OUT on anything because my keyboard doesn't show up in the options to do so. And I don't have anything about "Send to Keyboard" anywhere. I don't think these instructions apply to my keyboard.

Also, I've just found something. It seems as though I made a mistake, Device manager doesn't see "USB MIDI Device", it sees "USB Audio Device".
Score
0
August 1, 2010 3:31:15 AM

Alright, sorry for not posting sooner but:

I've found the solution. it seems to be linked to DirectX. I used System Restore to roll back my system to before install DirectX 9 some time ago, and the keyboard works fine.
Score
0
October 16, 2011 10:59:38 AM

im having the same problem but i cant roll back before directX 9 :/  could i have some help please?
Score
0
April 3, 2012 4:35:56 AM

oskar_hendriks said:
Please take a look here
http://forums.techarena.in/windows-xp-support/559307.ht...

Oskar


Yes, I had the same problem. I have now removed the logitech quickcam software and driver package using the control panel and this also fixes it. I don't know about hub am waiting for one to arrive. Thanks.

Philip
Score
0
June 23, 2012 6:11:08 PM

soundguruman said:
There's more than one thing to check and correct

A. USB power is automatically turning off:

click my computer, on your desktop
click control panel, it's on the left hand side of my computer window
click the "system" icon, a window will open that says system properties
click the hardware tab
click the device manager bar
when the device manager window opens, scroll down, find universal serial bus controllers
double click universal serial bus controllers, it's on this list
now you will see a list, find USB root hub on the list
double click the first USB hub on the list
when the USB hub properties window opens, click the power management tab at the top of the window
now you will see a box that says: "allow computer to turn off this device to save power"
Un-check that box, click OK
Now double click the second USB hub on the USB Hub Properties list, click the power management tab, un-check the power saver box just as above, and click OK
Now repeat that same procedure for all the other USB hubs on the list, un-check the power saver box in each USB hub, until you have done all the USB hubs on the list. There may be several, you must do each, one at a time.
Now close all your windows and restart the computer.
Now the USB should stay on.
The computer was turning off the USB device to save power. It's a bug in XP.

B: Plug and play USB needs to be turned on in bios settings:

Hold down F2 and start computer, look all through the bios settings. The plug and play needs to be turned on, the USB needs to be turned on. This varies with the type of computer, you may or may not see these settings in the bios set up.
Save the changes and exit the bios setup, if you were able to make changes.

C. Driver not installed correctly:

click my computer, click control panel, click add remove programs. Look at the list for the Casio MIDI diver. Delete the driver.
Turn off the anti virus, re-install the driver, restart the computer, turn the anti virus back on.

D. Midi sound turned off, midi turned off:

Double click the speaker icon in the lower right hand corner of the screen. This opens the audio settings. Look through the audio software and determine if the MIDI volume is turned up, if the midi is turned on.

click my computer, click control panel, click sounds and audio devices, click the audio tab. Look at: MIDI music playback, determine if the volume is set correctly, check the other available settings and drivers in this window.


Thank you so much!!! The A. USB power is turning off was my problem!! It took me a lot of internet searching to find this!!
Score
0
February 25, 2013 9:09:46 AM

I second the solution of removing the logitech quickcam software and driver package from Windows XP.

Before that, my usb-midi cable from Conrad installed automatically and showed as USB Audio Device, but it had sub-properties including Midi, but Anvil Studio would not recognize it via an Acer Laptop w/Windows XP.

The same cable worked fine automatically under Windows 7
Thanks for that suggestion.
Score
0
July 19, 2013 4:53:47 AM

I had the very same problem with another usb keyboard. Solved it turning USB audio device off and on in devices list
Score
0
!