Sign in with
Sign up | Sign in
Your question

IDE devices aren't getting detected

Tags:
  • DVD Drives
  • Hard Drives
  • Storage
Last response: in Storage
Share
March 19, 2009 7:58:07 AM

I've got a weird problem and I just can't figure out what's happening. I built a new machine last week and got everything working. Installed Windows XP and all the drivers that came with the Gigabyte GA-EP45T-UP3P. Then I switched everything off and plugged in the old IDE hard disk from my old PC so I could get the data copied over to the new Sata disk. Since then it doesn't matter what I do PC doesn't recognise any IDE device. I've tried 3 IDE hard disks, a DVD-RW and a DVDROM. I've tried 2 or 3 different IDE cables. Set the jumpers to master and slave. Hard disks and the DVDs are getting power because disks have a vibration feeling to them when I touch them and I can open/close the DVD drives.
BIOS detects the hard disk but it shows a size of 1220GB while the disks are only 80GB.
DVD drives were getting detected as Floppy drive in windows (nothing in BIOS) so in BIOS I've disabled the floppy drive.
Please help because this is driving me nuts. Thanks

More about : ide devices detected

March 19, 2009 9:13:01 AM

don't know if this helps but,,on some mobo's you actually have to turn on the ide protocol,and it is not referenced to as ide,of course you might have a lemon too...:) 
a b G Storage
March 19, 2009 2:16:02 PM

If all else fails you can install your old HDD in an external enclosure and import your data through a USB port. I had to do that myself once.
Related resources
March 19, 2009 2:24:22 PM

Thanks for replies guys. The problem is its not just HDD that I need. I need my DVD-Rewriter too. I don't want to spend anymore money on buying a SATA DVD RW when I've a fairly new one.
What really puzzles me is the fact that Windows XP is detecting the DVD-RW but its being detected as Floppy Drive.
March 21, 2009 3:24:04 PM

go to your disk management tools. You can then change the drive letter from A: to D:
March 25, 2009 6:11:10 PM

I built a computer that wouldnt recognize my IDE drives and also showed the drive as a different size. I cleared the bios, toggled pnp os installed option, changed the jumper settings and change the IDE protocol. Nothing worked. Then I downloaded my mobo model's flash utility and made a bootable floppy drive and upgraded the bios. I still had to play with the bios settings a little but I got it running and it hasn't given me any problems since. Sometimes you just get a mobo with a corrupt bios Hopefully upgrading the bios will work(if you haven't tried that already) even if you dont need it upgraded I would still flash the bios with a new copy from the manufacturer. Good luck.
!