Sign in with
Sign up | Sign in
Your question

Unable to connect to wireless network - software or NIC issue?

Last response: in Wireless Networking
Share
April 25, 2009 8:22:43 PM

I have the following problem and would greatly appreciate any help/pointers.

I am unable to enable wireless networking on my pc. I'm running Vista 64 SP1 and my basic hardware specs are at the bottom of this post (you never know - happy to upload any data if that helps). The NIC I'm using is the Dynamode Wireless 802.11N PCI card. The model number is WL-GI-600-11N. I think it's essentially the Ralink RT2860 chipset.

This is what I've done:

1) Install card
2) Install driver shipped with the device

It installed properly (driver plus the Dynamode wlan utility) and Device Manager shows the 902.11n WLAN Card as properly working. However, under "Network Connections" in the control panel, the Wireless Network Connection remains disabled and clicking on enable has no effect. In the wlan utility, no networks showed up and clicking on refresh just permanently greyed out the button without listing any networks. Vista (under connect to a network) cannot find any wireless networks either.

3) I uninstalled drivers and utility
4) Downloaded and installed Ralink driver (thank god for 3G phones)

This produces the same outcome. The drivers and RaUI appear to install correctly. The WLAN Card is shown as properly working in Device Manager, but the Wireless Network Connection remains disabled. RaUI shows status as "disconnected", lists no networks and the refresh button is greyed out. I played around with the settings for the NIC (region codes, enable/disable ad-hoc, etc). To no avail.

Obvious points: radio is on and there are wireless networks available (I can connect with my phone etc...).

Hardware specs:
Intel Q9450 2.66 GHz (not o'clocked at the moment)
EVGA 790i Ultra
4GB OCZ PC10666 Platinum
EVGA Nvidia 9800GTX
Let me know if anything else may be relevant

I'm beginning to wonder if this might be a hardware problem.

Many thanks in advance for your help.
Anonymous
April 26, 2009 9:15:56 AM

Dynamode is a small outfit but their hardware is okay -- I'm using one of their Wireless PCI cards right now. Go to their website and see if there's a new driver pack for your card -- hopefully including one for Vista64.

Otherwise I can only suggest treating it as a generic PCI problem -- changing to a different slot, going into motherboard BIOS and disabling any devices not in use -- perhaps COM ports, Game/Midi port, Parallel printer port (if using USB printer). Then restart machine a couple of times before installing wireless card.
April 26, 2009 10:17:52 AM

Thanks for your reply. The Dynamode website does not seem to have a comprehensive driver library (only some products - at any rate the WL-600-11N isn't even listed under their products). Since I tried the shipped driver and the latest driver from the chipset manufacturer, I'm inclined to think that it probably isn't a driver issue.

I'll give the PCI suggestions a go. I've a free PCI slot, so I can try that one and I can deactivate serial port/firewire/ethernet ports etc. Is it worth it trying manually to assign IRQ (noting that Vista does not show any resource conflicts)?

Thanks
Related resources
Anonymous
April 26, 2009 6:05:47 PM

Do the shipped drivers claim to work with Vista 64 ? -- this is an issue with some big brand models.


I wouldn't go manually assigning resources. Restarting the machine lets Windows sort things out.

You'll probably want to keep ethernet port for addressing your router to make changes (it's confusing if you use wireless).

Does anyone use Firewire with the PC ?
April 26, 2009 8:29:01 PM

The shipped drivers claim to be compatible with Vista, but without specifying 32/64. The Ralink drivers do mention that they include Vista 64 compatibility.

I quickly tried deactivating serial port and firewire (which is not in use), but without taking the network card out - I didn't have much time today. That didn't change anything but I'll try again with removing the card and swapping PCI slots.

Thanks for your help, really appreciate it - I'll report back tomorrow
October 18, 2010 5:08:45 AM

Hi,

I have had the same problem.

Also see http://forums.overclockers.co.uk/showthread.php?p=13292...


It seems that the problem is with the software installed.

A workaround that I use is to go to windows mobility centre, click the connected button, and manually connect. However this is far from ideal.
!