Sign in with
Sign up | Sign in
Your question

How to test Memory on 64-bit Vista?

Last response: in Memory
Share
April 10, 2008 1:46:08 AM

I've been having issues with my newly built PC since shortly after i built it. Nearly all have been solved, but new ones keep cropping up. For instance, my computer will never used to have any problems with resuming from sleep (sfter I changed BIOS to S#, that is.) Now, whenever I resume from sleep, the PC works fine...until I try to do something. As soon as I open an app, like Firefox, for example, BOOM! BSOD. And I mean every time, 100% reliablility. I've run every Memory diagnostic I can find, except for MemTest 86, which never seems to work. Is it not compatible with 64-bit systems? If so, is there a compatible version? I've tried it on CD and Floppy; neither works. During boot, it just cycles saying to insert a boot-compatible disc or restart. And yes, i made sure to tell it to boot from the proper device, and even disabled the boot from HDD. I've tried simply pulling three of the sticks and only running 1GB at a time, but then I never get any faults. I really can't think of anything else to do. I'm all but positive it's the memory now, but I have no way to find out which stick(s) it is

And here's another curious thing happening since this started. Whenever I restart my computer, it doesn't really restart like normal, where the PC continues to run and Windows just resets. Instead, the whole thing shuts down, PC and all, for a few seconds, then powers on again. What it going on?

More about : test memory bit vista

April 10, 2008 2:50:40 AM

Try downloading a live K/ubuntu cd, boot off it and run the memory test.
April 10, 2008 2:55:39 AM

Am I understanding that it will resume from sleep mode without a problem running only one gig at a time?
April 11, 2008 1:55:02 AM

OK, sorry I ddin't make that more clear. All of the memory tests i perforemed were in the past. Everything checked out. I've finally got a working copy of memtest and ran it with one pair of dimms, and then the other. Again, both passed, but I am still having issues.

The situation seems to be getting worse, now. Whenever I try to go to sleep mode now, to test if the problem is still there, the PC hangs at shutdown and doesn't do anything. I manually shut down, then restart. But then, the PC turns on, shuts of, turns on again, turns off again, then restarts a third time and hangs. Only after manually killing the power again can I turn the PC on. At on point I got the message that the overclock had failed, even though i hadn't changed any settings. Just to make sure a bad overclock wasn't the problem, I de-clocked everything back to factory specs. Still have problems. Any ideas? Also, any ideas on the shut-down during restart? That started happening at the same time as the other stuff, so I'm guessing they have a common source.
!