Sign in with
Sign up | Sign in
Your question

Vista laptop cannot connect to wifi router. Wrong IP address leased to laptop.

Last response: in Windows Vista
Share
February 9, 2012 2:59:52 AM

My windows vista laptop cannot connect to the internet via a wifi router connected to a DSL modem.

I tried using a direct cable connection to the DSL modem, it can connect to the internet.

The problem is with the wifi connection, upon inspection using the ipconfig command I notice a different IP address being leased to my vista laptop by the wifi router for the wireless adapter. It's different from the IP block defined in the wifi router. More like an IPv6 address.

Shall I modify my registry settings? If this is the case, can you help me out on this? This just happened suddenly. Before this the vista laptop works fine with the router. Is there any I can get a windows vista registry file default setting for the network or wireless or IP section?

a c 204 D Laptop
February 10, 2012 3:59:35 PM

Are you sure you are looking at the IP address and not the MAC address of the adapter. The MAC address looks a bit like IP6.

Does the connection to the laptop from router work properly using an ethernet cable? You said you tried that to the modem, how about from the router?

You can try to uninstall and re-install the network adapters, also run Windows update if you have not had it running the whole time.
m
0
l
February 13, 2012 10:30:30 AM

Hi Maxx_Daxx,

This is a case of ip address conflict of another network. What you can do, is to release and renew the IP address. Here is the way for that: (1) Open the command prompt (2) type "ipconfig /release" without the quotes and hit the enter key, (3) Type "ipconfig /renew" without the quotes and then hit the enter key. (4) Also flush the DNS as "ipconfig /flushdns" without the quotes and then reboot the computer.

Also make sure that you have the dynamic IP address assigned to your network and computer. You may check here as type ncpa.cpl in the run command and then right click on your 'Wireless network connection' and then click on properties of your IPv4 or V6 you are using and make sure that its the dynamic ip address there.

m
0
l
Related resources
!