Sign in with
Sign up | Sign in
Your question
Closed

"Flat Panel Scaling Fix" For Windows Vista

Last response: in Graphics & Displays
Share

Does this solution work for you?

Total: 14 votes (7 blank votes)

  • "Yes" it does work
  • 43 %
  • "No" it doesn't work
  • 58 %
March 2, 2008 4:15:15 AM

I found a solution for the "Flat Panel Scaling" problem under Windows Vista (All Versions)

1) Change your monitor resolution to 800x600 or any res below the native one (Under Display Properties)
2) Open up NVIDIA Control Panel
3) Highlight "Change Flat Panel Scaling" in the left under "Display"
4) select "Use NVIDIA scaling with fixed-aspect ration" (2nd option)
5) Click on the "Apply" button
6) In the confirmation window click "Apply"
7) Change your desktop back to the original resolution if you want
8) Enjoy Non-Stretched Games and Desktop ;) 


Edit: In some games you would have to do this trick after you run the game every time you don't want "stretching".

I found out about it when I was playing with the settings for a few hours and I just got it working finally! :D 
March 4, 2008 7:18:10 PM

nice
March 6, 2008 3:31:42 PM

But don't you just set your monitor to it's native res, or are we talking about TV's, I'm interested but don't quite understand what situation would require this.
Related resources
March 7, 2008 10:56:28 PM

bildo123 said:
But don't you just set your monitor to it's native res, or are we talking about TV's, I'm interested but don't quite understand what situation would require this.


Well I'm talking about LCD Wide Screen Monitors, these monitors "stretch" anything that requires full screen by default, so the only solution I found is what I wrote in my first post above. :sol: 
March 8, 2008 12:10:36 AM

thanks, worked on 64 bit vista too! (sc ftw)
March 8, 2008 3:08:36 AM

darkmage87 said:
Well I'm talking about LCD Wide Screen Monitors, these monitors "stretch" anything that requires full screen by default, so the only solution I found is what I wrote in my first post above. :sol: 
Good wide-screen monitors should have options to scale video image without stretching.
For example, my old HP L2335 monitor has three scaling options: Fill to Screen (Scaling with stretch), Fill to Aspect Ratio (Scaling with no stretching) and One to One (No scaling).
March 10, 2008 4:13:11 AM

saiyan said:
Good wide-screen monitors should have options to scale video image without stretching.
For example, my old HP L2335 monitor has three scaling options: Fill to Screen (Scaling with stretch), Fill to Aspect Ratio (Scaling with no stretching) and One to One (No scaling).


Well most people can't afford monitors with those features, but anyways my monitor doesn't have scaling options so the only to fix it is through the video card. :sweat: 
March 10, 2008 4:50:37 AM

Well, I'll find out if I have a problem when I move from a CRT to a 20" LCD next week. The scaling options in CCC look to be under Monitor Properties, Adjustments.


March 10, 2008 6:16:41 AM

Thank god I moved from ATI to NVIDIA, all because of their nasty unstable drivers :pfff: 
March 12, 2008 12:28:10 AM

This solution unfortunately didn't work for me. I have a Palit 9600GT Sonic card connected by HDMI to a Viewsonic VX2835wm monitor. I have tried the 174.16 driver as posted at Nvidia as being "the" driver for 9600GT as well as the older version 171.15(?) which came with the card. In all cases, the scaling option is greyed out and not available in either the control panel or in the OSD on the monitor itself. Viewsonic doesn't seem to have a solution so I guess the only alternative to putting my old 8500GT card back in is to wait for nVidia to come up with a driver that works. Very disappointing to say the least.
March 20, 2008 1:26:47 AM

Unfortunately I have the opposite problem. My main issue is that one of the games I play is in Anamorphic Widescreen resolution and it's forcing it into 4:3 but not displaying everything.

Nvidia scaling used to fix this back in 164.09 but every driver revision after that has it broken..... It's really pissing me off.
March 20, 2008 1:42:14 AM

Any screen caps of this problem? I run a 22" WS and a 19" FS and don't notice any real difference as long as i set a widescreen resolution.
March 30, 2008 6:26:58 PM

"Any screen caps of this problem? I run a 22" WS and a 19" FS and don't notice any real difference as long as i set a widescreen resolution."

Lol this fix is only for games that don't support wide screen resolutions, like for example "Starcraft: Broodwar".
September 9, 2009 4:18:20 PM

I believe I have come across the answer to why some of us don't see scaling in the nvidia control panel.
The following is from an article at tweakguides.com:
Quote:
Adjust Desktop Size and Position

If you have a digital flat panel - most commonly an LCD display - connected via a digital connection like DVI or HDMI, then this section allows you to determine how various resolutions appear on your screen.


According to that, the widescreen LCD monitor needs to be connected to your computer by dvi/hdmi, not the usual vga.
January 20, 2010 4:27:59 PM

This worked for me in Windows 7 64-bit. I'm running a 9800GTX driver version 196.21 released 2010.01.19. I have a 37" 1080p TV and a 24" 16:10 display. 1920x1080 would be stretched vertically on my 24" in clone view. I've tried different connection configurations, using DVI/HDMI and VGA cable on both displays with no luck. I saw this thread and tried the mentioned fix and it worked.

This is clearly an issue with nVidia software... Their software has really been going downhill since the 4000 series died.

Thanks for the fix!
a c 171 Î Nvidia
January 20, 2010 9:38:32 PM

This topic has been closed by Mousemonkey
!