Sign in with
Sign up | Sign in
Your question

What would cause a RAID0 to become Unallocated?

Tags:
  • NAS / RAID
  • Windows Vista
  • Storage
Last response: in Storage
Share

How effective is free data recovery software?

Total: 2 votes

  • 1) Useless, you get what you pay for
  • 0 %
  • 2) Useful for simple issues (please list recoverable issues as a post)
  • 0 %
  • 3) Very useful if you know what you’re doing (please list tools you recommend as a post)WinHex etc.
  • 100 %
March 24, 2009 1:49:28 PM

Hello,

I am hoping anyone familiar with the "SATARaid5Manager" from Silicon Image or RAID 0 discovery/initialization in Windows can point me in the right direction.

I'm going to make this as short and sweet as I can, let me know if I left out any critical information . . .

I have been running a 3 disk RAID0 (3X 750GB = >2TB volume) in my Venus T5 - 5 disk external enclosure flawlessly for months in Vista Ultimate 64
(using Silicon image 3132 PCIe card + SATARaid5Manager utility)

Step 1) A driver loading mishap forced me to reload Vista on a new HD to access my files

Step 2) once inside new Vista install, I reload Silicon image drivers/ Raid manager
a) Device manager is happy with drivers
b) Raid manager is working fine, and shows 3 striped drives all healthy (see Pic)

c) *PROBLEM* Windows cannot see the array (in My Computer as before) and wants to initialize the volume.
Although I probably shouldn't have tried it, the initialization always fails with GPT or MBR.
(seen as a single volume but not recognized) (See "Disk Manager" Pic)


My most recent data has NOT been backed up
(didn't expect a driver upgrade to cause all of this ...) so I need to regain access to my files.

Corrective Steps I've tried:

1) AMS tech support- A JOKE, the man did not have a clue and never heard of this problem before. When I asked if I could escalate to higher support he informed me that he was IT!

2) Silicon Image does not offer support to the end user but they have all of the documentation and latest drivers available for download. I have tried every combination of driver/ card bios version that I could . . .

NOTE: SI docs claim that you CAN move the array to other pc's even with 'similar' eSata cards installed & the Raid manager program, . . . (This is the EXACT setup with just an OS reset!) . . .(See step3)

3) I finally was able to reboot the old Vista install (that originally hosted the array) but it behaves exactly the SAME as my other Vista install.
NOTE: Although I don't believe the external enclosure was effected at all, the original OS mishap involved the installation of my SATA2 Gigabyte Mobo driver. (if that is relevant at all?)

4) I tried a test of the enclosure itself by installing a spare Drive into one of the empty bays as a "pass thru"
RESULT: the drive came online immediately and was recognized by Windows with me doing nothing at all!
NOTE: I realize this is not a RAID drive, so it's not completely apples to apples, but it shows the enclosure CAN be seen by windows.

5) Recovery Software:
I ran iRecover and was able to see the entire volume and it's contents!
Just as I expected, this is a perception issue!
Note: confirming my theory that I've done nothing to 'damage' the array, I was not able to access the volume as individual drives of a 'broken' array, but when I selected the whole volume as a single array the recovery software showed it could recover everything and there were no damaged sectors.


Obviously, the Recovery $oftware is my last option (well, ahead of taking it to be recovered)
because of the expense involved
(I don't have to tell you that purchase $price$ of recovery software is not friendly)

This seems to be a 'perception issue' with either Windows not seeing the volume, or the RAIDManager not "showing" it as it should.

The raid manager utility is fully functional, and I've been through every option but I don't see anything that looks useful except 1 option:

"Create/Delete RAID Group" is available, but I'm under the impression if I re-create this group, it will format and I'll loose my data.
Any SATARAID5 experts?

I would be deeply grateful to anyone who could even shed a little light on my problem!
Thank You for reading my post!

More about : raid0 unallocated

March 25, 2009 3:34:53 PM

UPDATE:
I have 2 free programs working right now on recovering the data on the external array:
1) iRecover is shareware, but it includes a free picture etc. recovery (not sure how extensive this feature will work so . . .)
2) DiskInternals Raid to Raid 1.0 is freeware and it is copying the image onto my internal array

While it will be great to get my data back, it is a LONG process just to transfer such large files (almost 4 hours @ 25% for iRecover !)

So I really would like to find out what went wrong, especially since I intend to continue use of the enclosure.

I noticed something that might have been throwing off my diagnosis, notice this screen shot of my Disk Manager:


The Disk Manager requests to format Disk 5, which I assumed was my external. But I"m not so sure now because I was over looking the "Unallocated" Disk 3 (too many disks to keep track of I guess:)  )

*Notice the difference in "Volumes" info.
so it appears that my problem is not that Windows can't see the volume, but that it's "unallocated"

It has been suggested that Windows Partition Wizard is a "Work Around" Here:
http://kb.netgear.com/app/answers/detail/a_id/158

Now I'm going to allow the recovery processes to save the data, just so I don't take any chances, but:

1) Is there a better way than this "Work Around"?
2) If not, would this be the way to go the next time I move my external? (without loosing the data)

3) Also, any idea why Windows decided to make an issue of Disk 5 or what it is?
April 1, 2009 9:56:03 PM

I have changed Disk 3 to GPT and am formatting it. I still do not know how it lost it's Identity, but perhaps when it is finished the error on Disk 5 will disappear?
If I move the Drive in the future, will this happen again??
Does anyone have experience with this issue?
Related resources
April 3, 2009 4:39:26 AM

I'm sorry i didnt read all your text, but if you like to recover you need to be careful. In the second screenshot you posted, if you click OK windows will overwrite data on that disk. Did you do that?

Normally, when using onboard RAID the actual harddrives are being 'hidden' from Windows; unlike Linux or BSD. Should you boot the RAID-array off a Windows-system with only SATA drives (i.e. the RAID-drives supporting that array is not present), then Windows will show you the 'bare' drives.

One of them might say its initialized. This is because its the first disk in the array and thus contains the first 64KiB or so including the MBR so windows will see that as a single disk with a partition on it that is greater than its capacity. The other RAID-member disks would show as uninitialized disks, and if you double click them Windows will ask you if you want to initialize the disk, as you posted in screenshot 2. If you hit OK, you will destroy data on the RAID-array. That's why the RAID-drives hide the actual drives: if you tamper with them it will damage the RAID-array. Assuming, that is what happened, you should use recovery and start over.

I recommend you do as little to the disks as possible for now, because you might be corrupting your array with the actions you are taking, making full recovery impossible. Should proprietary tools fail, its also possible to regain access to your array with software RAID0 from Linux or BSD, which can be done without writing anything to the disks so its a safe procedure. But as you say this is time consuming and you need another computer with equal amount of storage to facilitate the recovery process. The linux/BSD part isnt that hard really; piece of cake if you know what to do. :) 

Should you need additional help feel free to ask.
April 7, 2009 10:25:56 AM

Translucency said:

Normally, when using onboard RAID the actual harddrives are being 'hidden' from Windows; unlike Linux or BSD. Should you boot the RAID-array off a Windows-system with only SATA drives (i.e. the RAID-drives supporting that array is not present), then Windows will show you the 'bare' drives.

Thank You for your reply Translucency,
fortunately I have recovered the data! I used R-Studio and it "SAW" the array from the beginning, so after I ran a scan, I was able to transfer the files off of the external array and reformat it.

UPDATE: I have come to find after reformatting the array that the "unknown" "disk 5" is UNRELATED to the array.
This was throwing me off in my diagnosis, and "disk 5" is the disk that asks to be initialized.
I could make this issue a separate post.


Translucency said:

The other RAID-member disks would show as uninitialized disks,

To clarify, since my disk manager is littered with drives:
I am not seeing the the individual disks of the array (3 of them)
The manager sees the volume as ONE 1990.97GB volume, just one that has somehow become "unallocated"
(why it is not a 2095GB volume is another question posted HERE )

As I related above, simply reinstalling windows should not have made this volume "unalocated" after I installed all of the drivers and managers.


Translucency said:
Should you need additional help feel free to ask.

Thanks again Translucency,
You have been the only one to reply this thread, and as I said the manufacturer's support is useless.
Maybe others are scratching their heads on this as well, as no one else has offered me an explanation.


April 24, 2009 10:45:51 PM

This just happened to me as well, sounds pretty much the same but I have a Marvel Raid 0, on an Intel board that has an Intel Raid as well on the same board. Marvel says raid ok, Windows sees it a 1 drive and says it has not recognized file system on it and wants to format it. My data is backed up but I was hoping to be able to fix it instead of formatting and restoring (movies) from back up. I bet it takes 24 hours or more for 3 TB. If any one knows how to get Vista 32 to see this again let me know.
May 13, 2010 2:52:14 AM

I will have to try out the R-Studio. I put the drives into my computer to try the software raid of linux and I still could not mount the raid. It did not see the drives in the raid. I will try hooking it up back in the housing and boot up linux again with the raid software installed.
!