Sign in with
Sign up | Sign in
Your question

Error 17, RAID0, Vista 64 Installation and Boot

Last response: in Storage
Share
March 30, 2009 8:31:21 PM

I run the following system:
- Upgrading to Vista 64bit - have Vista 32bit on 250Gb disk
- Q6600 B3 @ 2.4GHz
- 4x 1Gb Geil Black Dragon PC8500
- 4x Spinpoint F1 500Gb (RAID 0) - new, currently blank
- 1x 7200.10 250Gb
- ATi 4870

Tried to install Vista 64 on RAID, with 250Gb drive disconnected.

Installed from DVD and partitioned RAID array, as follows:
1. 300Gb - Intended for Vista + Programs
2. 10Gb - Swap file
3. ~1.6Tb - All other data
(All set as primary partitions during Vista install)

Accidentally installed Vista 64bit onto 1.6Tb partition.

On boot (250Gb still disconnected) would not boot, with "Error 17":

acpi vistaloader 2.1.2
find --set -root /bootmgr
Error 17: file not found

fallback XP/windows 2000/NT
find --set -root /ntldr
error 17: file not found.

On reboot to origonal 32bit Vista, the RAID 0 array is seen with partitions and Vista 64bit files, including file "missing" bootmgr in correct location.
Can also read and write to the array impling that hardware is ok.

Array drivers were not specifically installed at any stage. Drives are setup using motherboard SATA Intel RAID controller.
RAID array drives are not visible in the standard bios, are visible in RAID bios - as expected.
It does not seem possible to specify a boot partition.


I have seen the "Error 17" problem raised in various forms but no resolution.

What do I need to do to get Vista 64bit to boot from the RAID 0 array?

Jeremy

a b G Storage
March 31, 2009 3:36:12 AM

You need to install the RAID drivers for the pc to boot off of the array. It was the first option available upon windows install. First you need the drivers on a floppy or usb device. Then right at the beginning of the windows install, hit f6 when option appears. It will then ask which drivers you want, click your available drivers. It will install the RAID specific drivers. Then it will continue through the rest of the windows install.

You need those drivers to get windows to install on the array you have set up.
March 31, 2009 7:19:24 AM

Thanks aford, great reply.

I'm not entirely sure which drivers I need to install - link to gigabyte page:

http://www.gigabyte.com.tw/Support/Motherboard/Driver_M...(64-bit)#anchor_os

The board has 8 SATA ports, 6 on Intel chipset and 2 on gigabyte and the RAID is set from the Intel ones - so I assume I need the intel ICH9R drivers?

Thanks

Jeremy
Related resources
a b G Storage
March 31, 2009 7:30:04 AM

If you are on the intel chipset, you are correct. You want the preinstall drivers.
March 31, 2009 9:06:08 AM

Ok, the pre-install ones on the gigabyte website note that they are for non-Vista operating systems?
Are they definately the right ones?

Thanks again
Jeremy
a b G Storage
March 31, 2009 3:07:11 PM

Good catch. I missed that part. You want the ICH9R drivers that support vista (3rd option).
March 31, 2009 8:43:20 PM

Right an update.
- The full drivers aren't valid for install on Vista 64bit install.
- The pre-install drivers do install and seem to deal with Error 17.
- RAID partitions are still visible under 32 bit install.

However, I now have a new boot error obtained after complete installation of Vista as OS tries to boot from HDD for first time, possibly Error 28:

acpi
Vista Loader 2.1.2

Done!
Fallback 1
find --set-root /bootmgr

Unrecognised partition on drive 81. Please rebuild it using Microsoft Compatible FDISK tool (err=28). Current C/H/S=983/17/63


If I follow though I drop to a grub command prompt.

Now I'm deeply confused.

Jeremy

a b G Storage
March 31, 2009 10:58:21 PM

It appears the original partition, from the first time you tried the install, still exists.

You can boot each HD with your OS disc and delete any existing partition. But don't install anything. Just remove the partition.

Then you should be able to create your array. Then boot off of an OS disc. Then install your RAID drivers. Then continue windows install.
a b G Storage
March 31, 2009 11:35:36 PM

Zero write the drive - solves all sorts of issues, perhaps even destroy the Raid0 array and remake it? My ICH9 matrix raid array didnt need drivers (RAID0 aswell) - make sure aswell your DVD drive works and the rest of your hardware is aok.
April 1, 2009 7:38:49 AM

So,
I know that my hardware is fine, including the RAID disks.

The first install was to the 1.6Tb partition - which still remains on the drive. This was then formatted and the OS reinstalled onto the 300Gb partition.

I'm not entirely clear on what "zero writing" is. Or about booting from every individual drive. If you could explain a little more that would be great.

Thanks
Jeremy

a b G Storage
April 1, 2009 3:13:09 PM

What I meant was, you should start from scratch. It sounds like your original array left a partition. I would recommend treating the drives as individual discs for the moment. Plug one HD in and boot off of the OS disc. Delete any partition that is on the drive. Then exit the OS install. Then unplug that drive, and do the same for the 2nd HD. You don't want to install anything on them, just delete any existing partitions.

Then you can create your array, load the RAID drivers, and install windows.
April 2, 2009 8:03:49 AM

Thanks for all your help. It is now sorted.

I delete the left over partitions when installing Vista, then reinstalled the drivers, then recreated the partitions and it is now sorted.

All I have to work out now is how to move all of my work etc from the old install to the new one. Currently Vista has locked my out of my old user's file - which isn't that helpful!

Jeremy
a b G Storage
April 2, 2009 3:42:22 PM

So the array is installed and working as expected?

April 2, 2009 4:41:46 PM

Yep, the array is now fine. Thanks very much for the help!

I'm waiting on a copy of office then I'll move all of my files over to the 64bit version - if I can convince Vista to let me.

Jeremy
!