USB Flash and Free Agent Go drives failing

Something seems a bit odd to be a coincidence. First, my PNY 8GB flash drive failed. It was working fine then nothing at all. When plugged into a USB port on any of my 3 laptops or desktop, it is not recognized, the tiny light on the drive does not come on...nothing at all. The same day, my Lexar thumb drive failed in exactly the same way.
Last night, my Free Agent Go 500GB mysteriously died suddenly. Again, I tried it on all 3 of my laptops and my desktop PC...no detection, lights...nothing. I tried one of my other flash drives and an older Free Agent drive and both of them work fine on all my computer USB ports.

The only thing I can think might be killing my drives is a Targus USB port extension. It seems like all 3 of my drives failed after plugging them into the Targus 4-port extension. Is there any way that extension could somehow short out the drives and disable them? It has an electrical adapter so maybe that's sending a power surge through and killing my drives???

Anyway, this is a real mystery and any help would be appreciated.
2 answers Last reply
More about flash free agent drives failing
  1. If the voltage regulation in the port extender was faulty it would (probably) destroy thumb drives, if you know someone with a multi-meter they could easily test it for you (with a little help from Google to identify the power pins).
  2. Thanks. That could very well have been the problem. I just returned the Free Agent Go to Best Buy and they plugged it in and confirmed that the drive was totally dead. Something (probably the port extender) must have been frying my drives.
Ask a new question

Read More

Flash Media Storage