Sign in with
Sign up | Sign in
Your question

Getting random blue screens

Last response: in Systems
Share
February 27, 2008 12:05:03 AM

I just finished building my new system, and it keeps giving out blue screens at seemingly random times. It boots up, and all looks well. But after a while, the blue screen comes up. When the computer reboots, the chkdsk utility runs. And it usually says stuff like 'correcting minor error in such-and-such' or 'deleting such-and-such'.

Here's what the last blue screen said:

PAGE_FAULT_IN_NONPAGED_AREA

*** STOP: (0xBAF7A000, 0x00000001, 0x80645747, 0x00000000)


And here's a list of all my components:

CPU: Intel Core 2 Duo E8400
Motherboard: XFX MB-N780-ISH9
RAM: Corsair 4GB PC2-6400 DDR2 DIMM Dual Channel Memory Kit
Video Card: EVGA 512-P3-N841-A3 GeForce 8800GTS 512MB (Two, in SLI)
Sound Card: Creative SB X-Fi XtremeGamer
PSU: Thermaltake Toughpower W0133RU 1200W
Hard Drives: 2 Seagate Barracuda 7200.11 ST3500320AS 500GB 7200 RPM SATA-300 Hard Drives where I store all my files and applications, with a Western Digital Raptor WD740ADFD 74GB 10,000 RPM SATA-150 as the primary boot drive with Windows on it
DVD Drive 1: Samsung 20X DVD±R DVD Burner with LightScribe Black SATA Model SH-S203N
DVD Drive 2: Asus Black 16X DVD-ROM 48X CD-ROM SATA DVD-ROM Drive Model DVD-E616A3T
Case: Antec 900
OS: Microsoft Windows XP Professional with SP2

More about : random blue screens

February 27, 2008 12:39:25 AM

Hello! if the voltage on the RAMs are 1.8 in BIOS, try setting them at 2.0.
i had the same problems with my KingMax modules. 2.0 volt, and no more random BSODs.

Some might even require 2.2 volts. cheers!!!!
Related resources
February 27, 2008 4:59:24 PM

Ok, I changed the memory voltage to 2.0, and started the computer up. It ran the chkdsk utility again, and I recognized wmplayer.exe in the list of stuff it was deleting. Then it booted into Windows, and sure enough, wmplayer.exe wasn't there, so I reinstalled it. But then I tried to play a game, (Oblivion,) and the screen was totally black, but the sound was working. So I hit ctl-alt-delete, and a thing came up saying something about video drivers. Then the computer froze. I pushed the power button to turn it off, and then turned it back on. And it booted up fine. Then I reinstalled the video drivers, and tried playing Oblivion again, and this time, it worked - for a while. Before long, another blue screen came up, saying something different this time:

DRIVER_IRQL_NOT_LESS_OR_EQUAL

STOP: 0x000000D1 (0xBAEF17C0, 0x00000002, 0x00000001, 0xBAADAEF2)

HIDCLASS.SYS - Address BAADAEF2 base at BAAD8000, DateStamp 41107d52


I'm thinking that chkdsk deleting all that stuff broke something in the OS, and I may need to reinstall?


(By the way, I ran memcheck for 11 passes overnight before changing the voltage, and there were no errors.)
February 27, 2008 5:27:07 PM

I once had a system act like that, don't know about randomly deleting things, but on mine I ended up having to get a new mobo. The mobo stopped recognizing that there were any drives attached to it.
February 27, 2008 5:46:35 PM

I don't think your PSU is beefy enough. I'd consider a small fusion powered reactor to generate more stable power. And once I took care of that... yeah, I'd test the memory. If you still can't nail down your problem, go with 1 video card and just one memory module, remove the sound card and ditch the optical drives as well... anything to simplify your setup.
February 27, 2008 10:12:45 PM

I just tried taking everything apart, and putting it back together, per my dad's suggestion. I wiped all the hard drives clean, (didn't have anything very important saved on them,) and reinstalled Windows. And it worked just fine. I installed the video drivers. Worked just fine. I installed the sound card drivers. It started installing, but before it finished: poof! Blue screen. I hadn't remembered to change the setting to stop it from automatically restarting, so I don't know what it said.

However, I remember when I installed Windows the last time, that it gave a blue screen when installing the audio drivers. So, does that mean it's probably a problem with the sound card and/or the audio drivers?
February 27, 2008 10:59:08 PM

Now when you put it up that way it could be very possible. =o
if it has happened before and happened again that is pretty likely
that is the problem.
February 28, 2008 3:16:42 AM

I uninstalled everything from Creative, and then rebooted. I sat around for a while, just playing Solitaire and stuff, and there were no blue screens. Then I started running Stress Prime 2004, and one hour later, it had no errors to report, and there were no blue screens. Then I downloaded the latest drivers from the Creative website, (I had been using the ones that came on the CD,) and the installation went flawlessly. So now that I have sound again, I'm going to try running Oblivion again tomorrow, (getting rather sleepy right now...) and see if it crashes again. If not, then I guess I just got a bad batch of drivers on the CD...

I guess we'll know tomorrow!
February 28, 2008 11:19:39 AM

If it crashes again, eliminate the add-on cards leaving only the video. if that still crashes, disable onboard audio, network, firewire, etc. If that still crashes, something wrong with the mobo. If not, enable a feature in bios & boot xp. If it checks out, enable one more until all are enabled. Do boot xp each time. Last install your pci cards one by one & boot xp each time to verify.
February 28, 2008 5:03:21 PM

It crashed again... I wasn't even doing anything much, just looking around in My Computer.

It was the same error as the last one, the 'DRIVER_IRQL_NOT_LESS_OR_EQUAL and HIDCLASS.SYS' error.

What is hidclass.sys, anyway? What does it have to do with?
February 28, 2008 5:20:45 PM

By a first thought i think hidclass has to do with USB mouses and USB keyboards. but i have to google to be totally sure =X *brb*
February 28, 2008 7:14:57 PM

Strobeflux said:
maybe this could be of any information and/or help
http://support.microsoft.com/kb/924941

I don't have any Bluetooth stuff, so I doubt that's it. But I do have a USB keybooard and mouse. (The mouse being wireless.)

*Shrugs* I installed that update anyway, just in case it does help some.
February 29, 2008 10:55:12 AM

You only have to jot down the hex error code & any offending file. i.e.

0x00000070
hidclass.sys

Google it.
February 29, 2008 5:37:01 PM

Huh, maybe that update DID help some! After installing it, I haven't gotten a single blue screen! I ran Oblivion, and even Crysis, for a while, and no blue screens.

Thanks a bunch for all your help, guys! :) 
February 29, 2008 6:25:40 PM

i had the exact same problem "DRIVER_IRQL_NOT_LESS_OR_EQUAL" two weeks ago when i bought my new system... after two weeks of research i managed to solve the problem.

This error is an IRQ (Interrupt Request) error... its basically to do with USB devices being shared or a NIC (Network Interface Card aka Network Card) related problem............the problem with my system was that i had a modem connected to the mobo via USB. I chucked the USB connection and connected the modem via Ethernet cable. Solved the problem. I suggest you try the same.
!