Sign in with
Sign up | Sign in
Your question

XP Pro SP2 does not see more than 2GB ram

Last response: in Memory
Share
April 18, 2008 12:43:24 PM

Recently installed 4 1gb Corsair XMS2 6400C4 memory sticks on a Asus P5B Deluxe motherboard. After enabling memory remaping the bios upon boot will detect all 4GB of ram but in xp pro properties it sees only 2gb. I have tried the 3gb and pae switch and still it won't work. Any suggestions?

More about : pro sp2 2gb ram

April 18, 2008 2:35:58 PM

Do you know what the pae switch does? you really should not modify that for home use. What video card(s) are you running? what else do you have installed?
Related resources
a b } Memory
April 18, 2008 3:15:11 PM

Full system specs please.

even with PAE(Physical Address Extension) you will be limited to 4 gigs max, but this includes all addressable space like your video card(s) and other devices with onboard memory.

I have 3 gigs with SP2 and it works fine...also works fine with SP3 beta.
April 18, 2008 3:16:15 PM

Well the PAE switch is enabled by default I thought, at least in XP Pro SP2. I believe the indication is when you right-click on 'My Computer' and you see "Physical Address Extension" at the bottom of the 'General' Tab. I know your CPU, OS, and motherboard have to support it. We know you're CPU and OS support it, and I would assume from the 'Memory Remapping' option you can enable in your bios that your motherboard should support it.

I would check to see how much RAM XP can see with 'Memory Remapping' turned off. If you can still only see 2GB then you have to much crap loaded into the memory address space by your BIOS. Do you use onboard video? you might have to disable any onboard crap that you don't use because anything MMIO will decrease the address spacing available to your RAM, effectively giving you less RAM. Even discrete graphics card memory is mapped into the memory address spacing so if you have like 2x512MB or 2x1GB video cards then that'll compound the issue too. Maybe that is the issue and your memory remapping on your board just isn't working. If you can't get more memory seen by XP by disabling onboard stuff then I would call ASUS as it would seem your board is not really 'Remapping' memory at all.

Arson94
April 18, 2008 4:33:06 PM

You cannot get SP2 to go beyond 4GB, so you need to leave that memory remapper disabled.
April 18, 2008 6:38:54 PM

After searching for awhile I found that other people with the ASUS P5B Deluxe board also had this problem. They had to disable memory remapping which caused the bios only to see 3GB but XP Pro now detects 2.93GB ram. I guess that's the best I will get. I have read of others getting about 3.5GB deteted in xp and that is what I was trying to get. I knew I would never get the full 4gb with a windows 32bit os but am ready for when I upgrade to a 64bit os.

XP pro SP2
E6600
Asus p5b deluxe latest bios
8800GT 512mb
4GB corsair xms2 6400c4(4x1gb)
2x samsung s203b dvd burners
2x250gb wd hd drives
1x320gb seagate hd
sound blaster x-fi extreme
April 18, 2008 6:46:11 PM

Why oh why does everyone say "windows will only see 3.xx GB of memory"?

Not windows.... 32Bit operating systems can only address 4GB of ALL, i repeat ALL physical memory. This is ANY physical memory, so your video card memory must be allocated, therefore forcing "windows" (any 32bit operating system) to address video card memory and causing your available RAM to appear as though "windows" only addresses 3.xx GB of memory.

RESEARCH
a b } Memory
April 18, 2008 6:47:10 PM

I would still try to disable anything you do not use. you may be able to squeeze a bit more.

It still never lines up with all addressable memory...since adding a 4 megabyte pci card to my system lost me 256 megs of ram...

The most i ever managed to free. but to loose my 8800GTX it was not worth it...with it i get 3.25 i just stuck with 3 gigs in the end.


8800GTX - looks good. 768 missing


8800gtx + 4 megabyte PCI video card
April 18, 2008 6:51:53 PM

boonality said:
Why oh why does everyone say "windows will only see 3.xx GB of memory"?

Not windows.... 32Bit operating systems can only address 4GB of ALL, i repeat ALL physical memory. This is ANY physical memory, so your video card memory must be allocated, therefore forcing "windows" (any 32bit operating system) to address video card memory and causing your available RAM to appear as though "windows" only addresses 3.xx GB of memory.

RESEARCH


Everybody keeps saying that because it is very possible to do so in a 32-bit x86 OS. The memory manager in xp/sp2 and vista just doesn't allow it
April 18, 2008 8:04:16 PM

Well some people just don't seem to get the correlation... 32-bit OS's use 32-bit memory addresses = 2^32 = 4294967296 bytes = 4GB.

In case anybody is interested, here's an article I found way back when I didn't really know the issue that well. It goes into some good detail. Maybe it's helpful to somebody out there...

http://www.hardforum.com/showthread.php?t=1035670

Arson94
April 18, 2008 8:08:45 PM

32bit OSes uses 32-bit addresses for their virtual address space. The number of bits used on the physical side is not related to this in any way
April 18, 2008 8:36:57 PM

^^ true, but i was just saying that video card memory MUST be addressed is all, there is alot that goes into addressing that we should not hijack this thread over.

Sorry
a b } Memory
April 18, 2008 8:48:29 PM

Quote:
Kill yourself now!

WTF? STFU!
a b } Memory
April 18, 2008 8:51:05 PM

nukemaster said:
I would still try to disable anything you do not use. you may be able to squeeze a bit more.

It still never lines up with all addressable memory...since adding a 4 megabyte pci card to my system lost me 256 megs of ram...

The most i ever managed to free. but to loose my 8800GTX it was not worth it...with it i get 3.25 i just stuck with 3 gigs in the end.
http://img382.imageshack.us/img382/761/38081570he2.gif

8800GTX - looks good. 768 missing
http://img475.imageshack.us/img475/3733/95946067ql0.gif

8800gtx + 4 megabyte PCI video card
http://img452.imageshack.us/img452/4529/84516110xo7.gif

Nuke, how did you get the radiation symbol on that? Did you edit the image or is it actually part of the dialog box?
a b } Memory
April 18, 2008 9:03:52 PM

In the system32 directory add a file called OEMINFO.INI

Make it look like this just take what is in the lines...not the lines them selves.
________________COPY UNDER HERE___________
[General]
Manufacturer=Shadow703793 Systems
Model=Shadow's Overclocked boomstick

[Support Information]
Line1=What are you looking in here for?
Line2=
Line3=
Line4=
Line5=
Line6=
Line7=
Line8=
Line9=
__________STOP HERE_____________

Now take whatever picture you want...mine was scaled to 96 x 96.. a little bigger should work. save it with the name and format as Oemlogo.bmp(i do not think the cap matters) in the system32 directory. that should be it.
a b } Memory
April 18, 2008 9:31:35 PM

^Sweet. Will try that. Thanks for the info.
!