Sign in with
Sign up | Sign in
Your question

DXDiag help with Vid card.

Last response: in Graphics & Displays
Share
March 8, 2008 9:24:27 PM

I ran the Direct3d test on my video and had some strange conclusions.

Hardware accelerated Direct3d 7 interface-no problems, the spinning box looked fine.

Hardware accelerated direct3d 8 interface-Box was slightly broken up, but not completely.

Hardware accelerated direct3d 9 interface-The spinning box was totally mutilated.

Im running a Radeon 9800XT(AGP). I have downloaded and installed the latest drivers(for the card) and the latest bios for the MB. Also, none of the games I play work in 3d anymore. 2d stuff works fine.

System specs:

P4 3.0mhz
1 gig ram
Radeon 9800XT


Any help would be appreciated. Thanks.

More about : dxdiag vid card

a b U Graphics card
March 8, 2008 9:38:34 PM

Did you check to make sure the drivers were supporting your card? Have you tried older ones?
March 8, 2008 9:41:34 PM

Yea, I tried older ones. Tried some NGO ones also. I got the latest drivers right from ATI/AMD site. Im just baffled by it. I have also installed windows XP 2x and reinstalled all drivers.
Related resources
March 8, 2008 9:52:33 PM

Thanks, ill give it one more shot.
March 8, 2008 10:10:20 PM

I installed the DX and 8.3 drivers from the page you linked. Now I get "No 3d device found" and the below posted message in Dxdiag.

No problems found.
To test DirectDraw functionality, click the "Test DirectDraw" button above.
Direct3D functionality not available. You should verify that the driver is a final version from the hardware manufacturer.
a b U Graphics card
March 8, 2008 10:23:08 PM

Try a reboot. If that doesnt work, uninstall old driver, reboot, dont let windows install new driver, and download/install new driver from AMD
March 8, 2008 10:26:44 PM

How do I "not let windows" install new driver?? Never done that before
March 8, 2008 10:46:12 PM

Still no luck. Still no 3d device found and:
Direct3D functionality not available. You should verify that the driver is a final version from the hardware manufacturer.


Anyone with any other suggestions?
a b U Graphics card
March 8, 2008 11:16:40 PM

First uninstall ALL graphics drives. Then run Drive cleaner to get rid of all old versions. Link:
http://downloads.guru3d.com/download.php?det=745

Download the drives and boot in to SafeMode. Then try installing the drives, re boot and see.

Also make sure the card is not hot and not OCed too much.

March 9, 2008 4:47:43 AM

Shadow, I tried what you suggested. I ran into 1 problem though. In safe mode, I couldnt install the drivers. It said No hardware was found compatible with the the drivers, so it cancelled the install.

So I came back into XP normal mode and then installed the drivers again. Still no luck. It says NO 3D Device found. I cant even test it in DXdiag because direct 3d acceleration is not available.

As for the card being too hot, I dont think it is, I use a couple monitoring devices and they are in the green.

Also, what does OCed mean?

If anyone else has suggestions, I would be grateful.
a b U Graphics card
March 9, 2008 5:03:09 AM

OC means over clocked. Hold on Ill see if I can find something..
a b U Graphics card
March 9, 2008 5:07:22 AM

Have you or did you do anything at all before these problems started?
March 9, 2008 5:07:31 AM

ok thanks.
a b U Graphics card
March 9, 2008 5:11:55 AM

Have you installed anything new on your system? USB devices or wireless?
March 9, 2008 5:16:15 AM

Nothing new, however keep in mind that I did reinstall windows 2x and format 2x.
March 9, 2008 5:28:38 AM

I just DL Aquamark3 and it says no graphics device is found also. But then I check the Device Manager and its says the card is functioning properly. Haha, This thing has me banging my head on the wall.
a b U Graphics card
March 9, 2008 5:38:43 AM

Remove the card, power off of course, then reboot without the card. Remove the driver too before rebooting. After rebooting, dont let windows find driver, shut down, reinstall card, reboot, dont let windows install driver, download driver and that should work
March 9, 2008 5:43:43 AM

ok, ill give this a shot in the morning. Ill post what happens when I try it. Thanks again for the help.
a b U Graphics card
March 9, 2008 5:52:18 AM

yw
March 9, 2008 6:33:02 PM

Gave your idea a shot. Still no luck. I got a message on reboot from microsoft after i did a error report. It said something along the lines of Driver Error, reboot again or install drivers again. So im going to try that now.
a b U Graphics card
March 9, 2008 7:13:15 PM

In the BIOS did enable AGP ?
March 9, 2008 7:31:38 PM

Yes, I made sure of that after i installed the new bios. I installed old drivers again and then reinstalled directx 9.0c. The pc still wont find the 3d device. I cant even test it on aquamark to see if any of the changes helped with the texturing.
March 9, 2008 7:34:12 PM

Direct3D functionality not available. You should verify that the driver is a final version from the hardware manufacturer.

Thats what is located in the Dxdiag notes section now. I currently have the ATI 7.8 drivers.
March 9, 2008 7:50:00 PM

If you didnt, make sure always have the Motherboard drivers installed aswell
, as this will correctly enable AGP acceleration and other nice features.

I always had this problem on a newly installed system when i used my old Pentium IV board, until i installed the mobodrivers.

but maybe you allready did, i dont know ;) 
March 9, 2008 7:52:08 PM

Yea, they are installed..if your meaning the chipset drivers?

Anyone else have any suggestions or thoughts? Id at least like to get back to the 3d device being found, so i can test out some the ideas mentioned above.
March 9, 2008 7:55:59 PM

Yepp. Chipset drivers! So, that problem out of the way...... hmmm....
March 9, 2008 8:23:15 PM

ok ill try that...i just got this message on a reboot

Problem caused by Device Driver

You received this message because a device driver installed on your computer caused the Windows operating system to stop unexpectedly. This type of error is referred to as a "stop error." A stop error requires you to restart your computer.

March 9, 2008 8:26:29 PM

actually, i already tried the 8.3 drivers. Several times between last night and today
a b U Graphics card
March 9, 2008 8:27:10 PM

Did you actually remove the card from your rig, and then reboot without it? It may be a IRQ or a GART issue
March 9, 2008 8:40:46 PM

yea, i removed it, rebooted it..it beeped like 50 times..i then shut it back down, put the card back in and rebooted in safe mode, installed drivers again from there.

I had a bit of progression though just now on a seperate note. I installed some NG modded ATI drivers and they actually let the pc detect the 3d device now. But im back to the original problem I posted at the start of this thread(messed up texturing/geometry basically in games). Why would NG drivers detect the card but not the actual ATI drivers..Man, this is insanity:) 
a b U Graphics card
March 9, 2008 9:00:11 PM

You never mentioned "(messed up texturing/geometry basically in games" Thats an entirely different problem, or approach. Have you checked your temps? Whats about your power supply? This is a whole new ballgame now...
a b U Graphics card
March 9, 2008 9:04:45 PM

^ Agreed.
March 9, 2008 9:50:10 PM

yea, temps are fine. i have 3 total fans cooling my card. as for the ps, i dont know how to really check it. It seems to be working fine. Also, its a combination of problems

1: the original post-direct 7,8,9(in dxdiag testing)..7 worked fine, 8 a little messed up, 9 totally mutilated

2: When I do install new drivers ie. 8.3 catalysts, my pc dont recognize the 3d device at all. that includes several other old ati drivers.

3: NG Drivers for ATI(v 1.73) do find the 3d device, but then thats when the graphics are all messed up.

those are the 3 problems...They are all kinda of intertwined with each other.
March 9, 2008 10:28:35 PM

Umm it may be dull but it could be that your card has popped out a bit from its slot so could you try to double-check that? You need to remove the screw and reinsert it into it's slot. It happened a few times and it was exactly like you describe it with your directX stuff.

EDIT: corrected some typos
March 9, 2008 11:01:08 PM

I doubt thats it. I have taken it out and put it back in already earlier in the post as suggested.
!