Sign in with
Sign up | Sign in
Your question

Asus mobo, Raid 0 config

Last response: in Storage
Share
April 5, 2009 3:35:04 AM

Hey, i just got myself 2 Seagate 1.5TB HDDs. I wanted to set up a RAID 0 besides my OS.
Running Winodws Vista Ultimate 32. Asus P5Q3 mobo.

I tried to create the Raid array, but it didn't seem to work. I switched my 'storage configuration' in BIOS over to RAID, created a volume and then restarted the computer. I was unable to detect my OS.
I restarted my comp, changed it back to IDE and the OS on my original drive worked again.

However i can't see either of my 1.5TB disks. Even after i returned them to the original non-raid state.

Any ideas on what i'm doing wrong?

More about : asus mobo raid config

a b G Storage
April 5, 2009 3:47:39 AM

You must install the raid drivers before installing windows on the array. You can get them from Asus's website. Make sure you get the vista 32bit RAID drivers.

First, copy the drivers onto a floppy or usb drive. Then restart the pc and go into the RAID bios. Create your array there. Then get into the mobo's bios, and make sure the optical drive is the first boot device. You then need to boot off the OS disc, and hit f6 at the beginning to install the raid drivers off a floppy or usb drive. Windows can then finish installing on the array.
April 5, 2009 4:01:59 AM

Is this process where the OS ends up sitting on the array? Because i actually would prefer my OS beign on my Raptor X 150GB.
Is it even possible to run a RAID array and have the OS not on the array?

I retried again. Got to the OS loading screen, but it freezes every time and i get a BSOD.

I am also unable to detect the old IDE WD 300GB i have in the desktop. Not sure if the issues could be connected.

Thanks for replying so fast.
Related resources
a b G Storage
April 5, 2009 4:07:25 AM

Yes it's possible. You need to do the steps I listed above, but instead of choosing to install on the array, install the OS on the single drive. You do still need the RAID drivers though.
April 5, 2009 4:34:31 AM

Alright, then that makes more sense.
Thanks for your help. I will post when i know more :) 
April 5, 2009 8:37:44 PM

Hey again. I think i need to clarify my position a bit.
Currently my computer (the one i want to add a RAID array to) looks like this:

Drives:
C: Sata Raptor X 150GB with Vista Ultimate 32bit
E: IDE WD 300GB
D: DVD-RW

I have tried to install the drivers through repair when i booted from my Vista DVD. It didn't work. I don't need to install my OS since it already is installed on my 150GB drive.

However, when i set my 'storage configuration' in bios to [RAID] instead of [IDE] my OS will not start anymore. I begin loading the OS and then i get a BSOD.

Also, once i set the bios to RAID, i can't see any of my SATA drives individually. They all get grouped into a heading like this:
[RAID] WD (serial from 150GB HDD)
and my 1.5TB HDD's are not visible anymore.

Now ill go over the steps i did as you said:
1. Convert to Raid config
2. Create a Raid volume, accessed through BIOS post message
3. Insert OS disk
4. Attempt to install Driver from flash drive. (when i tried this under the 'repair' heading of boot-up it told me 'failed installation')

Let me know what you think. I am at my knowledge end here.

Thanks for your patience.
a b G Storage
April 6, 2009 1:10:55 AM

Have you formatted the new drives in disc management yet?

Since you aren't installing windows on the RAID drives, you should be able to install them inside windows. Sorry, I may have neglected to mention that in the last post.
April 6, 2009 4:24:59 AM

Yes he should install the drivers on his existing install, then make the switch from IDE to RAID mode.
April 6, 2009 3:15:58 PM

Hi again,
I knew i forgot something (formatting the drives) that is done now. Thanks for the reminder.
When i formatted the drives, vista asked my if i wanted to create a striped volume. I said 'Ok'. Is this also a good way to create a Raid 0 volume? or is this inferior to a Raid array created through the bios?

Just asking to be sure, i'd rather create the array the proper way.

Thanks for your help.
!