Sign in with
Sign up | Sign in
Your question

External hd: access denied, just explore

Last response: in Storage
Share
April 6, 2009 2:10:04 PM

My usb external HD (not flash memory) show a strange behaviour. In Explorer (Xp Sp3) they appear as folders, not as disks, and when I click open, “access denied” appears. I can only open them with right-click and explore command. The data transfer is also very slow and with a beep from the unit (maxtor one touch mini 2.5”/120gb). The same occours with a packard bell (2.5”/120gb). I’ve runned chdisk and other Hd reapair tools through System Mechanic 8, but the troubles persists (more with desktop, less with laptop). I’ve reinstall Os and check for viruses several times (ZoneAlarm antivirus and online) and I’ve updated everything, but the bug is till there. I don’t know what else to do. Anybody has a suggest? Thanks.

Ut, florence, italy
April 7, 2009 3:55:28 PM

did the drives come with any management software? check the box.

just sounds like some clever bit of programming gone slightly wrong.
a b G Storage
April 8, 2009 7:12:31 AM

Or worse, some malware with an autorun component snuck onto your hard disk. It's possible that it's causing access to fail when you try to open the disk. What files are on the main directory of the drive?
Related resources
April 8, 2009 7:35:51 AM

have you formatted it?
April 8, 2009 6:06:46 PM

I don't know what you mean for management software.
I only use System Mech 8 with several tools (registry, hd integrity etc).
I came from a long series of virus search and reinstals (the last 24h ago).
The pc seems works fine, but every time I connect usb ext hd,
I found folder icons instead drive icons, open denied (only explore)
and the data transfer damn slow. I'm repearing right now file system
and index of maxtor though a second pc and I'll format too.
Of course I'm thinking of an outorun malware, but I've make a lot of debugs,
even online and everytime I reinstall I format everything.
After two months I'm really tired. Do you know a paper
with detailed instructions to make a deep debug of an xp pro machine.
What hell are all these antivirus and win update for !
Thanks everybody.
ut
April 8, 2009 7:04:57 PM

not talking about formatting the pc, have you formatted the external drive?
April 9, 2009 12:39:18 AM

Yes, the maxtor and now it appears correctly in explorer, both in desk and lap (but it's empty !). Tomorrow I'll try to empty the big one and format it too. I'll see. The registry repear tool in System Mech works fine in lap, but non in desk. I'll see
a b G Storage
April 13, 2009 2:36:00 AM

Any updates? Can you now open the disk normally in Windows Explorer?
April 14, 2009 10:48:24 AM

To this day any ext drive appears in expl as a folder, not as a disk, open denied, just explore. Apart from that pc is fine. For sure it's a virus, but I don't know where hell it is (after six or seven reinstall). Antivirus/firewall is Zonealarm and every microsoft patches are on. Strange that nobody talk about that on google (for my searches). thanks again.
ut
a b G Storage
April 17, 2009 9:25:18 AM

Hmmmm... can you try going to Control Panel, Administrative Settings/Tools, Computer Management, Drive Management? Your external hard disk should appear on a list; try right-clicking on it and assign a driver letter to it.
April 20, 2009 1:42:49 PM

In Drive Management everithing ok. The ext drive appears corrtectly as volume K, the only difference is the icon (folder non drive) and that I can only explore it, if I click open it replies access denied. I can even assign a different letter but what changes ?
Thank for your patience.
ut
a b G Storage
April 21, 2009 7:07:34 AM

Have you tried the disk on another computer? You may have to prepare yourself for a reformat, because I'm honestly mystified over your problem.
May 2, 2009 7:41:51 AM

Hello,

I don't mean to hijack this thread, but this is the exact same problem that I am having. Googling for advice everyone says to take ownership of the drive. I think I have ownership but I still get access denied.

This problem started for me when I was reinstalling my Windows XP. After installation, it said that there was some problem with Explorer (I think I saw it said a problem associated with a file called BX(?)). But I continued to connect my external USB HD drives. The second first one got the usual HD icon, but the second external drive became a file icon.

And that I got access denied. Oddly, when I turn off the drive and turn it back again, after autoplay, I can ask to open it with explorer. But directly accessing it is denied.

I believe the original person and I are having similar problems.

I would like to get this fixed without having to format the entire drive (its 240GB full of my data).

Any ideas?

W.

a b G Storage
May 6, 2009 3:15:01 AM

I'm still quite mystified by what happened here... according to the OP his system is clear of viruses or malware, eliminating that as a cause.

And I don't think formatting the drive would fix anything anyway... the problem is probably with how the OS sees the hard drive, and not the hard drive itself.

The only suggestion I have left is to reformat and reinstall Windows. Sorry I couldn't be of more help :( 
May 6, 2009 3:00:50 PM

you can formate it
July 25, 2009 4:58:33 AM

Hi guys,

Thanks to forums like these, I've come across lots of problems that I know would have taken days if not weeks to solve, not counting nightmares!

Urbantucan's dilemna is one of them, and I want to share a solution that I hope will solve his problem.

1. Do either one of the following [ a. or b. ]:
a. Turn off the Autorun feature of your device (your external hard drive):
1) right-click device -> properties
2) click AutoPlay tab. Under "Actions", click "Select an action to perform" radio button
3) click on "Open folder to view files" to highlight it, then click "OK" button
b. Prompt action to take:
1) right-click device -> properties
2) click AutoPlay tab. Under "Actions", click "Prompt me each time to choose an action"
radio button, then click "OK" button.
2. See if you can open your device (your external hard drive) by double-clicking it.
If you still get an "Access denied" message, release it, unplug it, then plug it in again.
3. If you followed 1.a. above, you should get a window that displays the contents of your
hard drive. If you followed 1.b. above, you should be prompted to take action. Click on
"Open folder to view files", then you should get a window that displays the contents of
your hard drive.
4. Set your folder options to show hidden and system files:
a. click "Tools->Folder optons..."
b. click "View" tab and under "Hidden files and folders", enable "Show hidden files and
folders"
c. uncheck "Hide extensions for known file types"
d. uncheck "Hide protected operating system files [Recommended]"
5. Your hard drive window contents will most likely now show a file called "Autorun.inf"
whose content most likely includes a command line to execute a file (usually another
"Autorun.exe") in either the "Recycled" or "Recycler" subfolder.
6. DELETE, I repeat, DELETE this "Autorun.inf" file.
7. Then, also delete both the "Recycled" or "Recycler" subfolders.
8. Release your external drive.
9. The next time you plug your external hard drive in, you should have your regular icon
back, and your "Access denied" problems gone!
10. Good luck!!!

September 22, 2009 7:24:50 PM

This has been driving me demented for the past couple of days and EuSnake has got it absolutely right!

You're a star man, thank you very much indeed.
April 6, 2010 9:47:08 PM

I actually had the exact same problem on my external.

I discovered the problem and the solution.

It's in a (hidden) folder on the external named nano with an exe called banana.exe. When you look at the file origin author/ origin data its an WS8SKNirs8F.exe file.

It's a virus related somehow to the File img87.pif .

The solution I've found is simply to delete the entire nano folder. Then totally empty the Trash and turn off the external drive and reboot it. Should resolve the issue. Did for me.

File reference: File img87.pif

Site reference: http://www.virustotal.com/analisis/564a8371a452048c8520...
May 22, 2010 12:12:47 PM

EuSnake said:
Hi guys,

Thanks to forums like these, I've come across lots of problems that I know would have taken days if not weeks to solve, not counting nightmares!

Urbantucan's dilemna is one of them, and I want to share a solution that I hope will solve his problem.

1. Do either one of the following [ a. or b. ]:
a. Turn off the Autorun feature of your device (your external hard drive):
1) right-click device -> properties
2) click AutoPlay tab. Under "Actions", click "Select an action to perform" radio button
3) click on "Open folder to view files" to highlight it, then click "OK" button
b. Prompt action to take:
1) right-click device -> properties
2) click AutoPlay tab. Under "Actions", click "Prompt me each time to choose an action"
radio button, then click "OK" button.
2. See if you can open your device (your external hard drive) by double-clicking it.
If you still get an "Access denied" message, release it, unplug it, then plug it in again.
3. If you followed 1.a. above, you should get a window that displays the contents of your
hard drive. If you followed 1.b. above, you should be prompted to take action. Click on
"Open folder to view files", then you should get a window that displays the contents of
your hard drive.
4. Set your folder options to show hidden and system files:
a. click "Tools->Folder optons..."
b. click "View" tab and under "Hidden files and folders", enable "Show hidden files and
folders"
c. uncheck "Hide extensions for known file types"
d. uncheck "Hide protected operating system files [Recommended]"
5. Your hard drive window contents will most likely now show a file called "Autorun.inf"
whose content most likely includes a command line to execute a file (usually another
"Autorun.exe") in either the "Recycled" or "Recycler" subfolder.
6. DELETE, I repeat, DELETE this "Autorun.inf" file.
7. Then, also delete both the "Recycled" or "Recycler" subfolders.
8. Release your external drive.
9. The next time you plug your external hard drive in, you should have your regular icon
back, and your "Access denied" problems gone!
10. Good luck!!!


EuSnake, I have a similar problem but \I am running WIndow7 and get the same message Drive I in not accessable. I tried your fix but no can do. I can see it listed as drive but can not access. I have looked under Auto play and it is not showing as a device so unable to access Actions.
July 16, 2010 5:31:39 PM

WOW I have been battling this problem for some time now, thank you for your help.
EuSnake said:
Hi guys,

Thanks to forums like these, I've come across lots of problems that I know would have taken days if not weeks to solve, not counting nightmares!

Urbantucan's dilemna is one of them, and I want to share a solution that I hope will solve his problem.

1. Do either one of the following [ a. or b. ]:
a. Turn off the Autorun feature of your device (your external hard drive):
1) right-click device -> properties
2) click AutoPlay tab. Under "Actions", click "Select an action to perform" radio button
3) click on "Open folder to view files" to highlight it, then click "OK" button
b. Prompt action to take:
1) right-click device -> properties
2) click AutoPlay tab. Under "Actions", click "Prompt me each time to choose an action"
radio button, then click "OK" button.
2. See if you can open your device (your external hard drive) by double-clicking it.
If you still get an "Access denied" message, release it, unplug it, then plug it in again.
3. If you followed 1.a. above, you should get a window that displays the contents of your
hard drive. If you followed 1.b. above, you should be prompted to take action. Click on
"Open folder to view files", then you should get a window that displays the contents of
your hard drive.
4. Set your folder options to show hidden and system files:
a. click "Tools->Folder optons..."
b. click "View" tab and under "Hidden files and folders", enable "Show hidden files and
folders"
c. uncheck "Hide extensions for known file types"
d. uncheck "Hide protected operating system files [Recommended]"
5. Your hard drive window contents will most likely now show a file called "Autorun.inf"
whose content most likely includes a command line to execute a file (usually another
"Autorun.exe") in either the "Recycled" or "Recycler" subfolder.
6. DELETE, I repeat, DELETE this "Autorun.inf" file.
7. Then, also delete both the "Recycled" or "Recycler" subfolders.
8. Release your external drive.
9. The next time you plug your external hard drive in, you should have your regular icon
back, and your "Access denied" problems gone!
10. Good luck!!!

Anonymous
a b G Storage
July 20, 2010 3:19:41 PM

Hi! Just wondering if you have any idea of what to do with this problem;

I've got problems with my external harddrive from Iomega. (500gb).

When I connect it to my computer (Windows Vista 32-bit), It appears in "My computer" like it's supposed to, but when I open it, all maps in the drive are "Shortcuts" instead of "Filemaps". When I try to open a map in the drive, nothing happens, and after a moment I get this strange thing called c.exe wanting to acces my computer.

I think my harddrive has been infected by some sort of virus or something, but I really need the data from my drive, because it's about 260 gbs I've put into it.

I need help how to fix this!

August 8, 2010 2:44:27 PM

EuSnake said:
Hi guys,

Thanks to forums like these, I've come across lots of problems that I know would have taken days if not weeks to solve, not counting nightmares!

Urbantucan's dilemna is one of them, and I want to share a solution that I hope will solve his problem.

1. Do either one of the following [ a. or b. ]:
a. Turn off the Autorun feature of your device (your external hard drive):
1) right-click device -> properties
2) click AutoPlay tab. Under "Actions", click "Select an action to perform" radio button
3) click on "Open folder to view files" to highlight it, then click "OK" button
b. Prompt action to take:
1) right-click device -> properties
2) click AutoPlay tab. Under "Actions", click "Prompt me each time to choose an action"
radio button, then click "OK" button.
2. See if you can open your device (your external hard drive) by double-clicking it.
If you still get an "Access denied" message, release it, unplug it, then plug it in again.
3. If you followed 1.a. above, you should get a window that displays the contents of your
hard drive. If you followed 1.b. above, you should be prompted to take action. Click on
"Open folder to view files", then you should get a window that displays the contents of
your hard drive.
4. Set your folder options to show hidden and system files:
a. click "Tools->Folder optons..."
b. click "View" tab and under "Hidden files and folders", enable "Show hidden files and
folders"
c. uncheck "Hide extensions for known file types"
d. uncheck "Hide protected operating system files [Recommended]"
5. Your hard drive window contents will most likely now show a file called "Autorun.inf"
whose content most likely includes a command line to execute a file (usually another
"Autorun.exe") in either the "Recycled" or "Recycler" subfolder.
6. DELETE, I repeat, DELETE this "Autorun.inf" file.
7. Then, also delete both the "Recycled" or "Recycler" subfolders.
8. Release your external drive.
9. The next time you plug your external hard drive in, you should have your regular icon
back, and your "Access denied" problems gone!
10. Good luck!!!


Thanks buddy. this was the best solution that i got to get my hard disk hooked to my desktop. it worked just fine
January 1, 2011 3:14:10 PM

Thank you oh so much! Have been having this irritating problem for months and couldn't figure out what to do about it! Thanks for taking the trouble to post a solution! I registered specially so I could thank u! :) 

EuSnake said:
Hi guys,

Thanks to forums like these, I've come across lots of problems that I know would have taken days if not weeks to solve, not counting nightmares!

Urbantucan's dilemna is one of them, and I want to share a solution that I hope will solve his problem.

1. Do either one of the following [ a. or b. ]:
a. Turn off the Autorun feature of your device (your external hard drive):
1) right-click device -> properties
2) click AutoPlay tab. Under "Actions", click "Select an action to perform" radio button
3) click on "Open folder to view files" to highlight it, then click "OK" button
b. Prompt action to take:
1) right-click device -> properties
2) click AutoPlay tab. Under "Actions", click "Prompt me each time to choose an action"
radio button, then click "OK" button.
2. See if you can open your device (your external hard drive) by double-clicking it.
If you still get an "Access denied" message, release it, unplug it, then plug it in again.
3. If you followed 1.a. above, you should get a window that displays the contents of your
hard drive. If you followed 1.b. above, you should be prompted to take action. Click on
"Open folder to view files", then you should get a window that displays the contents of
your hard drive.
4. Set your folder options to show hidden and system files:
a. click "Tools->Folder optons..."
b. click "View" tab and under "Hidden files and folders", enable "Show hidden files and
folders"
c. uncheck "Hide extensions for known file types"
d. uncheck "Hide protected operating system files [Recommended]"
5. Your hard drive window contents will most likely now show a file called "Autorun.inf"
whose content most likely includes a command line to execute a file (usually another
"Autorun.exe") in either the "Recycled" or "Recycler" subfolder.
6. DELETE, I repeat, DELETE this "Autorun.inf" file.
7. Then, also delete both the "Recycled" or "Recycler" subfolders.
8. Release your external drive.
9. The next time you plug your external hard drive in, you should have your regular icon
back, and your "Access denied" problems gone!
10. Good luck!!!

May 7, 2011 11:37:17 AM

Hi. I have a similar problem that the above eusnake advice didn't fix unfortunately. Very frustrated.

It's an external Maxtor Basics 500gb hard drive, it is recognised by windows (can explore it and has drive letter etc) but just cannot access some specific sub-folders, ie. basically half of all the data on the drive. (includes all recently downloaded movies, but for some reason older stuff like data/software open fine.)

It says "access denied" to all these. These were all folders that worked fine before I had to re-install windows XP. Could it be that maxtor external HDDs have the disrupting data (similar to the autorun.inf etc, but different) within a Host Protected Area or something?

I've heard some weird and bad things about maxtor external drives. Could anyone can help pls?!?!
May 8, 2011 2:58:53 PM

EuSnake said:
Hi guys,

Thanks to forums like these, I've come across lots of problems that I know would have taken days if not weeks to solve, not counting nightmares!

Urbantucan's dilemna is one of them, and I want to share a solution that I hope will solve his problem.

1. Do either one of the following [ a. or b. ]:
a. Turn off the Autorun feature of your device (your external hard drive):
1) right-click device -> properties
2) click AutoPlay tab. Under "Actions", click "Select an action to perform" radio button
3) click on "Open folder to view files" to highlight it, then click "OK" button
b. Prompt action to take:
1) right-click device -> properties
2) click AutoPlay tab. Under "Actions", click "Prompt me each time to choose an action"
radio button, then click "OK" button.
2. See if you can open your device (your external hard drive) by double-clicking it.
If you still get an "Access denied" message, release it, unplug it, then plug it in again.
3. If you followed 1.a. above, you should get a window that displays the contents of your
hard drive. If you followed 1.b. above, you should be prompted to take action. Click on
"Open folder to view files", then you should get a window that displays the contents of
your hard drive.
4. Set your folder options to show hidden and system files:
a. click "Tools->Folder optons..."
b. click "View" tab and under "Hidden files and folders", enable "Show hidden files and
folders"
c. uncheck "Hide extensions for known file types"
d. uncheck "Hide protected operating system files [Recommended]"
5. Your hard drive window contents will most likely now show a file called "Autorun.inf"
whose content most likely includes a command line to execute a file (usually another
"Autorun.exe") in either the "Recycled" or "Recycler" subfolder.
6. DELETE, I repeat, DELETE this "Autorun.inf" file.
7. Then, also delete both the "Recycled" or "Recycler" subfolders.
8. Release your external drive.
9. The next time you plug your external hard drive in, you should have your regular icon
back, and your "Access denied" problems gone!
10. Good luck!!!


Hi there - thanks for the reply. I've tried both A and B and run into issues with both. On Windows 7. For A, there is on Auto Play tab when I right click. For option B, I cannot delete the Autorun file. When I try it says I do not have permission and need Administrative permission. I am logged in as the Administrator.

Any ideas?

Thanks!
KC
May 31, 2011 11:02:19 AM

nzgreg said:
Hi. I have a similar problem that the above eusnake advice didn't fix unfortunately. Very frustrated.

It's an external Maxtor Basics 500gb hard drive, it is recognised by windows (can explore it and has drive letter etc) but just cannot access some specific sub-folders, ie. basically half of all the data on the drive. (includes all recently downloaded movies, but for some reason older stuff like data/software open fine.)

It says "access denied" to all these. These were all folders that worked fine before I had to re-install windows XP. Could it be that maxtor external HDDs have the disrupting data (similar to the autorun.inf etc, but different) within a Host Protected Area or something?

I've heard some weird and bad things about maxtor external drives. Could anyone can help pls?!?!


I am having exact same problem. However, I am not using a Maxtor.
March 1, 2012 8:44:39 PM

EuSnake said:
Hi guys,

Thanks to forums like these, I've come across lots of problems that I know would have taken days if not weeks to solve, not counting nightmares!

Urbantucan's dilemna is one of them, and I want to share a solution that I hope will solve his problem.

1. Do either one of the following [ a. or b. ]:
a. Turn off the Autorun feature of your device (your external hard drive):
1) right-click device -> properties
2) click AutoPlay tab. Under "Actions", click "Select an action to perform" radio button
3) click on "Open folder to view files" to highlight it, then click "OK" button
b. Prompt action to take:
1) right-click device -> properties
2) click AutoPlay tab. Under "Actions", click "Prompt me each time to choose an action"
radio button, then click "OK" button.
2. See if you can open your device (your external hard drive) by double-clicking it.
If you still get an "Access denied" message, release it, unplug it, then plug it in again.
3. If you followed 1.a. above, you should get a window that displays the contents of your
hard drive. If you followed 1.b. above, you should be prompted to take action. Click on
"Open folder to view files", then you should get a window that displays the contents of
your hard drive.
4. Set your folder options to show hidden and system files:
a. click "Tools->Folder optons..."
b. click "View" tab and under "Hidden files and folders", enable "Show hidden files and
folders"
c. uncheck "Hide extensions for known file types"
d. uncheck "Hide protected operating system files [Recommended]"
5. Your hard drive window contents will most likely now show a file called "Autorun.inf"
whose content most likely includes a command line to execute a file (usually another
"Autorun.exe") in either the "Recycled" or "Recycler" subfolder.
6. DELETE, I repeat, DELETE this "Autorun.inf" file.
7. Then, also delete both the "Recycled" or "Recycler" subfolders.
8. Release your external drive.
9. The next time you plug your external hard drive in, you should have your regular icon
back, and your "Access denied" problems gone!
10. Good luck!!!



I know it has been 3 years ago that his thread was published. Nevertheless, I have encountered the same problem just now.
I recently purchased a brand new Western Digital 1 TB ext.drive. I'm tying to open it on a completely restored Dell PC with Windows XP Pro. Unfortunately, the drive arrived in the mail without any instructions or guidelines how to set it up. There were only pictures shown how to connect it with the power supply and the USB cable. I could not find anything helpful on their website, either. They even charge for service support !
When I connected it accordingly, the light showed on the unit and I could notice that was running. It also showed up on MyComputer as a disk on drive E. When I right-clicked on the file, it showed up as Address E:\ with the following entries :
(folder) autorun clicking on this folder opened a picture of " WD"
(folder) System Volume Information clicking on this folder "Access denied"
(icon) autorun.inf clicking on this folder - nothing happened

I also tried on another PC with Win XP and so far was only able to check disc options for file system errors and bad sections. No results were shown, apparently nothing was found. And, so far I did not get "Access" denied, but still don't know how to open a file on that disk which is shown as "Used Space" for 1.25 GB ??? Free Space shows 930 GB.

Sorry, I'm not too familiar with computer science and I sure could use some help how to make that new hard disk work for storage.

Thanks, Herb
!