Sign in with
Sign up | Sign in
Your question

Blue Screen on GA-MA770-DS3 Motherboard

Tags:
  • Gigabyte
  • Blue Screen
  • Motherboards
Last response: in Motherboards
Share
April 24, 2008 4:18:08 AM

I just put together a new system yesterday and am having a strange issue where the system gives me a blue screen whenever I try to load a cd or dvd. The system consists of the following:

Gigabyte GA-MA770-DS3 motherboard
AMD X2 5000+ Black Edition with Arctic Freezer 64 Pro cooler (still clocked at stock speeds until I figure out this issue)
EVGA 8800 GT 512 MB
2x1GB 800 mhz A-data ram
2x320 Gig Seagate Sata drives in raid 0
Lite-on LH-20A1L sata dvd burner
Corsair 450 Power supply (and please don't flame me saying that 450 watts is not enough, I know this power supply had more than enough power)

The exact error is Driver IRQ not less or euqal Stop 0x000000d1 ahcix86.sys and then an address number

I understand that the ahcix86.sys file is related to the sata controller so I did the following things in this order (none of them helped)
1. Updated the chipset drivers from Gigabyte's site (if anybody has anything newer please do let me know)
2. Updated the firmware of the dvd drive
3. Flashed the bios of the motherboard (almost froze the board, and had to take out the battery, piece of crap windows based bios flash)
4. Uninstalled all of the sata devices in the the device manager and let windows reinstall them

The system seems perfectly stable except almost every time I put in a disc the computer comes up with that blue screen. I did run Memtest86+ a few passes to make sure that I didn't get bad ram. I know that the dvd drive is in working order as I used it on my work computer fine. I also know that the hard drives are in working order as I bought them last year and had them in an old machine until earlier this week. All of the rest of the parts are brand new.

Thanks for any help since I am dreading calling Gigabyte.



Edit: I talked to an idiot from Gigabyte and he told me that you cannot run a raid setup and have a sata dvd drive hooked up because the chipset will only handle either raid or ahci. Can anybody confirm this before I talk to another idiot at Gigabyte?

More about : blue screen ma770 ds3 motherboard

May 11, 2008 3:37:33 AM

Hi Joel from another,

Good taste in Mobos. Unfortunately the SATA controller is the one headache on this board. You may have to get an IDE DVD Burner. I had similar problems on this board with a different SATA Configuration. Since there was only 1 IDE plug and I had 3 IDE devices, I used a SATA adapter to hook up an extra DVD Burner and ran into this same issue before I gave up and replaced my backup IDE drive with the burner. No problems since. Hope this helps. If you have to talk to Gigabyte, try to leave a detailed email instead of the live chat. I've gotten better information this way. I think the live chat thing is just to placate us. Good Luck
May 14, 2008 1:00:11 PM

I decided to drop the raid for now, and just use the sata hard drives in native ide mode. I might get a real raid card later, but for now I am doing a dual boot with ubuntu 8.04 and windows xp so it is probably less head aches to use native ide instead of raid or ahci. It is a bit disappoint though. But then again, I think most onboard raid controllers are trash, and this one seems no different.
Related resources
July 9, 2008 10:35:18 PM

Hi
I had the same problem on Gigabyte MA790X-DS4 board. When I installed RAID 0 and sata DVD, I've experienced bluescreens in Windows everytime I've tried to open/close DVD.
I really started to think those idiots from Gigabyte didn't think of someone using sata RAID and sata DVD at the same time.
It turned out that it was simply RAID drivers problem. I've used RAID Drivers 2.5.1540.44 version and thought it was the lates one. After few hour of serching I found 3.0.1540.46 version. Try installing it, it helped in my case.

link:
http://wwwd.amd.com/AMD/SReleaseF.nsf/softwarepages/Dri...

Enter this site and download Drivers (Six Languages) v8.477 (116MB). This archive contains x86 RAID drivers 3.0.1540.46 version.
After unzipping the file don't install the whole package via setup.exe. It will corrupt your system. Try instead upgrading your RAID drivers from control panell/system/device manager. (ATI AHCI Compatible RAID controller device)

RAID driver is in "\XP32-6Lang\SBDrv\RAID\x86\x86" folder.
You can also try installing other drivers from "\XP32-6Lang\SBDrv" folder for example:
- IDEATA133
- SMBUS
- WebPam
Don not install stuff from "\XP32-6Lang\SBDrv\SATARAID" folder because it's some Silicon Image SiI 3112 driver. The Gigabyte board isn't equipped with one :) 

I hope I helped you solving the problem!

July 30, 2008 12:30:45 PM

I am setting up a virtualisation system using this motherboard and two Sata drives, a 160Gb WD for the OS and a 1000Gb Seagate for the virtual machines.
Had problem getting OS (Server 2008) to recognise the drives even though showed up in BIOS
Eventually solved problem by setting Sata to RAID and then at startup you need to do a CTRL F just after memory check to enter RAID configuration
Configured the drives individually as JBOD (Just a bunch of drives) and they showed up just fine in Server 2008 Setup
By the way also put the Sata connectors in slots 1 and 3 to get 2 masters and putting them in 1 and 2 showed up as Master and Slave
August 3, 2008 11:10:42 PM

For a while I thought I was the only one experiencing this issue. I've been having awful stability issues in general with a Gigabyte MA-790X-DS4. Of particular note with the OP is that I am using a Lite-On LH-20A1S sata dvd burner. I'm in the process of downloading the drivers mentioned by hit-man. I am hoping that those will fix the issue of the DVD-drive opening/closing causing the bluescreen.

In addition to this error, my problem that I have been experiencing is this: While the system is under load playing a game it will do a hard reboot. It's only when I am playing a game, like Call of Duty 2, Guild Wars, Neverwinter Nights 2, Doom 3, etc. All of these games will make the system reboot, either after 30 seconds or after 30 minutes. What's frustrating is I can't isolate when, only that I know that once I start taxing the system by playing a game, at some point it will reboot. I can surf the web, do any type of "normal" tasks and the computer is fine (other than open or close the DVD drive, ha ha).

I tried isolating the various systems and haven't been able to pinpoint it. I have run two copies of Prime95, one for each core of the CPU and let it sit for hours without issue. I've run Memtest86 for hours also with no issues. I'm pretty stumped, to say the least.

System specs are as follows:
AMD Athlon 64 X2 6400+ Black Edition
4GB of memory (2 2GB Kingston sticks of memory).
Palit Geforce 9600GT 512MB DDR3 Video Card
Gigabyte MA-790x-DS4 Motherboard
Western Digital 500GB SATA HDD
OCZ Vendetta CPU Cooler
Antec Earthwatts 430Watt PSU
Lite-On LH-20A1S SATA DVD burner
Antec P182 mid-tower case
OS is Windows XP (32 bit) (Yes I know not all of the 4GB RAM is recognized)


The only thing I can think of is that on the Motherboard, the auxiliary power connector is made to accomodate an 8-pin connector, however there is a black cover over four of the pins, and the manual states that a four-pin connector can be used. My PSU only has a 4-pin connector. I'm wondering if the PSU I have simply can't handle the load, and the combined draw from the CPU + Video card pushes it over the edge, causing it to reset, hence the reboot. My thinking is that whilke a four-pin connector can be used, really, a PSU with the additional power and appropriate connectors would really be what is necessary in order to make the board work stably. Of course, I'd have to pony up and get a better PSU to be sure, which may or may not fix the problem.

So, for now I am stuck, in the meantime I will see if this download fixes the tray open/close problem, and who knows, maybe it will fix the other issue. I'll repost later on and report back if it has worked.

Thanks for your post hit-man, very informative and I thank you for sharing what worked for you.


August 4, 2008 2:27:20 AM

Quick Update - I updated the SATA RAID drivers and it appears that the DVD drive open/close issue is fixed! No more BSOD! I have yet to test and see if my other stability problem is fixed at this time.

Here's what I did: I referred to the site that hit-man referenced in his post. I downloaded the ~116MB file, and extracted it. It is version 8.477, as he states. I also checked Gigabyte's website, and found that as of 7/25/2008, Gigabyte has newer drivers than the ATI/AMD site! Gigabyte now has version 8.51 of the drivers available, and the actual ahcix86.sys driver file date is 05/27/2008, and the driver file version is 3.1.1540.64. The version of the driver from the AMD website is 3.0.1540.46, with a date of 06/04/2007.

One thing that is missing from the Gigabyte website is the ATA133 IDE controller driver. You'll need to download the big file off of AMD's website if you wish to update from the Generic Microsoft driver to the AMD one.

So, all in all I updated three things. The IDE Controller driver from the Generic Microsoft driver to the "AMD PCI IDE Controller" version. I used the driver from the "IDEATA133" directory from the big file off of AMD's website for this. Next I updated the "AMD AHCI Compatible RAID Controller" to the latest 3.1.1540.64 version using the Gigabyte driver file. I rebooted after that, and then updated the "AMD RAID Console" driver using the same RAID driver.

Lastly, I had to force XP to update the RAID driver, as otherwise it didn't want to let me upgrade to the newer version while searching for the driver to use. Make sure to remember to use the "Don't search, I will choose the driver to install" option when going through the driver update wizard. I forgot to do this the first couple times and was tearing my hair out trying to figure out how to get it to update. D'oh! :lol: 



August 4, 2008 3:58:20 AM

Still reboots when playing games. So, I have yet to fix that issue. But at least now I can open and close the DVD Drive without a BSOD. Yippee... :heink: 
!