Sign in with
Sign up | Sign in
Your question

LG GGC-H20L Blu-ray dvd-rw magically turns into "DVD-RAM"

Last response: in Storage
Share
April 11, 2009 3:59:28 AM

Last week I bought a LG GGC-H20L Blu-ray dvd+rw drive, and after installing it (and powerdvd that came with it), everything worked fine until yesterday. I put in a blu-ray disc to watch and noticed that it wouldn't play in powerdvd or any other program. Upon checking the My Computer window, I noticed that the LG drive, which used to show up as "D: HL-DT-ST BDDVDRW GGC-H20L" was now showing up as "D: DVD-RAM". Corresponding with this change, blu-ray discs no longer work, however, both dvds and cds work perfectly fine. When checking both the Control Panel and the AnyDVD information screen, the drive still shows up as "HL-DT-ST BDDVDRW GGC-H20L" and AnyDVD seems to be able to read and indentify the blu-ray discs.

Is there any reason that my drive would suddenly turn into a DVD-RAM after working perfectly for a week, or am I looking at a defective unit here?

Any help is greatly appreciated.
April 11, 2009 8:32:56 PM

Have you updated AnyDVD HD? Blu Rays that can't be decoded show up as DVD-Ram.
April 12, 2009 1:07:45 AM

That's not the problem, because discs that worked before no longer read. When the drive is empty, it says "D: DVD-RAM" and after it reads the blu-ray disc, the drive turns to "D: CD DRIVE".
Related resources
April 12, 2009 8:58:06 PM

What troubleshooting have you done?
-disable AnyDVD
-exit out of AnyDVD
-reinstall drivers
-change sata port
-update/reinstall AnyDVD
-did you install the UDF 2.5 driver(for XP, Vista already has it)
April 13, 2009 5:00:56 AM

First thing i would do is uninstall and reinstall the drive in control panel. Then I would access lg's website and get a firmware or bios flash for the drive.
April 13, 2009 7:37:14 AM

It's probably a driver issue, uninstall in windows control panel and get new drivers off LG website.
April 15, 2009 10:34:55 PM

It appears that the problem was the UDF 2.5 drivers, the only thing I hadn't tried (and didn't even know I needed). Many thanks to everyone for their assitance.
!