Sign in with
Sign up | Sign in
Your question

3870x2 or just new ati cards fan problems

Last response: in Graphics & Displays
Share
March 15, 2008 5:27:51 PM

Who has had the fans go out or come new with bad fans? I have a 3870x2 after a month the fan started hiting the cover. Also i was wondering if there was a difference that it made from the card being in a tower or a desktop ( ie horizontal or vertical )
Thanks all!!!
March 17, 2008 8:20:45 AM

I have a visiontek 3870x2 and mine seems fine with regard to fan clearance. I would RMA back if Possible.
March 26, 2008 12:48:21 AM

Well i am surprised that there was not more of a reply from people since i have read in the forums of people getting new cards with bad fans right out of the box,I am not bashing ATI or anything like that, I like the card alot. But here is a good one that i would like to get some help with, i sent the card in to get fixed payed $9.00 dollars to ship a one month old card in for fan problem, waited two weeks to get it back the same way i shipped it out , the repair paper work said that they (diamond) retighten the fan!. I am sorry but i am just alittle upset at this point how should i handle this! Thanks all
Related resources
March 26, 2008 1:18:50 AM

I've never had any problems with the fans on any of my ATi cards. The one currently in my computer is three years old. I would RMA your card.
March 26, 2008 2:02:35 AM

fleakiller said:
Well i am surprised that there was not more of a reply from people since i have read in the forums of people getting new cards with bad fans right out of the box,I am not bashing ATI or anything like that, I like the card alot. But here is a good one that i would like to get some help with, i sent the card in to get fixed payed $9.00 dollars to ship a one month old card in for fan problem, waited two weeks to get it back the same way i shipped it out , the repair paper work said that they (diamond) retighten the fan!. I am sorry but i am just alittle upset at this point how should i handle this! Thanks all


I would check with Diamond as they may use the ATI reference cooler but of their own design normall. Or it might be their own. I prefer Sapphier brand ATI cards as every single one(from my 9800XT) all the way to my HD2900Pro has been a solid card.

Or if you feel up to the task see if you can tighten the fan yourself as it may just be a bit loose. But the last resort would be RMAing it to the retailer and maybe picking up a different brand like Sapphire or another besides Diamond.
March 26, 2008 6:52:43 AM

jimmy i understand what you are saying and i can do the repairs myself but why!, i spent 500 dollars for a card and it has problems i am a forman for a large crane company for the west coast i am 50 years old and back in the 80's i went to work two hours early to dig in the trash behind computer stores to build my first 8088 !!!! I know i can RMA it and or repair it but this is not what i am trying to find out i thought i would get some good replys from here !! i have been reading /looking at this site for a long time and have seen MANY GOOD REPLYS TO HELP PEOPLE over the years but maybe i was wrong :( 
March 31, 2008 7:36:22 PM

UPDATE: After getting ahold of Diamond they agreed to pay for ship the card there and back so we will see what happens! TO JIMMYSMITTY sorry for the reply as i said i was a little upset at the time! and i do thank you for the reply
March 31, 2008 10:26:18 PM

Thats why theres no returns on most electronics. The more complex, the higher the risk of something going wrong. This isnt exsclusive to ATI, Diamond, nVidia evga etc. Just comes with the territory I guess. Hope it all works out
April 4, 2008 1:38:21 AM

Using a Sapphire card now with no fan issues. I've only purchased 1 ATI chipset on a card other than from Sapphire, and I didn't like it much; Visiontek. I'll stick with Sapphire from now on.
April 4, 2008 2:42:20 AM

Always ran with Sapphire i don't know why since my older 9550 ran hot as hell XD. I haven't noticed any problems apart from the lovely sapphire logo peal off as i did an extreme overclock :) 
April 16, 2008 6:35:31 AM

Well here is another update i sent the card in on 4-1 and i just got it back today 4-15 they told me that they replaced the card i took the card out and i just had to wonder what in the @#%$#!! is this company thinking about!!!! First off Diamond is one day away from me so it took(lets be nice and say four days to ship card there and back that gave them 10 days to find out the fan was bad then they shiped me this card that looks like this
April 16, 2008 7:55:13 AM

my sapphire runs fine...no probs :)  ::crosses finger::
April 16, 2008 9:46:47 AM

Ditto my Sapphire runs fine :) 
April 19, 2008 8:45:33 AM

I had a sapphire, returned it (bad fan). Got another sapphire: and is working fine now!
May 4, 2008 8:25:11 PM

LAST UPDATE HOPEFULLY, Well after firmly but polity asking to talk to a manager i was giving to a gentleman named Mario. First off i want to say thanks to him he was what customer service should be about he worked with me i got my card replaced with a new one all is good!! my Faith is restored in Diamond. P.S. the only thing i have to say is that it is sad that it had to get to this point i deal with a lot of customers in my line of work and good customer service is getting harder to find lets hope that companies see that and a happy customer is a good customer
June 3, 2008 3:50:38 AM

Hi I have the Sapphire Radeon HD 3870 X2, had the same problem, took Sapphire apart, found the Plastic-"Lock-washer" was warn thin and no longer held the Fan-Shaft in place, allowing it to drop and rub on the Fan Shroud, the only thing holding the spinning fan in place is the motor Magnets.
It’s the fault of the plastic lock-washer.
I now use Da.
Danger Den DD-3870-X2 Full Cover Radeon HD3870 X2 GPU Copper Water Block
!