/ Sign-up
Your question

Harddrive detected in BIOS but not when installing Vista

  • Hard Drives
  • BIOS
  • Windows Vista
  • Storage
Last response: in Storage
April 17, 2009 9:53:26 PM

Hello all,

After spending time messing around with partitions in the hope of having both XP and Vista working on my system i decided to stick with Vista. The problem i have is that when i boot up my computer it just hangs on

"Verifying dmi pool data

I have looked in my BIOS, it detects the harddrive and displays the correct memory capacity etc in the CMOS settings. To test this i unplugged the sata cable and replugged it in, again the BIOS detected the harddrive. When i go to reinstall Windows Vista it asks me "Where would you like to install Windows?" It doesn't show any drives whatsoever, I have only one harddrive.

My system specs:

Intel Core2 Quad CPU 2.40GHZ - Overclocked to 3.0GHz
nVidia 280 GTX
Abit IX38 QUADGT motherboard
500GB Sata harddrive

So my question is, how do I make Windows Installer re-detect the harddive? Any help is greatly appreciated. :) 

More about : harddrive detected bios installing vista

April 17, 2009 10:12:48 PM

Set your drive to ide mode in bios. Not SATA or ACHI.
April 17, 2009 10:16:42 PM

I don't see an option to do that, how do i do change it's setting ? Sorry I am a retard when it comes to BIOS.
Related resources
April 17, 2009 10:17:41 PM

Just look on the page where it lists the drives, there will be a option somewhere there.
April 17, 2009 10:22:31 PM

Turns out it is already set to IDE, I re-reset it as IDE to no avail. Any other ideas?

Thanks for your help :) 
a b G Storage
April 17, 2009 11:10:48 PM

Vista contains the SATA drivers, you do not need to set the drive to IDE mode.
You should be able to set it to AHCI mode and be just fine.
Be sure you have the drive plugged into the correct controller, and that it is enabled. Some boards have more than 1, and some boards that have 5 or 6 SATA slots reserve some of them for RAID functions if you have it set up that way in the BIOS.
Read your manual carefully, I am sure that probably this is the case.
Try another plugin, and check your SATA settings in your BIOS again, there should be 2 places for the settings. 1 setting controlling 4 of the plugs, and another line controlling the other 2.
Non-the-less, standard IDE mode is only needed for XP install if you do not have the SATA drivers. Vista has the right drivers.