Sign in with
Sign up | Sign in
Your question

WD MyBook Studio - eSATA connection problem

Last response: in Storage
Share
Anonymous
a b G Storage
April 18, 2009 12:59:52 PM

Recently I got external HD WD MyBook Studio edition 1TB. I have bought it especially for its multiinterface support -USB,firewire & esata. But so far I´m able to run in just on USB, eSata connection seems not working properly, transfer is very very slow and disk freezes very often leaving data mismatch and bad allocated sectors left. I use ASUS M3A78AM-EM with AMD SB700 SB controller. I tried it under MS VISTA and Windows7 beta ... on both with the same results. Is there any solution have to make the disk work in eSata mode, installing some special drivers, MB settings or anythig? Have someone an experience with this drive on AMD chipsets?
And is there some way how to update the WD hardrive on x64 systems,because there on the company pages I found the updater just for 32bit system which do not run on 64bit systems. Thanks much in advanca for any help.
March 1, 2010 1:31:27 PM

I had the same problem, but I enabled AHCI in the BIOS and fixed it this way. Now, however, I'm stuck with random disconnection problems.
!