Sign in with
Sign up | Sign in
Your question

windows (cpu-z) displays wrong DDR2 info...

Last response: in CPUs
Share
April 5, 2008 9:36:25 AM

I upgarded from 6400 (800mhz) ddr2 sticks to 8500 (1066mhz) ballistix sticks. first of all my bios recognized the 8500's as 6400. after turning it off and taking them out, and putting them back in, it recognized it properly but in windows, its still reconized by 6400 by CPUz and PCwizard. my mother board is gigabyte p35 S3 , updated to the latest bios, never had problems with it? whats going on?
a b à CPUs
April 5, 2008 9:42:08 AM

Go into the BIOS any manually set the ram to the Speed and timings its rated for. Also set the voltage if its not what its supposed to be.
April 5, 2008 10:00:38 AM

someguy7 said:
Go into the BIOS any manually set the ram to the Speed and timings its rated for. Also set the voltage if its not what its supposed to be.


the bios issue is settled, its the fact that windows programs arent recognizing it as genuine 8500's
Related resources
April 5, 2008 1:44:04 PM

gallionfc said:
the bios issue is settled, its the fact that windows programs arent recognizing it as genuine 8500's



If it runs at 1066mhz, does it matter what Windows think? It's just like a seal of approval. :p 
a b à CPUs
April 5, 2008 4:58:20 PM

Its not what windows thinks. Its apps like cpuz/everest that give you the info. And I cant recall ever hearing them reporting ram speeds/timing wrong. OP, you say the BIOS identifys the ram correctly. What exactly do you mean by that? In post screen? In the BIOS options to tweak the ram settings? Which I believe are hidden features(control+f1) in gigabyte boards.

In cpuz you are getting your info from the SPD tab correct? The memory tab tells all the current specs its running at while spd gives you the mobo slot the ram is in, manufacturer, max bandwith. that is where it should say 1066 ballistix and the rated timings for different speeds...

If still no luck try other memorys settings, such as running it at 667, 800, 533mhz or any speed that loads up windows. Then see if cpuz reads it properly.
a b à CPUs
April 5, 2008 5:07:47 PM

You will have to manually set your PC8500 to 1066MHz in BIOS. JEDEC standard ratings do not go over 800MHz so all DDR2 memory has to have a SPD rating of 400, 533, 667 or 800 at 1.8v. PC8500 will show up as PC6400, but the Mfg. guarantees it to run at PC8500 1066MHz. when set to Mfg. specifications. PC8500 = PC6400 +++.
April 5, 2008 5:56:13 PM

badge said:
You will have to manually set your PC8500 to 1066MHz in BIOS. JEDEC standard ratings do not go over 800MHz so all DDR2 memory has to have a SPD rating of 400, 533, 667 or 800 at 1.8v. PC8500 will show up as PC6400, but the Mfg. guarantees it to run at PC8500 1066MHz. when set to Mfg. specifications. PC8500 = PC6400 +++.


what do you mean by Mfg?

and yes im getting the info from the spd panel...

I guess the ram is in EPP #2 state (because thats the on that says 533 (1066)). so once again, what is Mfg, and how do I change its specifications so that pc8500 = pc8500 and not pc6400 +++?
April 5, 2008 10:05:48 PM

gallionfc said:
what do you mean by Mfg?

and yes im getting the info from the spd panel...

I guess the ram is in EPP #2 state (because thats the on that says 533 (1066)). so once again, what is Mfg, and how do I change its specifications so that pc8500 = pc8500 and not pc6400 +++?



Go to BIOS and put ram speed and voltage on manual, and set it according to whatever manufacturer claims it should run at. Same as overclocking ram.
April 5, 2008 11:57:40 PM

gallionfc said:
what do you mean by Mfg?

and yes im getting the info from the spd panel...

I guess the ram is in EPP #2 state (because thats the on that says 533 (1066)). so once again, what is Mfg, and how do I change its specifications so that pc8500 = pc8500 and not pc6400 +++?


In this case the "mfg" probably stands for manufacturer (http://acronyms.thefreedictionary.com/MFG)

As stated above PC2-8500 or 1066MHz DDR2 is not an official JEDEC standard, so it's not in the SPD records.
If you set your BIOS to run the memory above 800MHz (1066MHz in your case) you are running your RAM at PC2-8500.

What matters is the "Memory" tab of CPU-Z where the current settings are mirrored.
If the frequency reading in that tab is 533MHz your RAM is working as it should.


April 6, 2008 12:37:41 PM

Andrius said:
In this case the "mfg" probably stands for manufacturer (http://acronyms.thefreedictionary.com/MFG)

As stated above PC2-8500 or 1066MHz DDR2 is not an official JEDEC standard, so it's not in the SPD records.
If you set your BIOS to run the memory above 800MHz (1066MHz in your case) you are running your RAM at PC2-8500.

What matters is the "Memory" tab of CPU-Z where the current settings are mirrored.
If the frequency reading in that tab is 533MHz your RAM is working as it should.



now my idiotic motherboard is showing 800mhz instead of 1066mhz... I just dont understand...
April 6, 2008 1:54:31 PM

Well... the bios is only going to run the memory that falls to default to run the CPU.

Perhaps the ratio of running that memory might be the main problem. From what people are saying, not even sure what the rated FSB on the CPU your using.

Is it an E8400? The rated FSB on that is 1333mhz, so DDR2 667 would run that fine (1:1 ratio). But since your trying to run it at advertised speed, hard to say what the ratio is on that. For example on my E4400, the FSB is rated at 800mhz. When I ran my DDR2 800 at advertised speed, without OC'ing, the ratio was something like 16:9.

So I hope that helps you understand why your system needs you to set it up to run the way you want.
April 6, 2008 5:55:51 PM

Grimmy said:
Well... the bios is only going to run the memory that falls to default to run the CPU.

Perhaps the ratio of running that memory might be the main problem. From what people are saying, not even sure what the rated FSB on the CPU your using.

Is it an E8400? The rated FSB on that is 1333mhz, so DDR2 667 would run that fine (1:1 ratio). But since your trying to run it at advertised speed, hard to say what the ratio is on that. For example on my E4400, the FSB is rated at 800mhz. When I ran my DDR2 800 at advertised speed, without OC'ing, the ratio was something like 16:9.

So I hope that helps you understand why your system needs you to set it up to run the way you want.



im running an e6550 (2.33ghz) overclocked to 3.1ghz and the ratio of the memory, at the default speed of 1066mhz is 5:6.

when I do clear cmos the mobo recognizes the memory properly as 1066mhz, however windows still doesnt. BUT after a while even the motherboard sees it as 800mhz...
!