Sign in with
Sign up | Sign in
Your question

Win2k is reporting my partitioned hdd as unformatted; HELP!

Last response: in Storage
Share
April 21, 2009 2:55:36 AM

a 200gb pata hdd that is partitioned into (approx) 170 and 30 gb NTFS partitions using norton partitionmagic is showing up as unformatted in win2k. the 170gb partition was the primary master hdd where xp was installed in a separate rig -one now dead due to an unrelated problem.

the jumper is correctly set.

i've heard from multiple sources that it's common for partitioned hdds to show up as unformatted in windows, particularly in xp, but sadly no one remembers precisely how this problem is fixed. apparently the partition table needs to be reset or something -however, i'm very hesitant to proceed without knowing exactly what to do to recover all my data (hopefully without having to use something like norton getdataback, which requires a seperate hdd); i'm especially wary of using some random app that could mess up the data that i'm SURE is still secure on the hdd. i'm considering installing norton partitionmagic on this pc, but i believe the proprietary formats norton uses may be the cause of this problem.

help?
a b G Storage
April 21, 2009 4:01:42 AM

Both partitions are not showing up in Windows? Have you tried mounting the drive through Windows Drive Management? (If you don't know where it is, just search for Disk Management in help)
April 21, 2009 4:09:51 AM

the hard disk itself appears as an hdd in explorer with 0 space and no file system. clicking it causes an "X is not formatted, would you like to format it now" message to appear.
Related resources
a c 359 G Storage
April 21, 2009 4:16:52 PM

Just a hunch here - since you are running Win 2k, check out which Service Pack is installed in it. Win 2K did NOT get support for "48-bit LBA" until somewhere around SP4, but I'm not sure about that number.

The original LBA system was "28-bit LBA" and that allowed HDD volumes up to 137,000,000,000 bytes which Windows will call 128 GB. But you have a larger drive with the primary partition at 170 GB. To deal with that the OS must have been updated to support "48-bit LBA".

While you're at it, you also should check whether the hardware supports 48-bit LBA. First rule: SATA always does. But yours is PATA. Search the mobo manufacturer's website for info on the exact version of the BIOS your machine has, and what it can do. Just "LBA Supported" is not enough, nor is "supports large hard disk" - it needs to specify 48-bit or at least "larger than 137 GB". If you don't have 48-bit LBA, look for a way to update the BIOS by flashing it with a new version that does include support.

Oh, by the way, my comments on BIOS support presume that you are using an on-board controller (in the mobo's chipset) to control the HDD's. If you are using a separate HDD controller in a PCI slot, then the BIOS capabilities relate to this adapter card, not the mobo.
April 22, 2009 3:11:20 PM

sp4 is installed. finding out if 48bit lba is supported is proving to be more difficult as i can't find much hard data on my 'compaq 07e8h i845g' and the 'evo series desktop hardware' pdf from hp's website is broken :|

-however, that may be moot as it appears i can read and access all my files on both partitions using a linuxmint livecd.

here's a screenshot of the partitioned drive in gparted, if it may help:my wish is still to have both partitions fully accessible in win2k since there are programs i use which necessitate it.

-there's another weird thing to report: gparted, the partitioning software in linuxmint, reports the 172.2GB partition as being 160.40GiB and the 25.5GB partition as being 25.91GiB; in other words, unlike the file browser, gparted reports the size of the larger partition as being smaller and the smaller partition is reported as being larger... now that is really weird, and kind of suspicious. can someone explain this WTFery and how next to proceed?

thanks for the advice thus far!
April 24, 2009 1:53:51 AM

i feel i am one step closer to understanding my problem. from the wikipedia article on partitionmagic: "PartitionMagic is ... not compatible with Windows NT, 2000, or 2003 server editions."

urgh... never noticed that before. sadly, i'm still not entirely clear on how next to proceed. also, unfortunately, i am no longer in possession of any windows install disks. is there some other way to enter the recovery console without them (and in my case, which one should i use, the win2k disk or the xp disk?)?

i have made a message in symantic's forums and am also awaiting response from them.
!