Sign in with
Sign up | Sign in
Your question

First sata drive/problem

Tags:
  • Hard Drives
  • SATA
  • Storage
Last response: in Storage
Share
May 3, 2009 1:03:47 AM

My motherboard is Asus K8N-E deluxe.I have been using ide hds since the build and just put in a WD500Gig Sata HD.The pc,xp,sees the drive fine.I used WD data lifeguard tools to format the drive into a bootable drive and then copyed my os and the rest of my C: drive over to it.I then powered down,removed my old ide drive,booted into bios and set the new sata drive as the first boot device but it will not boot up.The little curser blinks in the upper left of the monitor and nothing else happens.Am i going to have reload everything onto this new drive to make it work or am i missing something simple?

More about : sata drive problem

a c 363 G Storage
May 3, 2009 4:21:00 AM

My guess is that your Win XP OS does not have the driver necessary to handle a SATA device until AFTER it boots up. So you can't boot from the SATA drive! There is a way around this.

Go back into your BIOS Setup and check carefully how the BIOS handles the new SATA drive. Many offer a few choices, and the one you want to use is an IDE Emulation or PATA drive. This tells the BIOS to take control of the SATA device and pretend to the rest of the world (including Windows) that it is just an old-style IDE or PATA drive, and Windows has built-in ways to handle that.That way it can read the drive to boot from it. From what you say I expect you do NOT want to use RAID anything, nor do you want to use AHCI or plain straight SATA.
May 3, 2009 4:38:44 AM

Paperdoc said:
My guess is that your Win XP OS does not have the driver necessary to handle a SATA device until AFTER it boots up. So you can't boot from the SATA drive! There is a way around this.

Go back into your BIOS Setup and check carefully how the BIOS handles the new SATA drive. Many offer a few choices, and the one you want to use is an IDE Emulation or PATA drive. This tells the BIOS to take control of the SATA device and pretend to the rest of the world (including Windows) that it is just an old-style IDE or PATA drive, and Windows has built-in ways to handle that.That way it can read the drive to boot from it. From what you say I expect you do NOT want to use RAID anything, nor do you want to use AHCI or plain straight SATA.



I want to use the sata drive for my os and as my main drive.The older ide drives will only be used for storage of photos and the like.Will check my bios for the features you stated and try that.If all else fails will this drive work if i do a clean install of windows on it?
Related resources
a c 363 G Storage
May 3, 2009 5:31:27 AM

You should not have to do a "clean install". My speculation is that, when you installed the new drive, you told the BIOS NOT to do the PATA emulation, but just treat it as a plain SATA drive. Or, you might even have told it to do PATA emulation, but then chose to add the AHCI option of drive control. Either or both are ways that Windows does not understand without drivers. However, I also would guess that, once you set those things up and went to use the WD Data Lifeguard tools, somewhere in the sequence it was recognized that Windows did not know how to deal with this new device and needed a driver for the job, so one got loaded into Windows. That allowed Windows to use the drive and do all the prep work properly. The trouble is that the driver here is something that Windows put on the original boot disk, along with a note in its Registry that it should be loaded in during boot-up. Now, however, it is trying to boot from a different device and it has a problem because it needs the driver loaded FIRST in order to use the disk to boot from! That is why the mobo BIOS makers put in the PATA emulation mode, so Windows will be fooled into thinking it is trying to boot from a plain IDE (or PATA) device it knows about.

All the information needed on the new SATA device is there and should work just fine as long as Windows can read it to start out for boot purposes. The PATA emulation, and no AHCI use, should solve that initial access problem.

The ONLY glitch I can imagine (and I really don't think this will cause you big trouble) is that Windows will boot properly from the new disk, and then see the note to load the SATA disk driver. But you will have changed it to a PATA disk! I think Windows will just not use the SATA driver it has loaded and it will all work. Just to be sure, after it has booted up properly and is working, go into Start ... Control Panel ... System. Click on the Hardware tab, then on the Device Manager button. Expand the Disk Drives item, then RIGHT-Click on the drive and check its Properties. You should have only one drive showing. If there is a second SATA drive showing up (because a driver for it is loaded), you might want to delete that piece of "hardware" and leave only the real drive (which Windows believes is PATA) installed, then reboot.

Once you've got it all working, you can go ahead and re-install your older drives and use them. Just make sure they are not in the Boot Sequence. Check this point carefully, because some mobo's will, by default, assume that any IDE drive in the system will be your boot drive, and you would need to change that in the BIOS. By the way, when you do this you may be surprised to find that the BIOS labels the new SATA drive as a SCSI drive! It can be confusing, but paying attention to the manufacturer name, model number and drive size will help you ensure you get the right one set as the boot device. After you get that done, however, you might need to go into Windows' Disk Manager to change the names of the hard disks so that the new boot drive is C: (should be anyway) and the older drives, after re-connection, are named as you choose. Similarly, you might need to re-name your DVD drive the way you want.
May 3, 2009 3:06:27 PM

Thank you very much for the info!Will dive back into the bios today and take a look.Will keep you posted.
a b G Storage
May 3, 2009 3:15:47 PM

Simply set your SATA controller to "emulated IDE" or "native IDE" mode.
!