Sign in with
Sign up | Sign in
Your question

USB stick recognized on one port but not on other

Last response: in Motherboards
Share
May 12, 2008 8:27:52 PM

Good evenin' ever1

I've spent the whole day today trying to figure what's going, to no avail

I have a Gigabyte GA-965P-DS4 Motherboard with a Intel ICH8R south bridge.
Windows XP professional SP 2.
It has 6 on board usb connectors and 4 on the rear panel. Now, the problem is that

1. when I plugin a usb stick into any of the 4 Rear I/O panel USB ports it works fine except that once in a while I get the Parameter incorrect message, usually happens when reading big files, 200 MB and higher. After that if I go into windows explorer and open up the stick, no data is shown although it's still there.

2. When I plug in the usb stick into any of the 6 on board usb ports I get the message Device not recognized, sometimes it does not even say that. The usb stick does not show up in the windows explorer. I've tried this with 3 different sticks, same thing.
The BIOS that came with this motherboard has a boot option, I can choose from a menu what hard drive to boot from, it's strange but this menu shows any plugged in usb stick even when it's plugged into one of the 6 onboard usb ports.

I hope I can resolve this on my own, don't want to go to the store and let them fix this because they want the whole PC and it will most likely take them a while to do it.

I appreciate any help
Thanks a lot

Trey

More about : usb stick recognized port

May 12, 2008 11:21:05 PM

Some USB items require a driver install for every USB port you insert them in. I've noticed this for my crappy old OTI MP3 Player. I recently got another OTI item (usb 512mb disk in a pen) as a gift. The same problem again.
It's not limited to a single computer.

If your usb disk is by any chance an OTI product that would explain alot.

I'm not sure what their problem is but this never happend on my Corsair USB key.
May 13, 2008 9:35:08 AM

Hi

I have two PNY attache sticks, one is a 256MB and the other 1GB
and I also have one SanDisK 1 GB Stick

I've never had any problems with these sticks on other computers

I have a feeling that the motherboard is defective, but I will probably have to reinstall windows and try all the testing with a fresh install
Related resources
May 13, 2008 9:53:17 AM

check your case manual and your mb manual to make sure that the front usb cables are wired right for your MB usb headers :) 
May 13, 2008 10:01:04 PM

royalcrown said:
check your case manual and your mb manual to make sure that the front usb cables are wired right for your MB usb headers :) 


Oh, I've done that, checked everything possible.

I forgot to mention that if I plug my midi controller "Evolution UC-33a" or midi keyboard "Evolution E-keys" into one of the 6 ports they work fine, so I guess this issue has something to do with USB sticks.
May 20, 2008 11:17:10 PM

I've installed WinXP today, all the necesary drivers (Chipset, video, etc.....) and I still get the same problem, so I guess the motherboard is a defect, I don't think it is anything else.
!