Sign in with
Sign up | Sign in
Your question

Issue with SATA controllers and Vista

Last response: in Storage
Share
May 7, 2009 3:20:39 PM

GIGABYTE GA-MA790XT-UD4P AM3 DDR3 AMD 790X ATX AMD Motherboard


Western Digital Caviar Black WD6401AALS 640GB 7200 RPM 32MB Cache SATA 3.0Gb/s 3.5" Hard Drive



I'm trying to install vista 64bit on the above mother board.I've plugged the SATA HDD into the AMD SB750 South Bridge SATA2_0 port (also tried SATA2_1). I get to the point in the Vista install that asks "Where do you want to install Vista?/ Load Drivers"). I have only one SATA HDD and am not trying to set up a RAID.

When I selected AHCI as the SATA type, I got the option of 2 drivers (If IDE is selected as the SATA type, i get no compatible drivers listed - if i uncheck i can see them as I'm using the GigaByte Driver CD sent with the mobo). Installing either or both (multiple times getting to this point in the install), the HDD will still not show up in the vista install.

TO NOTE: the SATA drive is also not showing up in the initial startup diagnostic or the BIOS, so I think I need to get that resolved before the install even has a chance.

I've tried reconfiguring the BIOS settings under Integrated Periperals. I have the GIGABYTE SATA2 SATA controller disabled (have the SATA drive plugged into AMD SB750 South Bridge SATA2_0 port), and have enable the OnChip SATA Controller. I've tried Native IDE and AHCI as the OnChip SATA type.

Not sure if it's part of the issue, but the DVD optical drive is IDE and configured as Master. I haven't changed the jumper settings on the SATA HDD, so it might still aslo be set to master?

I feel the issue is in my BIOS settings, but I'm not sure what I should the proper settings should be to get it to work.
a b G Storage
May 7, 2009 3:58:20 PM

You don't need to disable any of the SATA controllers. The IDE optical drive can still be configured as master. It will just be the master on the secondary controller.

If you had it configured as AHCI and no HD showed up, the drive may not be plugged in or it may be a dead drive. All BIOS are different, but I have a similar setup on one of my PC's and I found a setting in my BIOS for a combo controller. It was for configurations that need both types of controllers.

First, I'd be working on getting the bios to see your HD. On ACHI or RAID mode(this can be enabled even if not running RAID), the drive should show up.
May 7, 2009 4:05:44 PM

Thanks for the reply Aford10.

Quick question..the WD Black was OEM and did not come with the Western Digital SATA interface cable with SecureConnect. I hooked it up with a regular SATA connect cable.

The WD manual says "When using a
standard SATA interface cable (not included)
instead, DO NOT connect both the standard SATA
cable (not included) and legacy ATA 4-pin power
cable at the same time or the drive may malfunction".

So no power connection directly to the HDD if I'm reading that right.
Related resources
a b G Storage
May 7, 2009 4:20:30 PM

It's referring to the SATA power coming from the psu. You don't want the 4 pin molex power and the SATA power(psu connection) at the same time, that can blow up the drive.

You do need one or the other. In addition to the power cable, you need the SATA data cable that runs from the drive to the board.
a b G Storage
May 7, 2009 4:21:01 PM

If one of the cables is missing, that would fully explain why the drive isn't showing up.
May 7, 2009 4:27:32 PM

Ok. I'm at work at the moment and can't check my install, but I only hooked up a data cable from SATA slot to HDD. I didn't hook up anything from PSU and am now feeling a bit foolish. I just need to hook up the power connection. That's what I get for finishing the build @ 2:00 AM last night.

Thanks for the help!!
a b G Storage
May 7, 2009 4:43:13 PM

That should do it. HD needs power :) 
!