Sign in with
Sign up | Sign in
Your question

RAID 0 Problems. Asus M4A79T Deluxe. Vista 64

Last response: in Storage
Share
May 14, 2009 12:47:26 AM

Hi, I just built a new system using an Asus M4A79T Deluxe, two WD raptors 74g and Vista 64.
The two WD drives were used previously on an XP 32 system in RAID 0 on an MSI board.
The two drives have been formatted.

Now when we try an set up RAID 0 on the drives we have just run into endless problems.
In the BIOS when we have the IDE selected both drives show up as around 74g each in slots 1 and 2 of 5 (1-5), but when we select RAID the drives disappear upon reboot an we are unable to locate them when trying to install Vista.

When the PC is switched on the post screen shows 1 drive at 149g.

When in vista loading screens we get to stage where it says no drives located and gives the option to browse for drivers. We have tried the Vista disk, the motherboard disk and a floppy containing Vista 64 drivers for RAID (cant remember where we got them).

Me and two net buddies have been trying to do this for 2 days now and have looked in many forums and other webpages for answers but just cant make sense of where we are going wrong?

Are we missing something simple here or does it sound like a larger problem, like hardware?
a b G Storage
May 14, 2009 4:51:59 AM

Perhaps your RAID controller isn't connected properly?
a c 127 G Storage
May 14, 2009 8:10:25 AM

"but when we select RAID the drives disappear upon reboot an we are unable to locate them when trying to install Vista."

That is like it should be. Once you select RAID-mode, Windows will not display your physical disks anymore. All it sees is a RAID/SCSI controller, and it will require a driver to work, since onboard RAID = driver RAID; all processing is done by Windows-only drivers on the system; no hardware acceleration is performed.

You need to download and install the RAID-driver for your system. Also, after setting the mode to RAID in the System BIOS, you need to create a RAID-array using the RAID BIOS setup utility, which advertises itself after the System BIOS with something like "Press Control+F to enter RAID Setup!" just before you see the Windows loading screen.
Related resources
May 14, 2009 1:28:01 PM

r_manic ...... Thanks m8 but i should have said thats its onboard RAID.

sub mesa ... "That is like it should be. Once you select RAID-mode, Windows will not display your physical disks anymore."
OK thanks for confirming that because it was doing my head in.

Now, we have the RAID function set in BIOS and the drives vanish as you say, so reboot an press Ctrl F when asked and it takes me to RAID options.
These options are listed 1-4 and are view, create LD, delete LD and something else. So i press 2 and create RAID set 0 and it says now functional.
Reboot and the POST screen shows as 1 drive at 149g .... Now are we right so far up to this point?

Because at this point im lost, i cant see where the option to install drivers comes in apart from the option i see when first loading Vista from the disk, but like i say, no drives show up an we goto Load Driver and we cant find any drivers on the Vista disk, MB disk, a floppy that had drivers on and now the drivers that i just downloaded from Asus website an put on to a gig stick.
I mean the drivers are there but when selected an press OK it says 'To install the device driver needed to access your hard drive, insert the installation media containing the driver files, then click OK.'

So i guess my question is, how or where do we install the drivers?

Anonymous
a b G Storage
May 14, 2009 6:15:01 PM

them bangladeshi parts is not worth the rupeeeees :kaola: 


Oscer :bounce: 
a c 127 G Storage
May 14, 2009 6:40:37 PM

After you created a RAID0 array, you should see one line telling you its a RAID0 array of 2-disks (two 80GB disks i assume) which make it a total of 160GB. Because of the difference between GB and GiB, this translates to 149GiB as you stated.

After you created a new RAID-array, you need to install an operating system on it. So insert the Vista DVD, follow the installation setup, when it offers you to add additional drivers, use this option to load the drivers from floppy (XP and below) or USB/CD/DVD (Vista and up), which you prepare on another computer. If the drivers come in .zip format, you need to unpack it first. After you loaded the drivers, the OS sees the RAID-array (sometimes identified as SCSI-controller) and sees only one disk of 149GiB (or 160GB). You can now continue to partition and install the Operating System.

Creating a RAID-array destroys (actually, makes inaccessible) all pre-existing data on all disk members that were assigned to the RAID-array.
May 14, 2009 7:28:20 PM

"when it offers you to add additional drivers, use this option to load the drivers from floppy (XP and below) or USB/CD/DVD (Vista and up)"

OK so my problem is that its not recognising any of the drivers from DVDs, floppy or USB stick to install?

So we cant get to the next step of installing the Vista.
a c 127 G Storage
May 14, 2009 8:40:55 PM

Well what medium (USB, CD or DVD) did you use to load the drivers from, and what are the file names including extension?
May 14, 2009 10:02:44 PM

When i go to the screen where it said Locate drivers, i used the browse option to search through the Vista disk for RAID drivers, in fact i tried all possibilties available on disk. Then i tried the Motherboard disk, again trying all options. Then i tried the floppy with the unzipped drivers we got (i think) from Vista disk, and i also tried the USB stick which had the unzipped drivers downloaded from Asus.

The folders i have on the floppy are called X64 and X86.

On the gig stick i have two folders, one called Dc18 and one called MakeDisk. The Dc18 folder contains sub folders ... 9.92_RAID_Vista ... and Vista 64.
The MakeDisk folder contains four sub folders called Vista, Vista_64, XP and XP_64.

The DVD drive with Vista disk in contains 5 folders called BOOT, EFI, SOURCES, SUPPORT and UPGRADE.
these are full of sub folders, if you need more on that i will reply straight away.

The DVD drive with Motherboard disk in contains 5 folders called Bin, Drivers, LinuxDrivers, Manual and Software. I have checked in there for any mention of RAID and tried each folder individually.

There is also a drive showing called Boot (X:)  This contains four folders called Program files, Sources, Users and Windows, all with subfolders.
Theres too many to mention here but i have searched all thru them an the only mention of RAID is in .... Windows - System 32 - Driver Store - File Repository - where i find the following amongst maybe 50 others. mraid35x.inf_6d2d4d74 and mraid35x2.inf_149127a8 and nvraid.inf733654ff and sisraid2.inf_b5866c78 and sisraid4.inf_5bb9e87a and vsmraid.inf_29a82f17.

I have just selected all those mentioned and nothing showed. However when i unticked the box that says 'only show compatible drivers with this computer', loads showed up. This is only new thing i have noticed today.

I do hope this is the info you are asking about.
May 15, 2009 5:45:13 AM

> We have tried the Vista disk, the motherboard disk and a floppy containing Vista 64 drivers for RAID (cant remember where we got them). ...

See your mobo manual pg 4-20 sec 4.5.1 and 4.5.2 (English version) "Creating a RAID/SATA driver disk...". Read it and follow the instructions and create a driver floppy/USB, then use it during Vista install. If that doesn't work report back.
a c 127 G Storage
May 15, 2009 8:07:11 AM

I'm just guessing here since i don't use Windows, but you may need to have a file called OEMSETUP.INI in the root of the medium used (USB-stick or CD are the easiest i guess). This file is often included in the .zip file you download which contains the RAID-driver. If the instructions in your manual really don't work, report back like jrst said and i'll have another look at it.

Good luck!
May 15, 2009 2:16:51 PM

OK 1st boot device is CD/DVD rom.
Motherboard disk inserted.
Save and reboot.
Now it didnt give me an option to press <1> It went straight to a screen where it says ..

Echo is off

Welcome to ASUS Motherboard Make Disk for DOS menu.

a) ATI SB750 RAID/AHCI Controller 32bit/64bit WinXP Driver
b) ATI SB750 RAID/AHCI Controller 32bit/64bit Vista Driver
c) FreeDOS command prompt
Please choose a ~ c:

Now i have been here several times before and this is where we got the drivers before on the floppy that i said i wasnt sure where i got them. (b) Vista Driver. These have been on a floppy and gig stick from start.

So its number 6 or 7 that we get to in MB book, page 4-20. sec 4.5.1

Now i have also tried to browse the motherboard disk on my other comp but it wont let me browse it.
a c 127 G Storage
May 15, 2009 3:13:32 PM

Won't let you browse it? So you couldn't even verify the files actually exist on the driver medium? Then it will not work ofcourse. Go download the driver from the manufacturer website (Asus) and put the files on a USB stick, then make sure the files actually exist on the USB stick and that you can read/copy them. Floppies often have read errors so can't really be trusted.
May 15, 2009 3:27:07 PM

OK i have the drivers downloaded from Asus website,
Description Mark AHCI/RAID Driver Disk for Windows XP/Vista and Windows 64bit XP/Vista.File Size 1.41 (MBytes)

and

Description ATI SB750 RAID/AHCI Controller Driver for Windows XP & 64bit XP & 32/64bit Vista.(WHQL)
File Size 2.24 (MBytes)

unzipped them and they show on gig stick on my old comp.

Now i go thru the motions again and get the same result, No device drivers were found.
May 15, 2009 4:07:32 PM

I have MSN or Skype if you want to try a live chat, if that would be easier?
a c 127 G Storage
May 15, 2009 8:18:49 PM

I don't have those services i'm sorry, i do have IRC if you are acquainted with that, you can use the Chatzilla firefox-extension for a quick and easy to install IRC-client.

I just downloaded your driver, from here:
http://dlcdnet.asus.com/pub/ASUS/misc/sata/ATI_SB750_RA...

That contains a Vista directory, then a x64 directory (indicating 64-bit version of Vista) and in there i can find three important files:

ahcix64s.cat
ahcix64s.inf
ahcix64s.sys

If you put those three files on the root of a USB-stick, formatted with FAT32, without any further files on it, could you try the Vista installation again? Its very important that the files can be browsed and you can see the file names when you select the driver. Probably its looking for the .inf file which contains alot of configuration data, while the .sys file is the actual driver.
May 15, 2009 9:01:40 PM

OK i just downloaded those files and added them to the USB stick and tried again, no joy.
Only the folders were available to browse, but not the individual files inside.

I have just installed (I think) chatzilla for firefox, well it downloaded and installed but i cant find where to open it (Now i sound like a div). I registered and if you want to add me my nick is Altymir.
a c 127 G Storage
May 15, 2009 9:21:09 PM

Click Tools, Click ChatZilla. In the new window that opens click Freenode (its a blue hyperlink) then join channel #submesa. Cya there. :) 
June 12, 2009 7:16:33 AM

Did u get this problem found out because i just ran into the same prob same mother board and same hardrives
June 12, 2009 8:25:31 AM

nvm i just found the solution to this prob ended up exploring the motherboard cd and copied the entire driver folder for raid onto a thumb drive and was able to get it to work that way
Anonymous
a b G Storage
August 9, 2009 2:10:23 PM

Hey! I had the exact same problem with the same mobo as you. When vista asks you about the drivers, you need to browse the files from the floppy or the usb drive. It wont find them if you just click on the drive and press ok. Hope this helps.
October 6, 2009 7:26:08 PM

OK first here is my system spec
Asus M4A78-EM
AMD 920 Processor
4x1 GB’s of memory
Sony DVD DL R/W
Samsung DVD DL R/W
2 250 GB’s Maxtor SATA hard Drives
2 80 GB’s Seagate hard Drives
Hauppauge 2250 HVR card
Apevia X-QPack 2 Case

PLEASE READ THROUGH ALL THE STEPS BEFORE STARTING. Because I had to do this several times on the 64bit installation to get it right. Also please feel free to point out any steps you added or did not do so others may hopefully be able to install Windows 7.

Ok let me start off by saying I was ready to give up on ever buying AMD or ASUS products again. Especially, since ASUS web site saying their boards is Windows 7 ready. The truth may be that they are ready but NOT easily ready to install Windows 7 on them. I spend almost 3 days working on this project and I have finally figure out a way to install both the 32bit and 64bit of Windows 7 Ultimate on a RAID 1. I do not know if these steps will work on any other board or with any other RAID setup.

Now you will notice that I have 4 hard drives listed. The reason for that is I discovered these steps while trying to install Windows 7 32bit. I did not want to destroy what I had done when I attempted these steps on a Windows 7 64bit install.

After many BSOD and thousand of very choice words I used the following steps. Now you may or may not need to do some of them but these work for me. Also if after reading this you have questions please post them here so I can try and answer them for everyone.

On the 32bit installation

I first configured the bios so that sata channels 1-4 were set to RAID and 5and 6 set to IDE.

Then is plugged in the hard drives and using the onboard RAID configuration tool, configured a RAID 1
.
After that was recognized, I then unplugged both drives from channel 1 and 2 and connected only 1 to channel 4. I left the RAID turned on.

I then proceeded to install Windows 7 Ultimate 32bit. I had previously downloaded all the latest drivers and programs from ASUS website. During the installation of the 32bit version, I did NOT install any additional drivers. I did a complete installation of all programs and updated the drivers and Windows update.

Once this was completed, I also install RAIDXpert2.4.1540.4_X2. I used this to view and work with the RAID setup in Windows.
Then I first plugged the one drive that I had installed the O/S to channel 1. Upon booting the built in RAID controller showed the array as critical but continue to post. Once back into the O/S I made sure I could see everything. With that completed, I powered down and plugged the second drive into Channel 2.

Upon rebooting and going into RAIDXpert, the second drive showed up as a JBOD drive. I just deleted that and a rebuild kicked off. Once the rebuild completed everything is running fine.

Now for the 64bit version. Most of the steps are the same expect for what is below.

After creating the RAID, you will have to go back into the bios and set ALL the SATA controller channels to IDE.

I also again only plugged in one drive to channel 5.

During the beginning of the installation I had the following files on my USB key.

Ahcix64s.cat
Ahcix64s.inf
Ahcix64s.sys
Amdsata.cat
Amdsata.inf
Amdsata.sys
Amdxata.sys

I had to uncheck the hide files button, but I choose to install all of the inf files it provided me.

The installation went on without any problems. Again I did a completed installation and update.

Once that was completed, I powered down and went back into the bios and turn on RAID for channels 1-4. I STILL HAD THE DRIVE PLUGGED INTO CHANNEL 5 AT THIS POINT.

I powered on the system and let it completely boot up. Once that was done, I powered down, plugged the one drive into channel 1 and powered on again.

I had to reboot twice in order to see the drive. I receive a no boot device found on the try. But on the second it saw the drive.

Again I let it completely boot up. I powered down one more time, this time I plugged in the second drive. Powered on again. Using RAIDXpert, I saw both drives with the second as a JBOD, again I deleted it and the rebuild started. Once the rebuild was completed everything ran fine.

adobe win7 32bit
Aisuite V1.05.32 07202009
AMD Chipset Program Driver WHQL V3.0.732.0 07312009
AMD HDMI Driver V5.10.0.5880 08072009
AMD VGA Driver V8.632.0.0 07222009
ASUS AMD Cool&Quiet utility V 2.18.01 07222009
ASUS EPU-4 Engine V1.00.29 07082009
ASUS Express Gate Installer V1.4.10.4 07222009
ASUS PC Probe II V1.04.75 07272009
ASUS TurboV V1.00.41 07312009
ASUS Update V7.17.02 Install Program 07302009
Hauppauge
RAIDXpert2.4.1540.4_X2
Realtek HD Audio Driver v5.10.0.5859_6.0.1.58 07272009
Realtek RTL8111BC & RTL8112L 10_100_1000M LAN Driver V7.3.522.2009 07302009
9-9_vista64_win7_64_dd_ccc_wdm_enu
!