Sign in with
Sign up | Sign in
Your question

Urgent help with 8800gt driver issues

Last response: in Graphics & Displays
Share
April 4, 2008 8:46:24 PM

Hi all.

I have tried and tried to work out a solution for this problem, but failed. I hope someone here has a solution for me.

My System :
Gigabyte P35 DS4
4 GB Ram
Leadtek 8800gt 512 MB
Intel Core 2 Quad Q6600.
Windows Vista x64

My Problem:
I installed my OS, and installed the mobo drivers came with the mobo, then installed the 8800gt driver with the disc that came with it. After restart, in the display settings section, it still says Windows GENERIC graphics adapter. and not 8800GT. I checked the advanced settings and the nvidia control panel isnt there.

So i downloaded a new forceware from the net, for the x64. when i install it, i get a message " The installation didnt find any hardware related to the drivers"....Weird....whats the 8800GT then....

Then i downloaded new motherboard bios, new motherboard drivers.
Updated BIOS
Reformated, installed x64, with all the new drivers. SAME PROBLEM.

Then i reformated and installed x86 Vista...And this time the driver installed flawlessly from the CD provided by leadtek.

I ve already tried to install vista 5 times now. And im tired.. Someone please help....

Thanks

More about : urgent 8800gt driver issues

April 4, 2008 9:14:15 PM

I did download the x64 driver. Here is the exact file name of the file...

174.74_geforce_winvista_64bit_english_whql.exe
Related resources
a b U Graphics card
April 4, 2008 9:18:02 PM

Thats the one, now load it up and see if thats the problem. Sometimes they dont include all optional drivers on the cds
a b U Graphics card
April 4, 2008 9:18:45 PM

Make sure you delete the old driver first
April 4, 2008 9:21:55 PM

Here is the exact message i get when i try to run that file

"The Nvidia setup program could not locate any drivers that are compatible with your current hardware. Setup will now exit."

On the CD, the forceware version is 163.XX and 167.XX..I tried installing both, they install properly, after a reboot, nothing happens no nvidia cpanel nor the name of the driver in the display settings.
a b U Graphics card
April 4, 2008 9:25:16 PM

Wait a minute, thats not the driver I linked you to. Go to my link, download that driver
April 4, 2008 9:27:36 PM

Yes, you linked me to 169.25 driver. Which i am already downloading at the moment.

Maybe that will help, will let you know if it works....but does it make a difference, i mean i just downloaded the newer version than what u gave me and it showed me that error....

a b U Graphics card
April 4, 2008 9:28:21 PM

Its version 169.25
a b U Graphics card
April 4, 2008 9:30:13 PM

Thats the newest most current driver for a 8800GT running Vista 64, the 169.25, the newest driver you downloaded must not be either supported by your card or a 64bit system, and being as its Vista, that also makes a difference
April 4, 2008 9:32:35 PM

ok...its at 62% download......the speed is quite slow over here...so will take another 15 min till its complete...will keep you posted...

Thanks alot for the help so far.....
a b U Graphics card
April 4, 2008 9:34:31 PM

YW, Im thinking thats the problem and all should be well, but if it isnt, come on back and either I or someone will help, good luck and good gaming
April 4, 2008 9:49:06 PM

Dude/Dudette....

I dont know if i should be angry at you or thankful to you.

Thankful : because u just solved the problem ive had for the past 7-8 hrs
Angry : Why the hell didnt u descend from the heaven to me for help 7 HOURS EARLIER....

Thank your very much for the help....

Everything worked out well...i think next time before i shoot myself for not solving aproblem, i should ask help here...
Thanks alot
a b U Graphics card
April 4, 2008 9:51:28 PM

Again YW. And theres alot to learn here, anytime you want help, or contribute, go for it
a b U Graphics card
April 4, 2008 10:59:14 PM

As a note, I think the problem had something to do with driver signing; heard Vista x64 is very picky about that. The 174.74 drivers are BETA right now, but 169.25 are official and signed. When I installed the 174.74 drivers, I didn't use the installer (sorry, I'm old school), I just went through the device manager. If I selected the "find driver" option, it wouldn't update the drivers, but I did the "have disk" and selected the .inf file explicitly and it worked (after warning message about driver signature).

If you still want the 174.74 drivers (which I recommend for performance gain, got a 5-15% FPS gain in Crysis from upgrading), just update through the device manager and point it to the drivers yourself.
April 5, 2008 4:27:59 PM

Zenthar : I did the old school way as well. I selected the INF file from the extracted Forceware folder just to be sure earlier. Even then the device manager said the driver which i was currently using (STANDARD VGA ADAPTER) was the best and current one.

But im happy i can atleast start my games finally..

Thanks all...
a b U Graphics card
April 5, 2008 6:42:48 PM

Just out of curiosity, what does GPU-Z report?
a b U Graphics card
April 5, 2008 7:19:51 PM

The 174 series is only available for the 9X00 series, not the 8800 series. As you discovered the 8800 series drivers are still in the 169's. This is stupid, I know, the 8800Gt has the G92 core just like the 9600, and 9800's. If you did the manual download, you would have noticed that the product series defaults to the Geforce 9 series.
a b U Graphics card
April 5, 2008 8:00:20 PM

techgeek said:
The 174 series is only available for the 9X00 series, not the 8800 series. As you discovered the 8800 series drivers are still in the 169's. This is stupid, I know, the 8800Gt has the G92 core just like the 9600, and 9800's. If you did the manual download, you would have noticed that the product series defaults to the Geforce 9 series.
They are official only for the GF9 family, they are beta for GF8 (I'm using 174.74 on my 8800 GTS 512MB and got FPS improvement from 5-15% over 169.25 in Crysis) you can get them from Guru3D here (x64).
April 6, 2008 4:55:27 AM

techgeek said:
The 174 series is only available for the 9X00 series, not the 8800 series. As you discovered the 8800 series drivers are still in the 169's. This is stupid, I know, the 8800Gt has the G92 core just like the 9600, and 9800's. If you did the manual download, you would have noticed that the product series defaults to the Geforce 9 series.

174.74 work good on my 8800GT (only 174 so far)
Was using 173.65
a c 273 U Graphics card
April 6, 2008 12:05:56 PM

+1 for the 174.74's working fine on a pair of 8800GT's in Sli.
!