Got stuck with USB flash drive boot

I formatted my flash drive using HP USB Disk Storage Format Tool with MS-DOS 6.22 system files but I could not boot up from it. I made the necessary changes in my BIOS in order to boot from an USB device but after restart I got a non-system disk error. I have tested the image file with floppy disk and it worked fine. How do I know my USB flash drive supports booting from it in general. I do not know its vendor. Actually it is a noname (general disk) stuff, I have won it as a prize with some stupid game. :whistle: I took a look at the drive in Disk management section and it was displayed as an active, primary partition. Any idea?
4 answers Last reply
More about stuck flash drive boot
  1. Stupid question: you did make the USB drive bootable when you formatted it, right?

    Maybe you can try the boot file creator here: http://www.bootdisk.com/bootdisk.htm

    Can't vouch for its integrity though. Maybe someone else here can help. You're trying to play old DOS games, aren't you? :D
  2. Ok. Problem has been solved. In MS-DOS 6.22 and before there was no USB support that caused my problem.
  3. I don't understand, wouldn't USB support be reliant on your BIOS? So you're saying that even though you loaded a 6.22 boot on your USB, it couldn't load because it couldn't recognize its own drive?
  4. Yeah, that is totally right. I got an error message that computer cannot locate the command.com.
Ask a new question

Read More

Flash Media Boot Storage