Sign in with
Sign up | Sign in
Your question

Hard drive detected by bios, but not windows

Last response: in Storage
Share
May 21, 2009 8:53:36 PM

Hey all,
I had 3 hard drives connected to my pc with 1 IDE for booting windows and the other and the other 2(SATA and IDE) for storage. I did a reinstall of windows and now my IDE storage drive is not recognized by windows. I looked at the hard drives under computer management but it does not appear at all. It does show up in the bios though. I checked the jumper setting and even tried connecting via usb with an external enclosure. With the enclosure it just found the hardware but no drive on 2 different computers.

Recovering the information on the drive is ideal, but not necessary. That said, does anyone have any idea how to fix this? If I do not find a solution, is there any way to format the hard drive without windows? I thought about installing a different OS on another computer just to format the drive but was not sure if this would work or if there was an easier way.

Thanks in advance.
a c 327 G Storage
May 22, 2009 3:30:14 PM

Let's make sure you "checked the jumpers" correctly - and maybe you did already! Since you have 2 IDE drives, I'll start by assuming they both are on one ribbon data cable. IDE drives ALWAYS have to have some Master or Slave identification because the port will handle 2 drives on one cable. With both on one cable, one should be jumpered to Master (sometimes there's a separate setting for Master with Slave present), and the other to Slave. Note that this has NOTHING to do with the boot drive (boot drive is set in Bios Boot Sequence Priority) - it is just the identifier on the shared cable. The alternative is to set BOTH drives to CS (Cable Select) and let the ribbon cable take care of it. Then make sure the Master is the one at the END of the cable, and the Slave is in the middle.

How is your CD or DVD drive connected? If it is also an IDE device, it should probably be the Slave on one of the IDE ports (probably Port 0), with one of your IDE HDD units as that port's Master. That would require connecting the second IDE drive as Master on the other IDE port. In fact, this MIGHT be part of your trouble. Some CD drives can handle being the Master on an IDE port if it is the ONLY device on that port/cable, but are not "smart" enough to be Master with a second device on the cable. In that case it is important to make the HDD the Master on this two-device IDE port/cable, and make the CD drive the Slave.

When you tried out the second IDE drive in an external enclosure, you would have needed to change the jumper. An external enclosure only holds one IDE drive (usually) so it MUST be the Master - an IDE port can't operate without a Master. So, during your tests, did you set the drive that way? And, did you change it back when returning it to the computer case?

By the way, if you have two IDE ports in your machine and the two drives are connected separately to the ports so that each is the only drive on its cable, then BOTH must be Masters - one for each port - and each should be plugged into the END connector if the cable has two.

If all that is set up correctly, try this next. Disconnect the SATA drive and check the BIOS. If necessary, disable the SATA ports and concentrate on the two IDE drives. Your boot drive should be the Master on the first IDE port (usually Port 0), and the data drive should be either the Slave on that same port or the Master on the other IDE port, depending how you connected them. Try getting the machine to run properly that way. Make sure the BIOS Boot Priority is set to use only the one drive that it should (maybe after your CD or floppy drive).

When you have that working, go back in to reconnect the SATA drive, making sure to reset the BIOS to enable its port(s), and checking again the Boot Priority to be sure it does not try to use this SATA drive or the data-only IDE drive. Should be able to boot and run with all three drives showing.

Watch for a small possible confusion. Often the best way for a mobo to handle a SATA drive is to set the BIOS to use it as an emulated IDE (or PATA) drive. That makes things easier for the OS to handle it. But when you do that, you may find the BIOS display starts calling the SATA unit an IDE drive or a SCSI drive. That may be slightly confusing, but the drive sizes usually will help you keep straight which is which.

Once you've done all this, you may have drives with "wrong names". Windows used to (maybe still does) assign letter names this way: C: is the Primary (Port 0) IDE Master, D: is the Secondary (Port 1) Master, E: is the Primary Slave, and F: is the Secondary Slave if it exists. Then it assigned the next letter to the next device, like SATA Port 0. If that's what your system does to you and you like it or can tolerate it, OK. But often that is a problem because your system already is set up with the CD drive as D: and it depends on finding CD items there, or something like that. If you need to change drive names after they are all working, you can do that through the Disk Manager. When doing that you can't (even temporarily) use the same letter for 2 devices. But you can create "space" by assigning unique letters, even if only temporarily, to each device, and then coming back to re-assign the final names to each.
May 22, 2009 7:18:26 PM

Thank you for you input. My dvd drives are IDE. I tried everything you said and even tried disconnecting everything except my boot drive and the data drive which I set up as masters on their own ide ports but the end result was still the same. Do you think the drive will be recognized by windows if I format it? How can I format without using windows?
Related resources
May 22, 2009 7:43:58 PM

I had recently had a similar problem. It turns out it was Norton GoBack that did something to your hard drive and prevented the hard drive from being recognized by Windows even if the hard drive shows up in BIOS and Device Manager. If you do have GoBack on those old hard drives, try to find a way to disable it might work.

Good luck!
a c 327 G Storage
May 22, 2009 8:54:25 PM

Abscissaordinate has an interesting idea. Whether it was GoBack or something else, maybe that drive had its contents written oddly or hidden in places locked by a password. If you really have given up on recovering its contents, you certainly can wipe it clean and start over, and you should not have to go outside Windows to do it. I'm familiar with XP, so I'll write about that.

Disk Management has two windows to examine, and I'm not clear which you refer to. Click on Start, then RIGHT-click on My computer and choose Manage. In the window expand Storage if needed, then choose Disk Management. On the right are TWO windows, both scrollable. The upper one shows all the devices Windows can use. The lower one shows those plus other devices Windows does not understand well. You should see your IDE storage disk there. If you can, then you should be able to do the three steps necessary to make a disk usable by Windows. First you right-click on any and all partitions it has (one at a time) and Delete them all. When you have no Partitions left, only Unallocated Space, You can right-click on it and choose to create a new Partition. This will be the drive's Primary Partition, and since this is for data only do NOT make it bootable. I presume you would like it to take up all the available space on the drive as one volume. When that is done you right-click on it again and choose to format this Partition setting it to use the NTFS File system.

This process should wipe out all previous data and get it ready to Windows to use as a blank disk. Reboot and see if it shows up in My Computer.

On the other hand, if you still want to retrieve the disk's contents, see if you can remember whether it was using some special software like GoBack. If so you might have to install that software and use it to read the disk. Then you should be able to disable the software so that disk no longer depends on it, then un-install that software so it does not interfere any more. Once you get the data off it completely, try the Partition and Format sequence to wipe it clean and start fresh.
May 23, 2009 4:59:32 AM

You didn't by chance convert the disk to a "Dynamic disk" under you previous OS, did you?
If so, try using a Partition utility like partiton commander. It will allow you to see the contents of the drive and move the data to another drive. You can also convert the drive back to NTSF withoutt loosing your data.
Even if you didn't convert the drive, a good partition utility will allow you to see the drive.
a b G Storage
May 23, 2009 12:41:45 PM

Quote:
I'm having a similar issue. I've been running a couple of elderly 120gb IDE drives for years, and decided I needed an upgrade. I'm on a budget, so I bought an Ebay white label 1.5TB SATA drive and a 150gb WD Raptor drive. Raptor hasn't arrived yet, so I thought I would at least set up the 1.5TB drive and transfer all my media and such over before I remove the older drives and set up Vista x64 on the Raptor.

Anyway, I hooked up the 1.5TB to the SATA1 port, and booted up the machine. BIOS sees it no problem, and I can see it in device manager, but it doesn't show up in My Computer. I've read alot of the posts in this forum and others, and haven't found anything that works yet, so I thought I would try just starting fresh. I'm not sure how to tell BIOS to consider it an IDE drive; there's no option for that as far as I can tell. I'm not running anything by Norton.

Any thoughts?

Asus M2N-SLI Deluxe Motherboard
Vista 32bit Ultimate SP1 (upgrading to x64 once I get the Raptor)




You should not hijack other people's threads. It is considered rude.
If you have a question, start a new thread.
May 23, 2009 1:12:03 PM

Quote:
You should not hijack other people's threads. It is considered rude.
If you have a question, start a new thread.


Sorry, I'm new to to the forums. I had a similar issue, so I thought I would ask. I didn't mean to be rude; I'll start a new thread.
Thanks for the advice.
!