Sign in with
Sign up | Sign in
Your question

Uncommon issue with the recycle bin?

Last response: in Windows XP
Share
August 7, 2010 10:38:34 PM

A few days ago I noticed something unusual within my recycle bin. There were hundreds (literally) of empty folders with the dc prefix, and most ending with .org's, .nets, and whatnot. Last night I made an effort to remove these files from the recycle bin, only to be greeted with the all too familiar:
"Cannot remove folder dcxxxx. Access is denied."
Attempts at removing them via the Unlocker program only seems to create a new, identical folder while removing the previous. There are currently 57 of these folders in my recycle bin, and though they are not visible in the folder (even with hidden files and system files toggled), the recycle bin still shows as being filled. I have found the same folders in the C:\RECYCLER subfolder, however I am only meeting the same issue in there. I have run checkdisk, I have tried "repairing" the registry from the site listed here:
http://www.dougknox.com/xp/scripts/recycbin-2.reg
I have also attempted cmd prompts that have had no effect - even when I am running as administrator in safe mode. The line I was instructed to try (from another similar thread in these forums) was "rd \RECYCLER /s" which returned a list of all the folders and access is denied (obviously).
There is another user on this computer that is not experiencing this issue whatsoever. Lastly, any other item I attempt to delete will delete normally.
So I ask - what am I doing wrong, and how can I fix this irritating bug?
August 8, 2010 2:59:20 AM

The recycle bin obeys the orders of the registry as to what you will or will not see.
If you can see it, you can control it. You can then alter the permissions of any file or folder.

You obviously need to see the files in the recycle bin. You may need to restore them back where they came from to actually get rid of them also.

If you must restore them to get rid of them, turn off the recycle bin when you go to delete them for the last time, or they will just go back to the recycle bin and you will have gained nothing.

I made a post that explains how to cause every file in your computer to show itself.
If you decide to have full disclosure of what is in your hard drive(s), use this wisely and read and heed my fair warning.


http://www.tomshardware.com/forum/249318-45-show-hidden...
m
0
l
August 8, 2010 8:28:59 AM

Strangely, that seemed to have the opposite effect. Now I can't seem to view ANY hidden files, even after a restart - and yes, I did double-check the folder options to make sure. Each time I go into folder options, the "do not show hidden files and folders" is the one selected, and I can't seem to get it to register the other option. Once I tell it to show them, and hit apply, nothing happens. Clicking OK and then going back into the folder options reveals it has reset itself again.
m
0
l
Related resources
August 8, 2010 8:41:47 AM

I managed to fix the latest issue about the hidden folders by going to the registry folder in
"HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\
Explorer\Advanced\Folder\Hidden\SHOWALL"
and deleting/replacing the checkedvalue key as a DWORD.. However I'm still unable to see anything in the recycle bin.. :( 
m
0
l
August 8, 2010 2:52:40 PM

Cephara said:
Strangely, that seemed to have the opposite effect. Now I can't seem to view ANY hidden files, even after a restart - and yes, I did double-check the folder options to make sure. Each time I go into folder options, the "do not show hidden files and folders" is the one selected, and I can't seem to get it to register the other option. Once I tell it to show them, and hit apply, nothing happens. Clicking OK and then going back into the folder options reveals it has reset itself again.



So, it wants to stay ticked on hide hidden eh..... Copy everything in red below, paste into notepad, save as whatever name you like but with the ".reg" extention, and change the filetype in the save dialog drop-down to "all files." add this:

Windows Registry Editor Version 5.00

[-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\Hidden]

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\Hidden]
"Text"="@shell32.dll,-30499"
"Type"="group"
"Bitmap"=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,\
00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,53,00,\
48,00,45,00,4c,00,4c,00,33,00,32,00,2e,00,64,00,6c,00,6c,00,2c,00,34,00,00,\
00
"HelpID"="shell.hlp#51131"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\Hidden\NOHIDDEN]
"RegPath"="Software\\Microsoft\\Windows\\CurrentVersion\\Explorer\\Advanced"
"Text"="@shell32.dll,-30501"
"Type"="radio"
"CheckedValue"=dword:00000002
"ValueName"="Hidden"
"DefaultValue"=dword:00000002
"HKeyRoot"=dword:80000001
"HelpID"="shell.hlp#51104"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced\Folder\Hidden\SHOWALL]
"RegPath"="Software\\Microsoft\\Windows\\CurrentVersion\\Explorer\\Advanced"
"Text"="@shell32.dll,-30500"
"Type"="radio"
"CheckedValue"=dword:00000001
"ValueName"="Hidden"
"DefaultValue"=dword:00000002
"HKeyRoot"=dword:80000001
"HelpID"="shell.hlp#51105"

m
0
l
August 9, 2010 10:53:28 PM

Well I've found a bit of a loop it would seem. The first code you gave seems to change the type of key that "checkedvalue" is in the registry, which then makes it nonfunctional, at least for me. If I delete the key (which is now a REG_SZ) and replace it as a DWORD, it begins working again. The other code I can't seem to see any difference in anything, sadly. I still cannot view the items directly in the recycle bin, though they ARE visible in the C:\RECYCLER folder.
m
0
l
August 9, 2010 11:16:29 PM


Record where they came from and restore them. Disable the recy bin. Go to restored location and delete them from there.

My registry patches have never failed anybody... until you. It makes me wonder about your recy bin.
m
0
l
August 10, 2010 12:54:12 AM

Lol yes. It makes me wonder what I've done..
m
0
l
!