Sign in with
Sign up | Sign in
Your question

Windows Vista Error Code 31

Last response: in Systems
Share
March 31, 2008 5:44:14 PM

I have two USB devices that are no longer working on my computer... My Microsoft Zune (G2) and my Motorola Q9M. They worked fine a few days ago, but now they no longer work. When I view them in the device manager, they have a yellow exclamation point and the following error:

This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)

I am using Vista Home Premium x64, and I have many other USB devices that are working fine. I searched the net and found no solutions, I have also tried switching USB ports and restarting my machine... nothing fixed.

Yesterday I installed MagicISO/MagicDisk, then uninstalled it because I didnt like it, would that make a difference?
March 31, 2008 5:57:50 PM

I honestly dont know much about stuff like this, but if you installed and then uninstalled an application, then have problems, that application may or may not have somthing to do with it.
You said you have other usb devieces working just fine. Can you list them ALL please.

ISO.... Storage? Both the phone and the zune are storage devices. Maybe the application did somthing.
Also try google search.
March 31, 2008 6:08:39 PM

I tried google search... nothing came up except stuff for CD drives, which dont fix my problem...

I have the following USB devices:
2 Playstation Controller Adaptors
1 Microsoft Wireless Natural Multimedia Keyboard
1 Microsoft Wireless Intellimouse Explorer 2.0
1 160GB Western Digital External Hard Drive
Related resources
March 31, 2008 6:12:25 PM

Have you tried installing the drivers for the zune yourself?
March 31, 2008 6:23:11 PM

I dont really think its a driver problem... besides, I cant find the drivers for the zune on the net... Not to mention, the problem affects my windows mobile phone as well.
March 31, 2008 6:25:46 PM

HardForums had my answer... thanks for the help!
March 31, 2008 6:29:08 PM

No problem! Can you briefly explain the awnser?
Also, this should be posted under another thread area, youd get better awsnsers
December 19, 2009 8:28:56 PM

Hell Jaxel,

I have a similar problem like what you had with a couple usb devices in particular portable devices like two memory card readers that are listed in device manager with a conflict as WPD FileSystem Volume Driver under Portable Devices. They still work and so do USB jump drives but they show up in device manager with conflicts.

I saw in your post that you found a solution HardForums, but I could not find it. Could you please help me out? Any help would be tremendously appreciated!

Thanks!

Moises
moises.moraga@yahoo.com

P.S.
I have windows 7 64bit.
December 23, 2009 7:37:58 AM

I'm having the same problem too with two of my memory card readers AND my Windows Mobile phone.
Anonymous
a b B Homebuilt system
July 14, 2010 8:49:01 AM

has anyone found a solution to this problem yet? ive been having the same problem with my usb ports not working, card reader not working.
!