Sign in with
Sign up | Sign in
Your question

Esata hot swap problem

Tags:
  • Storage
Last response: in Storage
Share
May 24, 2009 3:15:10 PM

I have a problem with my esata port on Asus P6T Jmicron controller under Windows 7 x64 7100 and Vista Sp1 x64 I have tried the whql 17.47 driver and the newest 17.48 driver (both esata and esata no write cache), jmicron bios set to ahci mode. The hard drive that is connected to the esata port shows up in the safely remove device window, but windows doesn't let me eject the drive( saying that the drive is busy please close all programs thats accessing it.) Both system restore and page filing are turned off on that drive, antivirus is not actively scanning that drive and I have also tried disabling AV. It is also been set to "optimized for quick removal". Even if its a fresh formatted hard drive once it is plugged in and recognized, windows will not let me eject it. I also have to restart windows if I switch drives for it to be discovered(scanning for hardware changes doesn't work). But if I boot up the computer without a esata drive connected and then plug it in, windows discovers it just fine. Thank you for your time and your help!

Hard drives that I have tried with:
Seagate Barracuda.11 250g
Seagate Barracuda.11 500g
Seagate Barracuda.12 1TB
Hitachi Deskstar 7k1000 500g

More about : esata hot swap problem

a b G Storage
June 8, 2009 10:00:33 AM

Try using Unlocker to make sure your hard disks are totally free from Windows. Also, Windows might not like eSata disconnects.
m
0
l
October 3, 2010 2:53:21 PM

I have just the opposite problem with my Asus P6X58D motherboard under Windows 7 Ultimate x64. The machine crashes when I insert a drive, not when I unmount.

I have an Antec Easy-Sata caddy installed in an external 5.25 bay that holds a bare drive like a giant floppy. Its SATA cable is connected to one of the internal motherboard SATA connectors.

If I start the computer with the drive in, it mounts and operates fine. If I eject it using the Intel Rapid Storage utility, it says "drive was disconnected" or some such with no issues.

If I insert the drive, however, it operates okay for about ten seconds, IRS says "drive recognized," then Windows 7 crashes to the blue screen of death.

I reinstalled IRS. No luck.

On my HP Z400 at work, my esatas weren't working until I discovered that I can select "internal" or "esata" for each sata port in BIOS. If I don't have "esata" selected for a given sata port, the drive is not recognized or hot swappable. If I select "esata" the drive works like a USB drive, giving me the ability to eject is from the tray safely. When I insert a drive, it mounts normally. In other words, it works perfectly.

For some reason, this ASUS BIOS together with Intel IRS assumes I can use drives as esata. But every time I insert a drive, Windows 7 Ultimate crashes.
m
0
l
November 15, 2010 1:01:28 AM

Koblog, did you ever figure out what was causing your problem? I'm having the same issues with my Win 7 64 bit Pro and trying a couple different drives here via esata. I thought it initially was the psu, but it still does it with a new one from a different manufacturer. I even tried a different case with different brackets/backplanes/cables :( 
Thanks
m
0
l
!