Keyboard and mouse stopped working

So im not running anything on my pc and step away for about a hour and when I come back I notice my mouse (g500) and keyboard (@#$% logitech) have no power. Tried booting in safe mode didn't matter computer doesn't even act like I plugged it in any USB port. Doesn't even show in device manager. I installed a sound blaster audigy se 7.1 sound card yesterday and everything worked fine all day and night and most of today so I didn't think that was the issue but just to check I uninstalled the card and drivers...no change.. I'm on @#$% vista so I did a system restore to when it worked...still doesn't. Mouse and keyboard work fine on another pc. I assumed something with my USB ports.. Tried plugging my phone charger into it to check and see if it worked and it worked in every USB slot. Tried a @#$% logitech mouse and it gets power but doesn't work. Managed to find a old ps2 keyboard to navigate somewhat through the pc but don't have a old mouse...Any ideas on the problem? Here's my pc specs tried putting drivers on a USB drive from another computer. Doesnt see the USB stick..
if needed.. (have a 400w psu and 8600gts graphics card)
http://h10025.www1.hp.com/ewfrf/wc/document?cc=us&lc=en&dlc=en&docname=c01302540
4 answers Last reply
More about keyboard mouse stopped working
  1. Smig said:
    So im not running anything on my pc and step away for about a hour and when I come back I notice my mouse (g500) and keyboard (@#$% logitech) have no power. Tried booting in safe mode didn't matter computer doesn't even act like I plugged it in any USB port. Doesn't even show in device manager. I installed a sound blaster audigy se 7.1 sound card yesterday and everything worked fine all day and night and most of today so I didn't think that was the issue but just to check I uninstalled the card and drivers...no change.. I'm on @#$% vista so I did a system restore to when it worked...still doesn't. Mouse and keyboard work fine on another pc. I assumed something with my USB ports.. Tried plugging my phone charger into it to check and see if it worked and it worked in every USB slot. Tried a @#$% logitech mouse and it gets power but doesn't work. Managed to find a old ps2 keyboard to navigate somewhat through the pc but don't have a old mouse...Any ideas on the problem? Here's my pc specs tried putting drivers on a USB drive from another computer. Doesnt see the USB stick..
    if needed.. (have a 400w psu and 8600gts graphics card)
    http://h10025.www1.hp.com/ewfrf/wc/document?cc=us&lc=en&dlc=en&docname=c01302540


    1 - Try unplugging completely from power outlet, wait a few secs.
    (Someone said this actually worked for them, not my personal experience)

    2 - DeviceManager: Expand the USB Controller. Right click each HUB and scan for new hardware.

    Hope something is of use !
  2. Tried that also same results. Also tried deleting the USB root hubs and a restart to let them be found no change.
  3. Tried downloading newest bios for my motherboard on hps site. Got this message on restart "Default BIOS settings have been loaded due to BIOS or checksum issue" any ideas
  4. Bios is fine also I tried a USB to ps/2 adapter for the mouse and keyboard and they still do not work. I have no clu what it coul be but it only seems to be a problem with the mouse and keyboard
Ask a new question

Read More

Mice Keyboards Windows Vista