Dell Laptop stuck on Microsoft Corporation loading screen.

I am trying to re-install Windows Vista from the CD that the laptop came with. When I boot from CD, it stays at the "Microsoft Corporation" screen with the green bar moving back and forth. I also tried using a Windows 7 CD and it did the same thing except it was on the "Starting Windows" screen.

I ran diagnostics on all the hardware, and they all passed. The hard drive is formatted so its completely blank.

When I inserted a Ubuntu CD it worked perfectly. But I really need to have Windows Vista on the machine.

Any suggestions? I'm using the discs that the laptop came with.

Dell Studio Laptop
4gb RAM
WD 5400k rpm 320 HDD
Core2 Duo
1 answer Last reply
More about dell laptop stuck microsoft corporation loading screen
  1. so it worked fine when you booted from the ubuntuCD? Or did you actually install ubuntu on the hard disk? You may want to replace the hard disk to see if you can install windows vista or windows 7
Ask a new question

Read More

Laptops CD-Rom Windows Vista