Sign in with
Sign up | Sign in
Your question

2 disk raid array only works with third hd plugged in

Last response: in Storage
Share
May 31, 2009 8:09:25 AM

so i have a pretty strange problem. i have a 2 disk raid 0 array and it is used to boot my OS from. for some reason, this raid array will not boot my OS when i take out my 1tb back up hard drive. this drive is not part of the array so i don't understand why the raid array will not function without it. when the 1 tb drive isnt plugged in, the system posts fine. my mobo's raid card even reports the array as being healthy and set as bootable, but the drives will not boot my OS. my pc usually doesnt post an error message when i try to boot without the third drive, but afew times it reported that the array had a bad disk and this disk needed to be replaced. after i got this message i hooked the 1tb drive back in my rig and it booted the OS just fine, so im pretty sure both disks in my array are fully functional. i did some troobleshooting to try to figure out what was causing the trouble and here are the results:

-tried using a different power cable on the 1tb drive(using the same sata cable/port) and, even though the drive had power and was recognized in the bios) the system would not boot the OS :heink: 

-installed a different hard drive into my rig using the same sata/power cables that are usually used by the 1 tb drive. didnt solve the problem

-used different power cables for the 2 disks in my array and tried to boot without the 1tb installed. no luck

-installed the 1tb drive using a different sata cable/port and the system booted up normally

im starting to think maybe the raid drivers on my pc are currupted or something, but i reformatted the drives and reinstalled the OS(including raid drivers) about 2 weeks ago so i dont know how drivers could be the issue. the 1tb drive doesnt contain any windows system files or anything like that so i dont know why my OS wont work without it. this is really starting to piss me off so any ideas would be appriciated.

system info:
mobo- nvidia 780i sli
gfx- 2 sli'd gtx 260's
core- q6600
hard drives- wd 640 gb, seagate 640 gb, hitachi 1tb
a b G Storage
May 31, 2009 1:54:32 PM

Sounds to me like you have had Windows installed on the backup drive, and then you installed Windows later onto the array, without taking the backup drive out first.
This is EXACTLY what will happen.
Try doing a fresh install to that array with ONLY the array plugged in, no other HDD in the system.
a b G Storage
May 31, 2009 11:22:13 PM

Windows probably installed the OS loader onto the single hard drive.
unplug the single hard drive and either reinstall the OS to the raid array or if its vista you can use the repair install function. to fix the problem
Related resources
June 3, 2009 4:24:15 AM

alright. thanks for the help
a b G Storage
June 3, 2009 5:20:33 AM

Which drives are attached to which controller?
Or are all three attached to the nForce 570 MCP (southbridge of nF 780i)?
!