Sign in with
Sign up | Sign in
Your question

Event ID 9: Iastor error / timeout

Last response: in Storage
Share
May 31, 2009 9:20:01 PM

Hello,

In last few months, I began getting the error:
Quote:
The device, \Device\Ide\iaStor0, did not respond within the timeout period.


My system hangs and slows to a crawl. Error seems to be well-known, and solution is to install the latest version of Intel Matrix Manager, which is 8.6.


Thus far, I've tried the following:
1. Reformat / reinstall. Helped, but problem not eliminated.
2. Ran SeaTools Disk Diagnostic. No issue.
3. Installed Intel Matrix STorage, most recent version 8.6. Should've fix prob, but didn't.
4. Upgraded Bios from 7.5 to 7.9.
5. Ran sfc /scannow.
6. Changed registry settings for iastor/LPM per website suggestion.
7. Installed 3 new 1TB SATA drives; only my system drive remains unchanged.

Problem is significnatly improved, but not eliminated. This problem is driving me crazy so I'd appreciate suggestions. From my perspective, only two items left to address;
1. Replace System drive, C:
2. Replace motherboard.

Scott

System Details:
Core2 2.40GHz, 1066 FSB; MSI 975X Platinum V.2 975X , BIOS 7.9; 4x1GB Corsair DDR2-800; 600W Zalman Heatpipe; 1x250 GB Seagate SATA-2 + 2x1 TB Seagate SATA-2, RAID1 + 1x 1TB Seagate SATA-2; 2x SONY DRU-830A DVD/CD Combo; MSI GeForce 8600 GTS; Samsung 245BW; VISTA-Ultimate

June 2, 2009 6:48:05 AM

You'll have to eliminate either the hard disk or the motherboard as the problem. Which means testing them with components that work (hard disk with other mobo, mobo with other hard disk).
March 25, 2011 11:44:01 AM

I have worked on hundreds of these problems. It boils down to the Bios setting of SATA configuration. In each of the cases I worked on I chaged the setting from IRRT to ATA and the problem was eliminated. We are working with Dell for a solution as this is only a temp fix for now.
!