Sign in with
Sign up | Sign in
Your question

Driver_IRQL_Not_Less_or_equal scsiport.sys

Last response: in Systems
Share
April 6, 2008 7:18:26 PM

Hello everyone,
This is my first post here and im hopeful someone might be able to give me some direction as to what to do as I never encountered a problem like this before.

First the tech specs:
Intel extreme quad core 3.0 ghz
4 gigs corsair ram
SLI'd 8800 GTX PNY overclocked
780i nvidia mobo
1000w power supply
A+ el diablo case
creative audigy sound card
1 terrabyte harddrive
1 dvd multirecorder litescribe drive (sata)
1 dvd drive (IDE) - pulled from an older machine.
Windows xp 64bit fully patched

Problem:
When I first built this computer I wanted to have 64bit vista on this machine. I kept blue screening after it would copy and install the files. It would reboot after doing the inital install then launch vista and I would get a blue screen. After 4 failed attempts I gave up and Put xp 64bit on it. (I got free OS's through a college program)
So after putting in XP it went smoothly. Now I tried to install a few games. Medieval total war 2 and its xpack installed fine. However if I put in Call of Duty 4 it instantly crashes when the cd goes into the drive. Last night I had a friend over and I tried putting in some music cd's and a blank disc to burn something on it. All of which crashed with the same blue screen.
I was told to do a memory test to see if it was the ram (I Didn't think it was but it was advice so I tried it anyway) and it came out fine. I was also told to download a tweakui and disable auto play. I did that and I still get the blue screen.
Here is a picture of the bluescreen that I took today.


Please help!
April 6, 2008 7:33:42 PM

Well, I've never encountered it, but here are some threads where others have. Maybe some of these will help:

http://www.tek-tips.com/viewthread.cfm?qid=308429

A google search turns up hundreds of people with the same problem. Maybe try reinstalling the drivers. If that doesn't help, you could try some of these peeps suggestions (like a chip is overheating, etc.).
April 6, 2008 9:17:20 PM

So far to update this post with what ive done.

I tried to uninstal and reinstall the drives. I figured if it was a driver by redownloading the driver it might fix the issue. However it did not.

I also ran a start / run / sfc /scannow and that seemed to check out aswell.

I turned off the pagefile to see if that was an issue. It did nothing to fix the issue.

here are some error messages im seeing in the event viewer:

1. The IMAPI CD-Burning COM Service service entered the stopped state.
For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

2. The driver detected a controller error on \Device\CdRom0.
For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


Anyone?


also upon checking my event viewer it is litered with this error message:

The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID
{BC866CF2-5486-41F7-B46B-9AA49CF3EBB1}
to the user NT AUTHORITY\NETWORK SERVICE SID (S-1-5-20). This security permission can be modified using the Component Services administrative tool.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Related resources
April 6, 2008 10:13:16 PM

Does the BSOD happen when you try to use either drive or is it only with a specific one?

Are you installing the drivers manually or just letting Windows Update do it for you? Maybe your older DVD drive is automatically installing a 32-bit driver instead of a 64-bit one.
April 6, 2008 10:26:04 PM

Well thats another story all in itself which I want to tackle after I get this issue resolved but the long short of it is... the IDE dvd drive isnt totally working. The computer recognizes and sees it. However if I put a disc into the drive and try to access it it freezes and I have to alt ctrl delete.
When I reinstalled the drivers I let windows do it and I updated the litescribe drive first as thats the one that is working.
The date on the driver is from late 2002.
April 6, 2008 11:38:54 PM

Use 1 HDD, your SATA DVD, no sound card, only onboard soound.
Boot up and see if the problem is still there. If not add your other compnents one at a time until you find out which one is stubborn. After that it will be easy to to assist you. Right now there is to much to go through.

I suspect you IDE drive probably needs to be on cable select or slave because if its on master its somehow fighting for 1rq that is being used.
April 6, 2008 11:46:19 PM

tried rebooting in safe mode. it read the music cd that I had put in there but obviously couldn't play it as audio drivers werent loaded into safe mode. So its a driver issue. But I still have no idea what driver it would be or anything like that.

Also the IDE drive was originally on cable select.
April 7, 2008 2:22:40 PM

Well I ran a memory test on my system while I slept it ran for a couple hours and everything checked out. The only reason im hesitant that its the memory besides the fact that the test came out alright is that the games I did get on my machine work fine. Its just if I put certain cd's into the drive does it give me that blue screen. Im not seeing a connection to the ram in a scenario like that. Again if im wrong please correct me but wouldn't that be a driver issue with the drive? In this case in the blue screen a scsiport.sys?
April 7, 2008 3:03:25 PM

Try a different DVD drive.
April 7, 2008 3:11:46 PM

Ok now this may sound total BS ..but i had the same problem... i got mindf****d for a week trying to resolve the issue... what i did later was i switched the cable modem connection from USB to NIC (LAN card) .... and bingo it worked. Havent had a bsod ever since.

I know it sounds very dumb, but try it. :) 
April 7, 2008 3:45:01 PM

I've had a bunch of BSOD's as well over the past year with the IRQL. I haven't found the source of the problem but I think it has to do with IRQL sharing of devices and getting crossed up when both access the system. You can try to manually change your IRQL settings, or unplug hardware 1 ata time to find the source (but if it's two devices causign the problem this won't work well), or try to track down the BSOD codes:

http://aumha.org/a/stop.htm
April 7, 2008 3:49:22 PM

Well, although mihirkula's problem probably isn't yours it brings up a good point. It is likely that two devices are fighting for the same spot. Try manually setting the DVD drives. Set the SATA to master and the IDE to slave. It probably won't work, but what harm can it do.
April 7, 2008 6:46:09 PM

how do you set a sata to master when the sata drive doesnt have a jumper. Is that a bios setting? I may just try to unhook the ide drive and see if that fixes it as a quick test solution just to see. The ide was set to cable select before I know that for fact thou.

As for the cable modem connection fix I already am using the onboard nic so that wouldn't help here.
April 7, 2008 7:29:01 PM

Driver_IRQL_Not_Less_or_equal error means bad RAM or too agressive overclock. I never saw a scsiport.sys error though both bad RAM and overclocking could corrupt data from hard disk drives.

Use memtest86+ to test your RAM. Best to use 2-3 versions as each versions use different tests which means that one of the tests from a particular version may react to bad RAM. I prefer version 1.70 and 2.0 for test but some older versions as well works pretty well. After that you know it is not your RAM.

If you are overclocking then it is too agressive lower or even cancel the overclock.

hope it helped.
April 7, 2008 7:54:56 PM

Sorry rocky, I forgot that. Try removing the IDE drive like you said (its been a while since my last comp build).
April 7, 2008 8:15:58 PM

If your not overclocking then it must be RAM problem.

predaking said:
take out 2 gigs.

http://support.microsoft.com/kb/929777

run that update on vista. or get a vista service pack 1 disk.

then put in the other two gigs.


Didn't know Vista doesn't always work with 3GB+ RAM. I was thinking to get up to 8GB RAM with vista... now I will know what to do if that happens to me.
April 7, 2008 8:27:15 PM

I found the following microsoft files:

http://support.microsoft.com/kb/905205
http://support.microsoft.com/kb/839635

This stop error means that the scsiport.sys(or that a driver using that) is trying to access pageable memory incorrectly. see: http://msdn2.microsoft.com/en-us/library/ms795930.aspx

I agree with roadrunner197069 that you need to troubleshoot the hardware. Either take it out of the system and bootup to see if the error is there, or disable what you can disable and still be able to run the computer then reboot and test the computer.
April 8, 2008 12:44:55 AM

ok I tried taking the ram out of the system and booting with 1 at a time. Everytime the CD was loaded into the system it crashed with the same error. Its not the ram its a driver.
April 8, 2008 12:58:25 AM

Have you tried either the IDE drive alone or the SATA drive alone? I agree with you that it doesn't sound like a ram issue (since you've tested your ram about every way possible).
April 8, 2008 1:23:57 AM

^ I agree with EXT64. I had this problem and took out SATA CD - writer and installed IDE CD writer in and no problem since then.
April 8, 2008 2:04:40 AM

I've never used a SATA DVD drive, but I am on my next build (cross fingers).
April 8, 2008 5:42:36 AM

Unplug all your dvd drives, nic connection, extra RAM, usb connections, mouse....... reinstall windows..check if you're getting the same problem.

ps: what about your mouse and keyboard, are they ps2 or usb? .

also check http://www.vladd44.com/other/irq_error.php
!