GA-M57SLI-DS4 Integrated Lan will not connect above 10mbps

I have a GA-M57SLI-DS4 mb that has an integrated gigabit Lan controller that refuses to connect at anything over 10mbps. It shows as a nVidia nForce Networking Controller.

I've tried autonegotiate, force 100Mbps FD/HD, etc. The controller will appear to connect, however, the connection is too slow to be usable. When I force it to 10Mbps FD, it works fine. I can surf, etc. and it works ok - just at 10Mbps.

I have updated the latest nvidia nforce drivers and the drivers for my MB. Are there any configuration options that could help connect at 100Mbps (or gigabit)? I've gone through every possible combination of LAN settings - autowakeup enable/disable, vlan, etc.

Thanks
Rob
5 answers Last reply
More about m57sli integrated connect 10mbps
  1. It's possible that the issue lies with your router/modem.
  2. Could be - I actually went down this path...

    I originally plugged this PC into my D-Link Wireless router - it's 10/100 wired. When I could only get 10Mbps, I bought a Linksys 10/100 hub (no wireless) and plugged in there. Still get no more than 10Mbps.

    The strange thing is that another PC on my network connects at 100Mbps consistently.
  3. bump...

    I have since tried TCP optimizers, to no avail. I am able to force 100Mbps Full Duplex, but the connection is so slow that it is unusable. When I go back to 10Mbps, it works fine - just at 10Mbps which is too slow to do a network backup.

    Any ideas? Are there any good TCP sniffers out there that will tell me if there are collisions/errors/retries, etc?
  4. Well, my network guys here at work are telling me that 10/100/1000 cards do not play nice when plugged into a 10/100 hub - they are telling me get a Gigabit hub and I should be fine.

    I just ordered the linksys 5-port Gigabit hub from amazon - I'll post back if this works - maybe someone else is having this problem.
  5. Definitely the hub (thanks bdcrlsn).

    Apparently, when you take a gigabit NIC card and plug it into a 10/100 hub, the NIC says it will connect at 100Mbps, but the connection is obviously much slower and is unusable. Forcing it to 100 has no effect. Forcing it to 10Mbps works, but.... it's 10Mbps. Makes me feel dirty running at 10mbps on a gigabit card.

    So, I got a Linksys gigabit hub and all is running great now - MUCH faster.

    Hope this helps someone else out there.

    Later
    Rob
Ask a new question

Read More

Gigabyte Connection LAN Controller Motherboards