Sign in with
Sign up | Sign in
Your question

SATA hard drive not detected in BIOS

Last response: in Motherboards
Share
June 5, 2008 1:01:46 AM

I have a MS-7093(MSI RS480M2-IL) motherboard and the BIOS is not detecting my Maxtor 6L200MO 200GB Sata hard drive. I have reason to believe that it may be the Sata controller drivers but I do not know how to reinstall them or which driver I would need. I have tried to do a clean install of xp and see if that would install the required drivers but the hdd is still not detected. Any help or advice with this would be appreciated.

June 5, 2008 1:42:57 AM

Did the system work with this drive previously or is this a new addition to the system?

The SATA controller on this board is a 1st generation controller, only does 150mb sata vice 300 on current controllers. Many drives have a compatability jumper on them to set them to 150mb mode, ensure that if this drive has that option, that the jumper is in place. This issue can sometimes cause problems with older controllers. Your SATA controller drivers should be on the drive CD that came with the system or download them here http://global.msi.com.tw/index.php?func=searchresult&ke...

Edit: The drive is a SATA I drive, it doesn't require a compatibility jumper setting. However, it is an old drive, check it on another system if possible to see if perhaps it has died on you.
June 11, 2008 2:49:27 AM

Ok I purchased a brand new Western Digital drive and it is still doing the same thing no matter which jumper settings I use. I am totally lost on what to try next. Please help!!!
January 21, 2010 5:54:57 PM

I've had the same problem. I had a 200 gig SATA drive that worked fine but I have replace it with a Seagate Barracuda 1.5 TB. I had to slipstream the XP installation disk with the nVidia drivers and XP booted fine. I have a M2N-X mother board and I updated my BIOS to 9.06

[ SMBIOS: Type0 ]
Vendor = American Megatrends Inc.
BIOS Version = 0906
Starting Address = 0xf000
BIOS Release Date = 03/20/2008
BIOS ROM Size = 512 KBytes
BIOS Characteristics = 0x000000017f8bde90

and when I turn off the system the BIOS no longer sees the hard disk. If I go to the BIOS and change the ide settings for the SATA drive to AHCP it then sees it but crashes when booting XP. I then go in and change it back to SATA and reboot and it again boots fine. This is a work around but I would like to determine why it does this and fix it. Has anyone else experienced the same thing?

!