Sign in with
Sign up | Sign in
Your question

PC lags when accessing IDE disks

Tags:
  • Hard Drives
  • SATA
  • Music
  • Storage
Last response: in Storage
Share
June 12, 2009 8:20:02 PM

Hi, I have 2 SATA's and 1 IDE HD. When ever i write to my IDE drive the PC lags like its a celeron 400 MHz. Mouse becomes choppy and if im listening to music (music is stored on the IDE) the music starts to lag, like its running at 1/16th the normal speed.

specs:

Pentium EE 955 (3.46 Ghz)
3 GB RAM (1x2GB and 2 x512)
2 SATA's, 1 IDE
9600GT
Foxconn 975x board.

thanks

More about : lags accessing ide disks

a c 127 G Storage
June 12, 2009 9:50:06 PM

Your disk is running in PIO mode, once you resolve this, your system should work normally again. PIO mode is used as 'fall back' is DMA fails, for example due to bad cable, HDD problem/timeout or HDD recovery procedure. Bad sectors also cause the disk to downgrade to PIO mode.

You should delete the PATA controller from device manager, and reboot. After rebooting, chances are that your system runs fine again.
June 13, 2009 6:37:03 AM

just tried that, no cigar. i'll check the cable, maybe swap it out, and run a diskcheck on it in the morning.
Related resources
a c 127 G Storage
June 13, 2009 7:51:54 AM

Well you can confirm very easily if you are running in PIO mode. Download HDTune and start a benchmark on your disk, after the benchmark finishes you should see CPU usage close to 100% (or 50% if you have dualcore, or 25% if you have quadcore). Normally this is not more than a couple of percent, but due to PIO mode your CPU is loaded to the max, and things like mouse movement will not be smooth anymore.

You should google om the PIO problem, as there can be several fixes to this issue. But first identify it, please.
a b G Storage
June 13, 2009 12:36:00 PM

Christ get rid of the old IDE drive, and get another SATA drive........
June 13, 2009 12:58:39 PM

??? Replace hardware in case of a probable driver installation issue ??? I wouldn't begin that way.
June 13, 2009 2:40:11 PM

ran HDtune and check my processors, showed one of my processors using almost 100%. I'll try swapping the cable and seeing if that will make a difference.
June 13, 2009 9:08:56 PM

swapped cables/dusted then i uninstalled the IDE controller and that seemed to have fixed it.
!