Sign in with
Sign up | Sign in
Your question

Optical drive DMA problem

Last response: in Storage
Share
June 14, 2009 9:11:29 PM

Following a problem with my old burner when it appeared to run very slowly, which I chalked up to being a dodgy unit, I upgraded to a bluray drive (Sony BDU-X10S) and I'm having transfer speed issues which (I think) are DMA/PIO related. To give some background, it takes ~1minute for My Computer to recognise the disc title (on any media type), it will read and transfer data but it is very slow. I’ve tried different SATA cables and different SATA ports on the mobo, the hard drive works fine in all ports. I’ve updated the (nvidia) chipset drivers and BIOS, got the latest firmware on the optical drive, and tried uninstalling the drive from device manager and starting again, all to no avail.

The BIOS is set to SATA, it recognises the device name properly and I've tried DMA in Auto and UDMA4 (what the drive should run at). Device Manager shows it as UDMA 4 and the "enable DMA" box is ticked initially, but when you select target id 1 is becomes greyed out (see screen dump below if that isnt clear!).



I've tried the standard tricks to enable DMA that are dotted about the internet (deleting the controllers from device manager and rebooting) but this has no effect. Given that I had the same issues with the previous drive it would seem unlikely that I have 2 duff units, albeit possible I suppose. Any ideas?

I borrowed a friends external USB2 bluray drive and the system plays them fine so that isn't an issue. Help!!
June 14, 2009 9:13:27 PM

Should also have said, OS is Vista 64 Home Premium and mobo is a Asus M2N68-VM.
!