Sign in with
Sign up | Sign in
Your question

Certain Folders on External HD "inaccessible, incorrect function"

Last response: in Storage
Share
June 19, 2009 7:55:19 PM

All -

Thanks in advance for the help. I tried Googling and searching the forums for an answer to this, but I can't seem to find any help.

I have a Dell laptop M1530 running Vista Home. I use a Maxtor Touch 300GB External HD where I store all of my songs, movies, etc. The other day, I tried to open one of my Music folders ("Unsorted") and got the error message "Unsorted is inaccessible, incorrect function". I tried safely removing the device and reattaching it. No luck. I tried restarting my computer. No luck. I tried changing the drive letter of the External HD. No luck.

I can still access other folders, but this one just has all of my unsorted music (it's pretty big, probably a few hundred files in there).

I tried to Check Disk (through Right Click, Properties, Tools), but it freezes after about an hour. I tried Defragging the drive, but that too freezes. I tried downloading one of the recovery programs from Cnet.com, but that froze as well.

So I started to transfer files to my laptop and delete them off the External HD. I was hoping to clear up some space and maybe that would somehow help the situation. It ended up making it worse and now I can't even open the Music folder (where my Unsorted folder lies within).

Anyone know what I can do to get my External HD working again? Some of these music files are from old CDs that I no longer know where they are so I really want to save the files.

a b G Storage
June 24, 2009 7:49:23 AM

Hi ksh937, is it possible to copy your entire drive to somewhere else? Maybe Windows will be able to read the files and copy it that way.

In any case, after try this, you should try chkdsk again. It sometimes really takes long, especially if your drive is having problems.
June 29, 2009 8:43:04 PM

Thanks for the response r. I wasn't able to copy the files anywhere. I have a friend who has a copy of the Geek Squad CD. He used it to "browse" for files on my External HD. We were able to see a bunch of the files, but we couldn't copy them anywhere.

It sounds like I have a partition issue with my External HD. Do you know what program would be good to deal with this?

Thanks!
!