Sign in with
Sign up | Sign in
Your question

After adding new SATA disk, windows will not boot

Last response: in Storage
Share
June 28, 2009 2:44:35 AM

Hey there everyone, new to the THG forums. Hopefully you guys can lend a hand with this perplexing issue I'm having =]
First of all, the obligatory system specs:
C2D e4300 @ 2.7 GHz (300x9)
2x1 GB OCZ DDR2-1150 RAM in dual channel
Gigabyte GA-965P-DS3 rev 3.3 mobo
eVGA 8800 GTS 640 MB
Creative X-Fi XtremeGamer
Antec TruePower Trio 550W
Lite-On DVDRW, IDE
3x250 GB WD HDD's, 2 in RAID-0 on the mobo's jmicron controller. The other has the OS on it, which is Win XP Pro SP3 (and is connected to the southbridge's SATA controller)

Also it's probably worth noting that I'm using a hacked intel chipset driver. My board comes with the ICH8 southbridge, which supports native SATA, AHCI mode for disks in-hardware (as opposed to IDE emulation), but for some reason it is disabled in intel's official driver. So I took the liberty of installing a hacked driver that enables this support. The system has been running for nearly 2 years this way without issue, so I'd be surprised if this is the cause of this new problem but who knows. Also, this thread here details what I'm talking about: http://kerneltrap.org/node/7582

OK, now onto the issue I'm having:
I have a couple of old SATA Maxtor DiamondMax 9 80 GB drives I'd like to add to my system. I've had these disks for a while; they were in an older Athlon XP box I had, and worked fine. After adding one of them to my current box, on the southbridge SATA controller, I can't get windows to boot. If I disconnect the drive again, it boots.
Basically, with the new disk added, the system POSTs, recognises the new disk, RAID BIOS runs fine, and then I get a blank, black screen.
I tried booting into Knoppix (from CD) and it had no problem reading the disk (which has already been formatted to NTFS).

Sorry for the verbose-ness of this post. If anyone can help I'd appreciate it.
June 28, 2009 4:26:22 PM

It's an old suggestion and I'm sure you've done it already but check the boot order, maybe that drive has priority somehow (unlikely as sata works by the port numbering but worth a check). P.S. I've had like 7 of those DiamondMax drives and none has failed yet, rather reliable.
!