Sign in with
Sign up | Sign in
Your question

Strange Belkin wireless problem...

Last response: in Wireless Networking
Share
June 3, 2009 9:51:08 PM

Hi, Ive searched these forums, but cant find any solution.

I have a Belkin F5D7630 wireless router. If I set the router to have no security, and enable ESSID boardcast, then it works on my Vista laptop perfectly. However:

1) When I add some security, it does not work. I set up a WPA-PSK. On my Vista laptop, I add the type (WPA-Personal), encryption type, and the security key. On the "connect to a network" screen, it says "Security enabled network", with a strong signal. When I try and connect, it does not work however. Im trying a super simple password, so its not a case of mistyping.

2) If I disable ESSID broadcast, then it wont connect either. I have the correct SSID written down. This part is the most fustrating thing. Its surely just a simple case of getting the SSID name on both laptop and router. There shouldnt be much making this not happen, right?


The fact that it connects when these two options are not being used obviously means theres nothing wrong with the signal. Cant find an answer for it anywhere. Is it just a case of not being compatible with Vista? I know its a pretty old router. Any help would be appreciated greatly! What Vista settings could be preventing these two actions?
Anonymous
a b 8 Security
June 4, 2009 11:55:42 AM

There's not much point in disabling SSID as it may just make detection harder for your adapter while still showing up in hackers' toolkits.

There are terminology issues with Vista (they seem to have followed Apple's vague definitions for different encryption standards).

Sounds like you have selected the right one, though. Try WEP just to see what happens -- but it's not very secure.

Also try a firmware update for the Belkin and the wireless adapter.
m
0
l
June 6, 2009 11:30:49 AM

Thanks for the reply. WEP worked fine. Ive updated the firmware. It just wont work with WAP. Annoying.

Ive tried lots of different things, and none of them work. If I bought a USB wireless adapter, would it work then? Do you think this is a problem with the router, or Vista, or the actual network card? Would a USB adapter solve the problem?
m
0
l
Related resources
Anonymous
a b 8 Security
June 6, 2009 3:39:52 PM

Assuming the laptop came with Vista, it's recent. Is the router an older model that doesn't support WPA ?
m
0
l
June 6, 2009 10:10:52 PM

WPA is an option when I access the routers config page through a web browser (http://192...), so it must be usable.
m
0
l
Anonymous
a b 8 Security
June 7, 2009 5:53:02 AM

The router must be the prime suspect so buying a USB is unlikely to help. Try updating driver for laptop wireless adapter and firmware on router.
m
0
l
!